Author Topic: Remove HTTPS for YouTube embed  (Read 1541 times)

congusbongus (OP)

  • *
  • Posts: 74
    • congusbongusgames
Remove HTTPS for YouTube embed
« on: February 25, 2015, 08:59:58 am »
Sometimes when copy/pasting YouTube URLs for embedding, the URL uses the HTTPS protocol. The embed doesn't work in this case, but it is trivially worked around by changing it to plain HTTP:

https://www.youtube.com/watch?v=KrL03milBMA
#Invalid YouTube Link#

http://www.youtube.com/watch?v=KrL03milBMA
<a href="http://www.youtube.com/watch?v=KrL03milBMA" target="_blank">http://www.youtube.com/watch?v=KrL03milBMA</a>

Although this is a simple workaround, it is also non-obvious, so it would be better if the forum software could do this for you.

pcercuei

  • ***
  • Posts: 1397
    • GitHub
Re: Remove HTTPS for YouTube embed
« Reply #1 on: February 25, 2015, 09:22:52 am »
And it would also be better if it was embedding HTML5 videos instead of using Flash  ???

omgmog

  • * Administrator
  • Doesn't sleep.
  • Posts: 717
    • omgmog.net
Re: Remove HTTPS for YouTube embed
« Reply #2 on: March 04, 2015, 08:11:45 am »
Yeah the YouTube plugin we're using is probably a bit old now, so could do with some updates. I'll see what I can do...

omgmog

  • * Administrator
  • Doesn't sleep.
  • Posts: 717
    • omgmog.net
Re: Remove HTTPS for YouTube embed
« Reply #3 on: March 04, 2015, 07:08:44 pm »
Alright I've modified the youtube BBCode to allow https, and to use the iframe embed (so we get HTML5 video)  8)

#Invalid YouTube Link#

 

Post a new topic