Author Topic: Super Mario Karts  (Read 2593 times)

maj

  • Guest
Super Mario Karts
« on: December 17, 2011, 06:33:49 pm »
Got a letcool and can't run super mario karts for snes do i need to update the letcool (haven't updated yet)

bamboori

  • Posts: 661
Re: Super Mario Karts
« Reply #1 on: December 24, 2011, 06:44:51 pm »
jfyi: no current letcool firmware supports super mario kart
Handhelds:
Powkiddy V90, FC3000, X2, LDK vertical, PMP IV, RS-90...

maj

  • Guest
Re: Super Mario Karts
« Reply #2 on: December 25, 2011, 12:14:13 pm »
:(