• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: UAE4ALL (Amiga emulator) smooth scrolls with good sound?  (Read 1145 times)

Elaphe666 (OP)

  • Posts: 18
UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« on: November 06, 2020, 09:04:17 pm »
I've been trying several games and the only way to get perfectly smooth scrolls is with frameskip 0. However, then the sound is skippy and that's specially noticiable in the musics, which sound terribly bad. With frameskip auto, the sound and the music are fine, but the scrolls are not smooth. Trying different settings of throttle, scrolls seem to improve a little, but no way, they are never butter smooth like with frameskip 0. I suppose this is due to the fact that the emulator tries to run the games at 50hz, whilest the screen of the console is at 60hz. However, if I remember well, with the Windows version of the emulator, I can run the games perfectly smooth at 60 hz (obviously a little faster than they are supposed to run) and at the same time the sounds and the music are fine (just a little accelerated). Can't this be achieved with the port of the emulator to the RG350?

goldmojo

  • Posts: 60
Re: UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« Reply #1 on: November 07, 2020, 01:48:21 pm »
Hello @Elaphe666

I can confirm that UAE4ALL automatically switch to PAL mode, it is hard coded.
I tried to activate NTSC but it implies too many changes.

I executed some profiling during compilation (thanks to discord users).

You can get this latest release here:
https://github.com/goldmojo/uae4all/releases/tag/Release-1-params-20201107

Could you confirm that you also feel some improvement ?

PS : I also added a dedicated binary has been created with UI only (will not work in simplemenu or other front-end).
« Last Edit: November 08, 2020, 11:58:46 am by goldmojo »

Elaphe666 (OP)

  • Posts: 18
Re: UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« Reply #2 on: November 07, 2020, 08:38:48 pm »
Exactly the same results. With frameskip 0, the scrolls are butter smooth, but the music in the games, instead of accelerate like the rest of the game, sounds corrupted with continuous interruptions.

goldmojo

  • Posts: 60
Re: UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« Reply #3 on: November 11, 2020, 11:22:12 am »
Hello @Elaphe666

If interested in BETA stuff, I just compiled UAE4ALL on OD BETA FW and platform games now run nicely without sound issue.

You can get it here: https://github.com/goldmojo/uae4all/releases/tag/Release-1-params-20201111-r2

==> Be careful, this will ONLY run on BETA firmware ! <==
« Last Edit: November 11, 2020, 03:33:33 pm by goldmojo »

Elaphe666 (OP)

  • Posts: 18
Re: UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« Reply #4 on: November 11, 2020, 08:03:21 pm »
I don't know what you mean. I have the Rogue firmware installed.

elea

  • Posts: 63
Re: UAE4ALL (Amiga emulator) smooth scrolls with good sound?
« Reply #5 on: November 12, 2020, 03:02:05 pm »
Beta OD firmware:

https://zcrc.me/opendingux/2020/10/13/we-have-nighties.html

Here are the update files - choose the GCW0 OPK: http://od.abstraction.se/opendingux/latest/

You can run it overtop Rogue or Stock. Backup your files first! Better yet, run it on a different OS SD card.

Here are some other emulators that are compatible with beta FW:

https://gitlab.com/gameblabla/gameblabla-releases/-/tree/master/opk/gcw0




 

Post a new topic
Post a new topic