Author Topic: Here is how to enable dual analog in Quake 1-2 and Hexen II  (Read 1703 times)

Anubys (OP)

  • Posts: 30
Here is how to enable dual analog in Quake 1-2 and Hexen II
« on: December 22, 2019, 05:05:07 pm »
So Quake 1-2 and Hexen II ports do not support the right analog stick by default, but here is a workaround for that.
You will need to press POWER + B (yes, the power on button) to enable right stick's mouse mode. Now you will be able to use the right stick as a mouse.
Start the game you want to play, and map walk forward, backward to the left analog stick up / down, and map strafe left / right to the left analog stick left and right.
If needed, adjust mouse sensitivity (the maximum sensitivity works the best for me), and turn on "freelook" or "mouse look" if disabled.
Enjoy your game with dual analog.   :)
You will need to switch on mouse mode (by pressing POWER + B) each time you reboot your device!

EDIT: On the newest Rogue firmware (1.7.9.1) the button combination seems to be POWER + L1 to enable mouse on the right stick and then POWER + B to enable the left stick, otherwise it would not work to map walk on that stick.

EDIT2: from Rouge 1.7.9.5 (or maybe from earlier verions) use POWER + B and POWER + R1 to enable both looking on the right stick and walking on the left stick.
« Last Edit: January 31, 2020, 09:21:43 pm by Anubys »

Vilkata

  • Posts: 7
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #1 on: December 25, 2019, 02:41:41 am »
Thanks that's so much better for Quake.

By the way you actually got Hexen 2 running? How'd you manage that? Putting the files in the suggested directory shown on the list here has had no effect for me.

Anubys (OP)

  • Posts: 30
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #2 on: December 25, 2019, 12:04:28 pm »
Yes, it works fine for me. Here in this thread I wrote down everything about Hexen II and Rise of the Triad, which I see you have problem with too.

https://boards.dingoonity.org/retro-game-350rg-350/all-the-paths-for-additional-files-of-games/

Vilkata

  • Posts: 7
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #3 on: December 25, 2019, 09:38:06 pm »
Hey thanks a lot! That got Rise of the Triad going, but nothing changed with Hexen 2.

I did some more digging and figured it out though. Turns out it will only run with Hexen 2 files patched to 1.11. Earlier versions just wouldn't start at all.

Now I just have to figure out why there's no sound in Heretic and I'm all set!

Thanks again and Merry Christmas

thekojac

  • Posts: 1
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #4 on: January 09, 2020, 04:30:02 am »
I can't for the life of me get mouse mode to work in Quake or Quake 2.  Hitting Power + B seems to do absolutely nothing.   I'm running the latest 1.5 firmware.  I just re-flashed my firmware to see if that would help and nothing.

Any suggestions? 

beamquaker

  • Posts: 3
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #5 on: January 09, 2020, 08:50:10 am »
I pressed power plus l1 then power plus l2. This got it working for me. You have to do that every time you want to play it. Good luck

RowleyBirkinQC

  • Posts: 16
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #6 on: January 27, 2020, 04:04:12 am »
I can get the mouse working but the mouse speed is so slow its unplayable, has anyone else seen this issue? Seems to do the same for Duke 3D with forward movement.

Anubys (OP)

  • Posts: 30
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #7 on: January 27, 2020, 11:20:28 pm »
I can get the mouse working but the mouse speed is so slow its unplayable, has anyone else seen this issue? Seems to do the same for Duke 3D with forward movement.

Which game? In Quake 1-2 and Hexen II you are able to set mouse sensitivity, just set it to maximum, it should be just fine.
As for Duke 3D, don't enable mouse support, as it supports dual joystick, but you will need to use the patched config file. Check out this thread:
https://boards.dingoonity.org/retro-game-350rg-350/all-the-paths-for-additional-files-of-games/

djfjaapie

  • Posts: 1
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #8 on: January 28, 2020, 06:20:45 am »
I can get the mouse working but the mouse speed is so slow its unplayable, has anyone else seen this issue? Seems to do the same for Duke 3D with forward movement.


It's possible to change the mouse speed in the user.cfg. You can edit this on your computer or open up 'glutexto' in the applications menu, browse to .local/share/Thenesis/Quake2/baseq2 select user.cfg.

Search for the lines named; set mouse_speed_pitch and mouse_speed_yaw default value is 0.022 i've changed it to 0.11 and now it's perfectly playable

RowleyBirkinQC

  • Posts: 16
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #9 on: January 28, 2020, 04:59:08 pm »
Thanks guys. Testing the Duke3D fix now. It is mainly Quake and Hexen 2 I am having issues with now, for some reason Quake 2 was fine straight off the bat.

Issue with Quake and Hexen 2 both seem to be the same with extremely slow mouse movement with sensitivity turned up full.
« Last Edit: January 28, 2020, 06:07:52 pm by RowleyBirkinQC »

Kalamer

  • Posts: 2
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #10 on: January 31, 2020, 12:32:40 am »
i got the right stick working but i cant map anything to the left stick? using latest rogue firmware

Anubys (OP)

  • Posts: 30
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #11 on: January 31, 2020, 09:20:26 pm »
i got the right stick working but i cant map anything to the left stick? using latest rogue firmware

It looks they have changed it again. Now it's POWER + B and POWER + R1 to enable both looking on the right stick and walking on the left stick (note: you may need to map the movement in the controls option)

Kalamer

  • Posts: 2
Re: Here is how to enable dual analog in Quake 1-2 and Hexen II
« Reply #12 on: January 31, 2020, 11:07:28 pm »
thank you so much! both sticks work now

 

Post a new topic