Author Topic: Atari800 4.1.0  (Read 3655 times)

Shanti777 (OP)

  • Posts: 23
Atari800 4.1.0
« on: December 12, 2019, 08:37:31 pm »
I compile Atari800 emu for RG-350. This is my first build, some menu options don't work properly and there is no virtual keyboard. Some settings can be made in the .atari800.cfg configuration file, e.g. enabling NTSC mode.

Version 1.3f: (20.03.2020)
- fix keys for  PocketGOv2 (L2/R2/MENU)

Version 1.3
- virtual keyboard work also in a5200

Version 1.2:
- virtual keyboard work also in menu
-------
Version 1.1:
- add virtual keyboard
- some keys change
- default path to ->  roms /media/sdcard/ROMS/atari800
- default path to _>  save /media/sdcard/ROMS/save

-----

Better colors:
Display_Settings->Color_preset->Vibrant

More RAM for some games:
System_Settings->RAM_size->...

Save config:
Emulator_Configuration->Save_Cconfiguration_file

-----

Keys in Emu:
SELECT = menu on
L1 = BACK
Y,A = ENTER
R3 (Press Right Analog) = SPACE BAR  (PocketGOv2 -> R2)
R1 = BACKSPACE
DPAD = choose option
R2 = Virtual Keyboard ON/OFF  (PocketGOv2 -> MENU)

Keys in Atari800:
L1 = SELECT
L2 = OPTION 
START = START
R1 = BACKSPACE
R3 = SPACE BAR   (PocketGOv2 -> R2)
Y = ENTER
R2 = Virtual Keyboard ON/OFF  (PocketGOv2 -> MENU)
B = SHIFT
X = joystick UP

Keys in Atari5200:
L2 = Pause
START = START
R2 = Virtual Keyboard ON/OFF  (PocketGOv2 -> MENU)
X = joystick UP
A = Fire
B = Second Fire
Y = *

Virtual Keyboard
A = Press Key
START = Set keyboard Top/Bottom
B = SHIFT
X = CONTROL
DPAD = choose key


Joystick:
A = FIRE
B = Second Fire in Atari5200
X = Joy Up (jump for some game like Crownland)
DPAD or LEFT ANALOG

OPK:
https://atariage.com/forums/applications/core/interface/file/attachment.php?id=711519

Atari Games:
http://atarionline.pl/v01/index.php?ct=katalog
http://a8.fandal.cz/games.php
« Last Edit: March 20, 2020, 12:40:27 pm by Shanti777 »

TheReaperUK

  • Posts: 62
Re: Atari800 4.1.0
« Reply #1 on: December 14, 2019, 05:34:58 pm »
This works really well, Most games i have tested worked and played great, sound is also working great, in the past i've tested Atari 800 emulators on other handhelds and most have sound issues and most games just don't work.

The only real problem was lack of virtual keyboard, i have some games i like to play but you need to enter numbers to start the game, which is a bit of a problem, other then that all works greats, And thanks for the Port.
Lots of Handhelds but my favourite is still my GCW Zero and also RG-350, But the RG-300 is 2nd Best.

Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #2 on: December 18, 2019, 08:14:02 pm »
I add virtual keyboard.

TheReaperUK

  • Posts: 62
Re: Atari800 4.1.0
« Reply #3 on: December 19, 2019, 11:36:10 am »
Thanks very much, Awesome now with working virtual kryboard, The Emulator is very much complete now ;D
Lots of Handhelds but my favourite is still my GCW Zero and also RG-350, But the RG-300 is 2nd Best.

Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #4 on: December 19, 2019, 02:20:41 pm »
Code: [Select]
Fast fix , keys SELECT pressed also TAB and OPTION pressed also F1, now SELECT and OPTION don't press any other keys.
----
I think I mixed up something, now it should be ok, for the difference I changed the version to 1.1
« Last Edit: December 19, 2019, 04:37:35 pm by Shanti777 »

npaladin2000

  • Posts: 46
Re: Atari800 4.1.0
« Reply #5 on: December 19, 2019, 10:18:27 pm »
Can this accept a rom as a command line parameter so we can launch directly from the launcher menu's ROM selector?
Join the RetroGameHandhelds Discord: https://discord.gg/p4uRmCd

Partitipate in the RetroGameHandhelds GitHub, Wikis and FAQs: https://github.com/retrogamehandheld

Recce

  • Posts: 58
Re: Atari800 4.1.0
« Reply #6 on: December 20, 2019, 02:45:36 am »
Thanks for the great effort!

Are you able to incorporate a readme with the key descriptions into the opk? It will be easier as we can then view it on the device.

Stouffa

  • Posts: 106
Re: Atari800 4.1.0
« Reply #7 on: December 23, 2019, 08:32:05 pm »
I can't start this emulator any more since I upgraded to the newest firmware (it may have been before this, there's been quite a few upgrades with that recently). Has anyone experienced any issues lately like that?

Sent from my F8331 using Tapatalk


Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #8 on: December 23, 2019, 09:00:48 pm »
What happens when you try to run? What's your firmware?  Maybe try unpack .opk to sdcard and run ( add link with Select to atari800).

Stouffa

  • Posts: 106
Re: Atari800 4.1.0
« Reply #9 on: December 23, 2019, 09:23:26 pm »
I'm now on the newest version of the rogue firmware(1.7.9.2). When I try run the emulator it simply crashes back to the selector menu (not the Atari one). Sometimes I can get a glimpse of what looks like an error message before it goes back, but it goes by so fast I can't read anything). Is there a way of accessing an error or user log? Also, how do I unpack an opk?

Sent from my F8331 using Tapatalk


Stouffa

  • Posts: 106
Re: Atari800 4.1.0
« Reply #10 on: December 23, 2019, 09:24:38 pm »
Also I've not tried this newest update, maybe that might help things?

Sent from my F8331 using Tapatalk


Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #11 on: December 23, 2019, 10:16:16 pm »
7zip can unpack .opk

Stouffa

  • Posts: 106
Re: Atari800 4.1.0
« Reply #12 on: December 23, 2019, 11:05:40 pm »
Looks like it's a firmware issue, I could read error messages about missing libraries, so I rolled the firmware back to the original and Atari 800 is working again!

Sent from my F8331 using Tapatalk


Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #13 on: February 13, 2020, 09:05:54 pm »
I add new version.

SeongGino

  • Posts: 53
    • Twitter!
Re: Atari800 4.1.0
« Reply #14 on: February 14, 2020, 05:08:18 pm »
Code: [Select]
./atari800: can't load library 'libncurses.so.5'Firmware based off stock.
These files can be found in Rogue, but NOT in Stock; there, we have
Code: [Select]
libncursesw.so
libncursesw.so.6
libncursesw.so.6.1
And because the root filesystem is read-only, I can't change this to test if it works through symlinking.

If you could change that and make a stock-based release instead, that would be nice for us that don't (want to) use Rogue.
« Last Edit: February 14, 2020, 05:17:25 pm by SeongGino »
It's just your average Seong.

Please contribute to the (un)official Dingux repository, to protect the life cycle of our favorite handheld platform! https://github.com/SeongGino/RetroGame350-AppRepo

Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #15 on: February 14, 2020, 06:03:53 pm »
I use stock firmware ver 1.7 not Rogue.


I use GCW Zero Toolchain http://www.gcw-zero.com/develop , Virtual Machine and mini ubuntu.
Unfortunately, after reinstalling windows to the ssd drive, I did not restore the environment to build under RG350, by the way deleted the latest sources Atari800 (1.2). I only have a copy of version 1.1.
« Last Edit: February 14, 2020, 06:27:07 pm by Shanti777 »

SeongGino

  • Posts: 53
    • Twitter!
Re: Atari800 4.1.0
« Reply #16 on: February 14, 2020, 06:50:33 pm »
Stock firmware doesn't have a '1.7' - it's only gone up to 1.5.1 (with an optional 1.5.2 hotfix, which I'm using). If you are using a '1.7', then I'm afraid you've been misinformed because that's Rogue.

I didn't mean to sound accusatory or anything; I just wanted to note that it's unusable for me, and might be for a majority of users that also use Tony's images.
It's just your average Seong.

Please contribute to the (un)official Dingux repository, to protect the life cycle of our favorite handheld platform! https://github.com/SeongGino/RetroGame350-AppRepo

Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #17 on: February 14, 2020, 07:10:05 pm »
https://www.reddit.com/r/RG350/comments/e24122/rg350_17_firmware_being_rolled_back_stick_with_15/

Also I had a problem with 1.7 after installing it on my card, emulators got stuck. However, I installed them again on the sd card which was originally in rg350 and problems with jams disappeared. I use this software all the time and everything works fine.


SeongGino

  • Posts: 53
    • Twitter!
Re: Atari800 4.1.0
« Reply #18 on: February 14, 2020, 07:15:06 pm »
I'd highly suggest that you switch to 1.5 anyways, since it's better-representative of the demographic that actually uses this device so the libraries used are at least consistent.

There, you'd notice how A800 here doesn't boot on anything that isn't Rogue.
It's just your average Seong.

Please contribute to the (un)official Dingux repository, to protect the life cycle of our favorite handheld platform! https://github.com/SeongGino/RetroGame350-AppRepo

Shanti777 (OP)

  • Posts: 23
Re: Atari800 4.1.0
« Reply #19 on: February 14, 2020, 07:37:49 pm »
...

« Last Edit: February 16, 2020, 09:29:04 pm by Shanti777 »