• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: My try at reverse engineering Powkiddy X2  (Read 335 times)

ccatalin (OP)

  • Posts: 1
My try at reverse engineering Powkiddy X2
« on: September 20, 2021, 01:02:27 pm »
I have bit the bullet and bought a Powkiddy X2, the device has a moderate moderate quality but the big screen and the 2 joysticks seems to make it worth.

My intention is to add ScummVM to it but it is a closed system so a custom firmware would be the only choice.
My ideea is to read the current firmware, if it is a linux image the it would be relatively easy to add new emulators and then flash it back.

Seeing that ithere is not much info on the hardware I have opened it up and found a RK3128 device, see attached pictures.
Also there is a small button on the main board and a serial header.

I have read about the similarities between x2 and a12/a13 and tried to use the same method. So the first step was to connect the left controller usb to PC and power on while holding the small button on the mobo pressed.

The rockcip driver recognized the device as:

List of rockusb connected
DevNo=1 Vid=0x2207,Pid=0x310c,Layer=2-8 Maskrom
Found 1 rockusb,Select input DevNo,Rescan press <R>,Quit press <Q>:1

And then I ran into an issue, AndroidTool_Console seems to fail any command given

Rockusb>RL 0x0 0xffffffff
Error:Read LBA failed!
Read capability Fail!
Read flash ID Fail!
Read flash Info Fail!
Read Chip Info Fail!
Rockusb>RL 0x0 0xffffffff test.img
Error:Read LBA failed!

After some more reading there seems to be an issue with Rockchip driver newer that 4.3(I had 5.11) so tried with 4.3, same error.

Does someone know why these commands fail? Any info would be greatly appreciated.


« Last Edit: September 20, 2021, 01:05:30 pm by ccatalin »


Post a new topic
Post a new topic