Author Topic: JXD S192K Firmware  (Read 243 times)

porter214 (OP)

JXD S192K Firmware
« on: August 12, 2017, 06:07:18 pm »
So basically i recieved my brand new s192k 2 weeks ago from jxd for my sons birthday, and i was installing applications on it and tried to do some cwm /twrp stuff to try and get remote play working for ps4 and ive ended up bricking it pretty much. When i have it in android tool/ rockchip batch tool it says found one maskrom device, and i cant get anything on the screen.

Skelton has been helping out and trying to find solutions but so far i have had no luck, as JXD wont send me the firmware file for the s192k and with it not being anywhere on the internet, im pretty stuffed at the moment !!

Would someone with the same device be able to try and backup there firmware and send the image file to me? i dont know if it would work but im kind of desperate now and need to get it working!
thanks guys!

skelton

  • *****
  • Posts: 6294
Re: JXD S192K Firmware
« Reply #1 on: August 14, 2017, 11:44:21 am »
I tried to contact them and also chat with them but no response at all (they just told me they would contact their engineer (LOL). My guess they hired someone to make the firmware for them and they don't even have it at hand. If someone has a working device maybe they can backup it for you using this:

http://freaktab.com/forum/development-area/rom-hacks-and-mods-development/10570-backing-up-your-rk-device-rom-with-the-new-rk-2-1-tool

Is the only thing that comes to my mind to recover it, but you need someone to make a backup for you.

If your device is a maskROM is a bad sign. When you connect it to BatchTool which colour do you get?
pink? Blue? Green? If it's blue I am afraid you would need to shortcircuit nand to get bootloader mode enabled.



« Last Edit: August 14, 2017, 11:49:55 am by skelton »
Retired

porter214 (OP)

Re: JXD S192K Firmware
« Reply #2 on: August 14, 2017, 05:06:58 pm »
Oh dear it just gets worse , i can confirm i get a blue sign lol
Jxd had the cheek to ask me to charge it fully ....

Web8bits

  • *
  • Posts: 37
    • GPD, JXD and Hyperkin distributor in Spain
Re: JXD S192K Firmware
« Reply #3 on: August 17, 2017, 08:38:29 am »
Hi Porter

The last available firmware for S192K solves the controllers bugs, and others bugs, you can download it from here:

https://drive.google.com/uc?id=0B_MwGd121hXdbkZMNDA5WGlNeG8&export=download

Hope this help you

Regards