• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: CFW RG280V - RG280M "ROGUE"  (Read 4655 times)

Ninoh-FOX (OP)

  • Posts: 128
CFW RG280V - RG280M "ROGUE"
« on: December 04, 2020, 09:45:34 am »


https://github.com/Ninoh-FOX/RG280M-ROGUE-CFW/releases/download/v1.7.10/sd_image.bin

https://github.com/Ninoh-FOX/RG280M-ROGUE-CFW/releases/download/v1.7.14/rg280m-update-1.7.14-2021-03-16.opk


https://github.com/Ninoh-FOX/RG280V_ROGUE/releases/download/v1.7.10u17/sd_image.bin

https://github.com/Ninoh-FOX/RG280V_ROGUE/releases/download/v1.7.14/rg280v-update-1.7.14-2021-03-16.opk

Same feactures that RG350, but in this WORK all screen resolutions.

Steps for install the cfw.

First download the sd_image.bin and burn with balena in a new micro sdcard (better sandisk 16gb higt speed)

The next step, when finish all instalation prosses in the console, is download the last update package and update the console.

-----------------------------------------------

new update, I hope it is the last in the current version.

fix rumble weak "motor"

add rg280v hardware tester program



apart from now having lower brightness levels, now the changes in the aspect ratio and sharpness are saved, so that even if you turn off the console you will not have to adjust it again, apart from that you can also change the sharpness in the gmenu2x menu, I have never changed it, but users send












« Last Edit: April 07, 2021, 06:33:05 am by Ninoh-FOX »

dezign999

  • Posts: 11
Re: CFW RG280V "ROGUE"
« Reply #1 on: December 05, 2020, 05:02:18 pm »
Works great, thanks so much! Just did the minor update as well which addresses the IPU resolutions. All my emulators are working great now, with the exception of Handy - its just a black screen on launch and requires a hard reset to exit.

Edit - Sorry, updated my Handy320 OPK and its working fine now :)
« Last Edit: December 05, 2020, 05:18:20 pm by dezign999 »

gameblabla

  • Posts: 1446
Re: CFW RG280V "ROGUE"
« Reply #2 on: December 05, 2020, 07:20:05 pm »
Works great, thanks so much! Just did the minor update as well which addresses the IPU resolutions. All my emulators are working great now, with the exception of Handy - its just a black screen on launch and requires a hard reset to exit.

Most likely you used my Handy port, that tries to set a resolution of 160x112, the atari lynx native resolution plus 10 extra vertical pixels. (due to an issue with the IPU implementation in the beta FW)
This fails, as it's not among the resolutions he hardcoded.
https://github.com/Ninoh-FOX/RG280_kernel/commit/10f9475f425b9bb52f671ca747a3942557714aeb

I hate to be negative but i fail to see the point of Rogue CFW over say, the beta firmware. Might be still useful to run some stuff that wasn't updated for beta like Tac08 but that's about it. (I would love for him to eventually work on adding PGO2 support to the Linux 5.10 kernel or perhaps rebase Rogue upon that)

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #3 on: December 05, 2020, 11:39:03 pm »
Works great, thanks so much! Just did the minor update as well which addresses the IPU resolutions. All my emulators are working great now, with the exception of Handy - its just a black screen on launch and requires a hard reset to exit.

Edit - Sorry, updated my Handy320 OPK and its working fine now :)

fixed in the last update (see the link)

new update (u11 for rootfs and u13 for kernel) enjoy.
« Last Edit: December 21, 2020, 05:24:54 pm by Ninoh-FOX »

whd6545

  • Posts: 2
Re: CFW RG280V "ROGUE"
« Reply #4 on: December 28, 2020, 01:23:29 am »
Thank you very much.
Works great, but I have a question in GBA
After updating u11, GBA had the best screen ratio and performance on hardware scale
After updating u12, it will be executed in full screen and frame drop will occur
Currently it does not solve the problem that has progressed to u14
Could you check what the problem is?

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #5 on: January 03, 2021, 09:37:36 am »
Thank you very much.
Works great, but I have a question in GBA
After updating u11, GBA had the best screen ratio and performance on hardware scale
After updating u12, it will be executed in full screen and frame drop will occur
Currently it does not solve the problem that has progressed to u14
Could you check what the problem is?

this is strange, because you can change the screen ratio if you push the power+a buttons.


Golden Sun 2 to 59/59 fps
« Last Edit: January 03, 2021, 09:59:18 am by Ninoh-FOX »

whd6545

  • Posts: 2
Re: CFW RG280V "ROGUE"
« Reply #6 on: January 03, 2021, 10:58:23 am »
Thank you very much.
Works great, but I have a question in GBA
After updating u11, GBA had the best screen ratio and performance on hardware scale
After updating u12, it will be executed in full screen and frame drop will occur
Currently it does not solve the problem that has progressed to u14
Could you check what the problem is?

this is strange, because you can change the screen ratio if you push the power+a buttons.


Golden Sun 2 to 59/59 fps

Thank you!
I don't know if there is a resolution change function..
Change the resolution with the POWER+A key and run at full speed!!

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #7 on: January 06, 2021, 07:47:40 pm »
https://github.com/Ninoh-FOX/RG280V_ROGUE/releases/download/v1.7.10u16/rg280v-update-1.7.10u16-2021-01-06.opk

new update, I hope it is the last in the current version.

apart from now having lower brightness levels, now the changes in the aspect ratio and sharpness are saved, so that even if you turn off the console you will not have to adjust it again, apart from that you can also change the sharpness in the gmenu2x menu, I have never changed it, but users send

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #8 on: January 10, 2021, 08:29:28 am »
https://github.com/Ninoh-FOX/RG280V_ROGUE/releases/tag/v1.7.10u17

updated alsalib to version 1.2.4
updated alsamixer to version 1.1.7
add libpng 16 from OD
fixed sound mute level in pcm
fixed sound crashes in some emulators (you have to delete the old temper settings from the folder /usr/local/home/.temper/config/)
updated Picodrive emulator to 1.97 https://github.com/irixxxx/picodrive
recompiled Temper 1.24.2 https://github.com/gameblabla/temper/tree/f3328369d5e00e70b9c2ea095e09b1dec6452de5
updated pr-boom+ to OD-pr-boom+


konyfero

  • Posts: 4
Re: CFW RG280V "ROGUE"
« Reply #9 on: January 10, 2021, 09:32:22 pm »
With the latest update my sdcard appears under /media/mmcblk1p5 mountpoint. Not in /media/sdcard/. I have reinstalled from clean update17 sd_image.bin with the same result. I'm switching back to u16.

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #10 on: January 11, 2021, 02:42:41 am »
With the latest update my sdcard appears under /media/mmcblk1p5 mountpoint. Not in /media/sdcard/. I have reinstalled from clean update17 sd_image.bin with the same result. I'm switching back to u16.

This is only is possible if you slot2 sdcard has more of 5 partitions, I go to see this anyway when I am finish in the work in the next week.

Anyway, I am download the sd_imagen.bin, flashed this in a new sdcard and all work fine.
« Last Edit: January 11, 2021, 02:57:00 am by Ninoh-FOX »

konyfero

  • Posts: 4
Re: CFW RG280V "ROGUE"
« Reply #11 on: January 11, 2021, 01:04:13 pm »
I'm so sorry, it's my card. It's weird... i have checked and it's MBR with only one FAT32 primary partition.

EDIT: Reformatted with SDA Formatter and now is mounting in /media/sdcard. Sorry for the inconveniences.
« Last Edit: January 11, 2021, 01:34:35 pm by konyfero »

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V "ROGUE"
« Reply #12 on: February 04, 2021, 09:57:39 pm »
new update!!

Ninoh-FOX (OP)

  • Posts: 128
« Last Edit: February 23, 2021, 10:07:06 am by Ninoh-FOX »

Kamjin

  • Posts: 8
Re: CFW RG280V - RG280M "ROGUE"
« Reply #14 on: February 25, 2021, 04:44:08 pm »
Ninoh-FOX, Thank you for the work that you are doing!

I have 2 issues, and both are related to the clock speed. I hope someone would be able to help..

My 280V has audio problem when the CPU is clocked at 1080Mhz..
My RG350M is completely unstable at 1080Mhz.. it even has a lot of trouble performing the install, I need to cool down the 350M and then it takes about 10-12 tries to install w/o a crash or corruption to the SD card.. both work without issues on the stock firmware and beta..

Is is possible to have a version of Rogue  that use the same clocks as the original firmware?  or some way to modify the clocks in the install image?

Also the clock setting in the GXMenu don't work properly, if you change the clock on any app.. to anything less than 1080Mhz the actual drop is speed most likely very much lower that what is displayed..

for example if I try to lower the clock (both the 350M & 280V) form 1080Mhz to even 1069Mhz using pcsx4all (crash bandicoot 3 as a test)  will go from 80% CPU at 60FPS  to 100% CPU at 40-50FPS..






Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V - RG280M "ROGUE"
« Reply #15 on: February 26, 2021, 06:46:13 am »
Ninoh-FOX, Thank you for the work that you are doing!

I have 2 issues, and both are related to the clock speed. I hope someone would be able to help..

My 280V has audio problem when the CPU is clocked at 1080Mhz..
My RG350M is completely unstable at 1080Mhz.. it even has a lot of trouble performing the install, I need to cool down the 350M and then it takes about 10-12 tries to install w/o a crash or corruption to the SD card.. both work without issues on the stock firmware and beta..

Is is possible to have a version of Rogue  that use the same clocks as the original firmware?  or some way to modify the clocks in the install image?

Also the clock setting in the GXMenu don't work properly, if you change the clock on any app.. to anything less than 1080Mhz the actual drop is speed most likely very much lower that what is displayed..

for example if I try to lower the clock (both the 350M & 280V) form 1080Mhz to even 1069Mhz using pcsx4all (crash bandicoot 3 as a test)  will go from 80% CPU at 60FPS  to 100% CPU at 40-50FPS..

I can try make a ROGUE version witout overclock, but, a part, not is possible change the clock to 1069Mhz... I don't know how you are use the system.

with kernel 3.12 it is only possible maximum or minimum clock, that is to say 1080 or 360, if you set for example the cpu to 1079, the console will automatically go to 360.
« Last Edit: February 26, 2021, 06:57:42 am by Ninoh-FOX »

Kamjin

  • Posts: 8
Re: CFW RG280V - RG280M "ROGUE"
« Reply #16 on: February 26, 2021, 08:12:42 pm »
but, a part, not is possible change the clock to 1069Mhz... I don't know how you are use the system.
with kernel 3.12 it is only possible maximum or minimum clock, that is to say 1080 or 360, if you set for example the cpu to 1079, the console will automatically go to 360.
Thank you for answering my questions!
it makes sense now..  why it behaves like that.. I didn't realize there was only 2 clock options..
just a note: if you use the game pad you have only  360<->1080..  but if you use L & R buttons  it seems to let you change.. + or - 11mhz steps

Quote from: Ninoh-FOX
I can try make a ROGUE version witout overclock,
I would very much appreciate if you can release a build with for the RG350M & RG280V that don't have overclock. I much prefer to use the rogue firmware..

Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V - RG280M "ROGUE"
« Reply #17 on: February 27, 2021, 03:55:49 am »
just a note: if you use the game pad you have only  360<->1080..  but if you use L & R buttons  it seems to let you change.. + or - 11mhz steps

ohll failed !!  that shouldn't be there XD
« Last Edit: February 27, 2021, 03:57:37 am by Ninoh-FOX »

Kamjin

  • Posts: 8
Re: CFW RG280V - RG280M "ROGUE"
« Reply #18 on: March 07, 2021, 03:16:33 am »
There's a strange sound problem with Rogue firmware...  I originally thought there was a sound problem on my 280V because of the overclock, but It seems that there's something else that is happening.. 

I've confirmed this problem happens on both the 280V and 280M (V1.7.12), and I also just confirmed it happens on the Pocketgo V2/Powkiddy Q80. (V1.0.9)

The symptoms are.. that the sound will have pop noises, and also have "hiccups"..

It's most noticeable in Chocolate Doom, ECWolf, and scummvm..
I've also seen it happen with older GCW0 apps (Prosystem, DinguxVectrex, ColecoD, etc..)
It doesn't seem to happen with PCSX4ALL, FCEUX, Gabatte, Picodrive etc..

You can see it happen easily by turning on the unit and starting chocolate doom..  the debug output from chocolate doom also catches it.. I have the same output errors on all 3 consoles..

ALSA lib pcm.c:8545:(snd_pcm_recover) underrun error occured..


One thing that I also noticed.. is that it's some sort initialization problem.. if you start and  then exit doom after s short delay repeat this 2-4 times then you'll notice the problem will go away, until you power off/on the console..

Just a note that it does not happen on the original firmware, and on the Dingux beta firmware.. maybe that can be a clue to what it is..

Hopefully this is something that you have some time to look at...


Ninoh-FOX (OP)

  • Posts: 128
Re: CFW RG280V - RG280M "ROGUE"
« Reply #19 on: March 08, 2021, 01:02:18 pm »
There's a strange sound problem with Rogue firmware...  I originally thought there was a sound problem on my 280V because of the overclock, but It seems that there's something else that is happening.. 

I've confirmed this problem happens on both the 280V and 280M (V1.7.12), and I also just confirmed it happens on the Pocketgo V2/Powkiddy Q80. (V1.0.9)

The symptoms are.. that the sound will have pop noises, and also have "hiccups"..

It's most noticeable in Chocolate Doom, ECWolf, and scummvm..
I've also seen it happen with older GCW0 apps (Prosystem, DinguxVectrex, ColecoD, etc..)
It doesn't seem to happen with PCSX4ALL, FCEUX, Gabatte, Picodrive etc..

You can see it happen easily by turning on the unit and starting chocolate doom..  the debug output from chocolate doom also catches it.. I have the same output errors on all 3 consoles..

ALSA lib pcm.c:8545:(snd_pcm_recover) underrun error occured..


One thing that I also noticed.. is that it's some sort initialization problem.. if you start and  then exit doom after s short delay repeat this 2-4 times then you'll notice the problem will go away, until you power off/on the console..

Just a note that it does not happen on the original firmware, and on the Dingux beta firmware.. maybe that can be a clue to what it is..

Hopefully this is something that you have some time to look at...

I know, the problem is that when changing to the master channel to solve the problem that the volume of the pcm goes into mute at 30% it seems that the sound buffer is exceeded sometimes, it seems that this overflow is random when loading some applications,  I have to see if another sound configuration to get the master channel at startup would be able to fix it, in stock this does not affect since it uses the audio channel in PCM by default.

 

Post a new topic