Author Topic: Win 2 lasted me 1 day :(  (Read 600 times)

CovisGod (OP)

  • *
  • Posts: 18
Win 2 lasted me 1 day :(
« on: December 24, 2018, 06:50:11 pm »
Came yesterday, fell in love with it. Charged up fine, gone to charge it today using the charger that came with it and nothing, no light or anything, battery now dead and can't charge it back up. Tried multiple chargers and nothing.

Anyone got any advice before it goes back?

dreamesper

  • ***
  • Posts: 1269
    • Dreamesper
Re: Win 2 lasted me 1 day :(
« Reply #1 on: December 24, 2018, 07:14:21 pm »
Sorry to hear... could be the charger that came with the unit. If you are interested before returning your unit, I sell a spare charger & usb cable for the win2.

Here is the link to my shop for it:

https://dreamesper.com/shop/win-2-charger-w-cable/


It's $20 + shipping

MJPIA

  • *
  • Posts: 263
Re: Win 2 lasted me 1 day :(
« Reply #2 on: December 24, 2018, 07:53:03 pm »
Are you certain it was actually charging when you first got it?
I've seen some arrive from the factory perfectly fine and running for the first day but won't charge and die the second day from the battery draining.
The Win2 will only charge using PD chargers but it will still recognize non-PD chargers and when you plug in an ordinary 5V phone charger the LED next to the charge port will flash once, does it flash when you plug any charger in?
And does the stock charger work to charge any other devices you own?

It'd be more complicated if you ordered it from China but if you ordered it from a seller in your country I'd honestly just recommend returning and replacing it.
You shouldn't need to deal with and diagnose issues for a $700 device the day after it arrives.


CovisGod (OP)

  • *
  • Posts: 18
Re: Win 2 lasted me 1 day :(
« Reply #3 on: December 24, 2018, 08:07:10 pm »
It definitely was charging to begin with as the light was flashing on the back, only once today when I tried it did it flash once and then go off, the rest of the time it didn't light up atall.

I'll try the charger in another device.

Gutted if I'm honest, can't get a replacement but can get a refund

MJPIA

  • *
  • Posts: 263
Re: Win 2 lasted me 1 day :(
« Reply #4 on: December 24, 2018, 09:26:58 pm »
You should have the reset hole on the back of your unit, have you tried using a pin to push the reset and see if that changes anything?
Also to charge it needs a 12v or 15V USB-PD charger so if you know anyone that has a Switch the Switch charger will charge the Win2 and vice-versa so that can be used to test it.

CovisGod (OP)

  • *
  • Posts: 18
Re: Win 2 lasted me 1 day :(
« Reply #5 on: December 25, 2018, 07:22:01 am »
Came home last night, thought I'll just try it before packaging up to send back and it's started charging...... How very odd. Wouldn't be anything to do with it being hot would it?

Thank god its working

 

Post a new topic