Author Topic: Screen does not get brighter past 50%!  (Read 1155 times)

MicroByte (OP)

Screen does not get brighter past 50%!
« on: January 20, 2017, 01:51:22 am »
Not sure what happened or what setting I might have messed up, but now when I try to go to 75% or 100% brightness, it doesn't do anything.  0, 25 and 50 all change and get brighter, but 75 and 100 look the same as 50!

Any ideas?

MicroByte (OP)

Re: Screen does not get brighter past 50%!
« Reply #1 on: January 20, 2017, 02:14:00 am »
For anyone that has this problem, I had rebooted once and that did not seem to do anything.  Another reboot and it now appears to be okay.

Zzzsss

Re: Screen does not get brighter past 50%!
« Reply #2 on: February 17, 2017, 12:54:02 am »
I have the same issue and there or no answers. From what I can tell it's a setting built into the screen that changes the brightness and contrast based on what's on the screen. Anyone have a fix yet??? (I disabled all intel piwer saving, changed advanced power settings, and even disabled adaptive brightness in Services)

Pochowandpoch

Re: Screen does not get brighter past 50%!
« Reply #3 on: February 17, 2017, 07:39:14 am »
Power Options -> Change Plan Settings -> Change Advanced Power Settings -> Display:

Screen brightness: you choose the one you like (I have it at 80%)

Screen brightness attenuated: change it to 0% (in battery and in current)

Enable Adaptive Brightness: Off.

Now in BIOS:

Advanced -> Thermal



Thermal Configuration



Intel DPTF Charger Participant -> Display Low Limit: Here put the brightness that you want to keep as a minimum, as in the GPD Win I have it at 80%, because I leave it like that (before it was 40%).



Intel Dynamic Power (Optional): This also disable it (I think it is not necessary to disable it for the brightness theme, but well, if it does not work, with this, it works lol)



Greetings.
« Last Edit: February 20, 2017, 09:19:11 am by Pochowandpoch »

Pochowandpoch

Re: Screen does not get brighter past 50%!
« Reply #4 on: February 20, 2017, 09:19:45 am »
Now yes! ;)

Zzzsss

Re: Screen does not get brighter past 50%!
« Reply #5 on: August 02, 2017, 05:16:20 pm »
You are amazing!!

Power Options -> Change Plan Settings -> Change Advanced Power Settings -> Display:

Screen brightness: you choose the one you like (I have it at 80%)

Screen brightness attenuated: change it to 0% (in battery and in current)

Enable Adaptive Brightness: Off.

Now in BIOS:

Advanced -> Thermal



Thermal Configuration



Intel DPTF Charger Participant -> Display Low Limit: Here put the brightness that you want to keep as a minimum, as in the GPD Win I have it at 80%, because I leave it like that (before it was 40%).



Intel Dynamic Power (Optional): This also disable it (I think it is not necessary to disable it for the brightness theme, but well, if it does not work, with this, it works lol)



Greetings.

 

Post a new topic