Author Topic: Make the card reader great again  (Read 15941 times)

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #60 on: February 23, 2017, 07:55:21 pm »
@sakya thanks for the tool.
You're welcome. ;)

Would it be possible to make the change to the tool to only write the first time and than make it read every X seconds?
It probably doesn't make any difference if you make it write or read every X seconds to keep it alive.
It does a huge difference: reads would be cached by the OS and the SD card hardware wouldn't wake up.

OK. It sucks that we can't disable this power saving feature in Windows 10. Your tool does it's job. I didn't experience any delays anymore with ScummVM with your tool.
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Maniac

  • Posts: 421
Re: Make the card reader great again
« Reply #61 on: February 27, 2017, 02:41:56 pm »
I played it for a few minutes. I'm getting these delays when there's speech that needs to be played. It sometimes takes too long before you hear the speech and that's because of the delay to read from the MicroSD card. I think that a Windows powersaving feature is causing this problem.

I'll try it again sometime soon, but I didn't notice any delays when there was speaking when I tried earlier.

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #62 on: February 28, 2017, 02:44:56 pm »
You should also notice the difference when using CD images stored on the MicroSD card with emulators. I've tried it with Skies of Arcadia and NullDC. It runs fine with GPD Win Keep Alive from my MicroSD card and it doesn't without it or disabled.
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #63 on: March 05, 2017, 03:28:24 pm »
There's a easy fix to stop the MicroSD card from going in sleep mode every time. You just have to change the value from a registry key.

Go to Search Windows and type regedit. Start regedit and go to "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power". Right click on CsEnabled and click on Modify... Change Value data from 1 to 0 and click OK.

That's it. Now every power plan is back available and it's possible to make the change to never turn off the Hard disk. It won't make the MicroSD card read/write speed faster but it does seem to fix the annoying delays after being idle for some time.
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Faust

  • Posts: 533
Re: Make the card reader great again
« Reply #64 on: March 05, 2017, 11:07:02 pm »
There's a easy fix to stop the MicroSD card from going in sleep mode every time. You just have to change the value from a registry key.

Go to Search Windows and type regedit. Start regedit and go to "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power". Right click on CsEnabled and click on Modify... Change Value data from 1 to 0 and click OK.

That's it. Now every power plan is back available and it's possible to make the change to never turn off the Hard disk. It won't make the MicroSD card read/write speed faster but it does seem to fix the annoying delays after being idle for some time.
Does it affect the card reader in sleeps mod? I don't want the card reader to pull battery will the Win is into sleeps mod.

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #65 on: March 06, 2017, 11:21:14 am »
I don't know if it would be an issue with sleep mode. I don't use sleep and hibernation. It's something you should try out. If it is an issue than you can change it back to 1 minute or try with a longer time before it shutdown the disks.
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Maniac

  • Posts: 421
Re: Make the card reader great again
« Reply #66 on: March 06, 2017, 01:28:12 pm »
Does it affect the card reader in sleeps mod? I don't want the card reader to pull battery will the Win is into sleeps mod.
CSEnabled removes sleep mode, so... yes?

Faust

  • Posts: 533
Re: Make the card reader great again
« Reply #67 on: March 06, 2017, 01:29:42 pm »
Does it affect the card reader in sleeps mod? I don't want the card reader to pull battery will the Win is into sleeps mod.
CSEnabled removes sleep mode, so... yes?
Thanks, so I rather keep the software and the sleeps mod

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #68 on: March 06, 2017, 05:30:12 pm »
Does it affect the card reader in sleeps mod? I don't want the card reader to pull battery will the Win is into sleeps mod.
CSEnabled removes sleep mode, so... yes?

Hmm... But it was enabled and I did disable it.  ???
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Maniac

  • Posts: 421
Re: Make the card reader great again
« Reply #69 on: March 06, 2017, 06:26:43 pm »
Does it affect the card reader in sleeps mod? I don't want the card reader to pull battery will the Win is into sleeps mod.
CSEnabled removes sleep mode, so... yes?

Hmm... But it was enabled and I did disable it.  ???
I should say, setting CSEnabled to 0 removes sleep mode.

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #70 on: March 06, 2017, 07:00:35 pm »
I don't care for sleep or hibernation. For me it's much more important that everything runs fine. Disabling CSEnabled and change the Shutdown Harddisk to never did fix the delays with the MicroSD card. That's something that did bother me a lot.
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller

Alien Grey

  • Posts: 1414
Re: Make the card reader great again
« Reply #71 on: January 10, 2018, 06:58:42 pm »
Hmm... After a clean Windows 10 Home X64 Anniversary Update installation on my GPD Win the MicroSD card slow response time was back.

I did disable the Turn off Hard Disk setting but this time it didn't fix it. After a bit of research I've found the reason why it didn't fix it. There's an other registry setting that needs to be altered to make the response time quick again.

Open Regedit and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\Parameters. Look for queuePriorityEnable. Change the value from 0 to 1 if it isn't already.

You still need to set the Turn of Hard Disk setting to 0 or Never.


After a restart the slow response time is back.  :(
« Last Edit: January 10, 2018, 07:44:39 pm by Alien Grey »
Dingoo A-380 CFW V2.11.09 "RetroDD" - 2 x SanDisk SDHC 32GB Class 10 MicroSD Inside - 2 x Dingoo F-16 Wireless Game Controller