Author Topic: Linux Anyone?  (Read 4839 times)

brittAnderson (OP)

Linux Anyone?
« on: January 14, 2017, 03:58:54 pm »
I have never been able to get the screen to rotate properly when running linux. If anyone has linux screen with proper rotation can you provide details on the distribution, kernel version, and any other parameters/drivers you used to accomplish this. I have been using Archlinux (both LTS and regular) and while I can get everything working, basically I cannot get the on-board screen to display except in the rotated, portrait, orientation. Ideally would like to support dual monitor (onboard and hdmi). Thanks,

midknight

  • *
  • Posts: 248
Re: Linux Anyone?
« Reply #1 on: January 15, 2017, 10:26:12 am »
there is a youtube video that one of the guys on this forum uploaded of xubuntu running in landscape on the win there was a display setting he had to change.

FuLgOrE

Re: Linux Anyone?
« Reply #2 on: January 15, 2017, 01:23:52 pm »
Try Manjaro KDE.
I never got XFCE or Gnome rotated without blackscreen.
With KDE it worked.

The biggest headache is to get the battery indication working...

SeongGino

Re: Linux Anyone?
« Reply #3 on: January 16, 2017, 03:14:37 am »
Try Manjaro KDE.
I never got XFCE or Gnome rotated without blackscreen.
With KDE it worked.

And by "works" does that also mean a pass on the MicroSD reader? Because Arch's compatibility page says it's not functioning properly yet.
It's just your average Seong. Nothing to see here, move along...

brittAnderson (OP)

Re: Linux Anyone?
« Reply #4 on: January 19, 2017, 03:35:55 pm »
Tried the Manjaro KDE live version from a usb. When I went to terminal and rotated with xrandr again got black screen, but when I used the KDE "gui" display to rotate it worked - though interestingly I had to rotate counterclockwise to get a clockwise result. Did not have functioning wifi though, but rest seemed to work based on a cursory inspection.

If you want to try linux try the Manjaro KDE, and maybe someone who knows more than me can help figure out what the setting is that Manjaro KDE display settings gui is using that we could then utilize in other distributions and desktops.

Thanks @FuLgOrE

Re: Linux Anyone?
« Reply #5 on: January 20, 2017, 07:40:40 pm »
Hello together.
Summary
XFCE runs, when installed from a Xubuntu 16.04 (16.10 produces black screen)
It rotates and touchscreen can be transformed to work correct. It stays cool with vent off.
Unfortunately, sound is off, shutdown/reboot hangs, close display hangs, display backlight not adjustable

Details
I created a Xubuntu 16.04 USB flash drive for installation
The Installation was done in portrait mode. Most steps where made by using touch screen, joysticks where pain.
I installed to /dev/mmcblk0 (I tried to install it to a second mmc /dev/mmcblk1, which always sent me to the grub shell after boot)
After installation I rotated the screen right using the gui, which worked well. This is persistent after reboot.
The touchscreen was transformed from command line. This is not persistent, however you can edit a config file (I did not)
command: xinput set-prop 'Goodix Capacitive TouchScreen' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1
(found on https://wiki.ubuntu.com/X/InputCoordinateTransformation)
WiFi was activated according to https://wiki.archlinux.org/index.php/GPD_Win
Most fonts where set to size "14"
Update and upgrade worked
release-upgrade to 16.10 killed the installation during the process (black screen)

I hope this was helpful

Can anybody please post information on fully working linux distros?

Best regards
Frytz

brittAnderson (OP)

Re: Linux Anyone?
« Reply #6 on: January 22, 2017, 01:55:00 am »
@FuLgOrE if you are running Manjaro KDE can you run the mhwd command to identify the installed graphic driver and post the results here? That may help those of us using different distros. The command is, I believe,
Code: [Select]
mhwd -li -d --pci and is described here: https://wiki.manjaro.org/index.php/Configure_Graphics_Cards.

Thanks for the update @derbaertigeFrytz Keep us posted on your progress.

Re: Linux Anyone?
« Reply #7 on: January 24, 2017, 10:34:37 pm »
Here is it.
This XUbuntu features are now working for me: Wifi, Sound, Landscape mode, touch screen, reboot?
I lost on that way: micro ssd is not recognized any more
Still not working: display backlight not adjustable, power indicator, keys to control sound

Nevertheless a system you can play with
I found some really worthful hints on the archlinux wiki

To get this, you have to
1. create a Xubuntu 16.10 USB flash drive for installation.
2. On the boot menu, select "install..." and press "e"
3. Find the options line with "quiet splash"
4. Add "i915.fastboot=1" to avoid black screen on boot.
5. Press Fn+F10
6. Install in portrait mode
7. When your installed Xubuntu starts, again add "i915.fastboot=1" to the startup options.
8. Still in portrait mode, test your sound 
9. Update, upgrade, reboot (remember the startup modification)
10.  Load the 4.9.5 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9.5/
 You need the debs from the "Build for amd64 succeeded" section
11. Install them with "dpkg -i *.deb"
12. Reboot. No startup modification is necessary.
13. Rotate the screen with "xrandr" or with the gui. Both will work. "xrandr" is not persistent.
14. Transform the touch screen
15. Grin. You are done.

good night

brittAnderson (OP)

Re: Linux Anyone?
« Reply #8 on: January 25, 2017, 01:16:36 pm »
@derbaertigeFrytz can you report on bluetooth and the microphone (as a portable device it would be great if one could use it for a skype conversation with bluetooth speakers/microphone - I know there is no camera)?

Your report is much appreciated, I was ready to give up. Cheers,

brittAnderson (OP)

Re: Linux Anyone?
« Reply #9 on: January 27, 2017, 12:19:32 am »
Afraid this didn't work for me.
First, no wireless so I couldn't get to the repo with kernel 4.9.5
Also, no mouse,
And after restarting after the Xubuntu install there was no opportunity to hit e and add the i.fastboot=1.

Not complaining. It was worth a shot, just throwing it out there that the effect of this may be idiosyncratic.


Re: Linux Anyone?
« Reply #10 on: January 28, 2017, 03:45:47 pm »
Hello everybody.
Good news first: brightness can be set!!!

my last message was posted deep in the night. It may have been not very clear.
I will try to correct this. Here is a new step by step instruction.

First, you should be aware, of what you will get.
The following features do not (fully) work, yet (Jan 2017).
1. Wifi quality seems to be poor.
2. Sound works only on right speaker.
3. Headset seems not to work.
4. BT seems not to work.
5. Touch screen does only support simple actions (while mouse via controller works perfect)
6. Function buttons, like volume control do not work.
7. Installation is not that easy. You should be at least an experienced console user.
8. Sensors (like battery sensor) do not work.

If you bear that in mind, you can have a running and really usable linux on the GPD Win.
Here is what you have to do for Xubuntu.

1. Create an USB install flash drive based on Xubuntu 16.10
2. Download the Linux kernel 4.9.6 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9.6/
   You need the deb files from the "Build for amd64 succeeded" section
   You can download those files later on, however this will be less convenient.
3. Download brcmfmac4356-pcie.txt from https://chromium.googlesource.com/chromiumos/third_party/linux-firmware/+/f151f016b4fe656399f199e28cabf8d658bcb52b/brcm/brcmfmac4356-pcie.txt
4. Prepare a second USB flash drive, or a micro sd card with the files from step 2-3
5. Shut down your GPD Win, plug in the installation flash drive, start it, while pressing ESC in order to enter BIOS setup
6. Use the A B X Y buttons and the Return button to access the boot settings and select your flash drive. Press Fn + 4 to save.
7. When the grub menu comes up, select "Install...", press "e", do not press Return. The boot configuration shows up.
8. Find the options line with "quiet splash". Add " i915.fastboot=1" behind "quiet splash" to avoid black screen on boot. Continue boot by pressing Fn + 0
9. Install in portrait mode. Install to /dev/mmcblk0 (Do not install to /dev/mmcblk1, if available. This will send you to the grub shell after boot)
   If you are experienced, I recommend a seperated home partitiom for upcoming re-install. This is my default approach, though not a must.
   When the install is done, the device will not shut down correct. You have to press the Power button for a while.
   Remove the install medium and start the device.
10. When the grub menu pops up, press "e" immediately. This will show the boot configuration.
    Again add " i915.fastboot=1" to the startup options (behind "quiet splash") and boot.
11. Log in. Do not try to rotate the screen at this point. Insert the flash drive from step 4.
12. As root, copy brcmfmac4356-pcie.txt to /lib/firmware/brcm
13. Either reboot (repeat step 10) or reload drivers with "modprobe -r brcmfmac" and "modprobe brcmfmac" as root
14. Update, upgrade, reboot (remember to repeat step 10)
15. Install the new kernel from your flash drive with "dpkg -i *.deb"
16. Reboot. No startup modification is necessary.
17. Rotate the screen with the gui (Settings - Display). You may use xrandr  as well. Both will work, however "xrandr" seems not to be persistent.
18. Execute "xinput set-prop 'Goodix Capacitive TouchScreen' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1" to transform touch screen.
19. Execute "xrandr --output DSI-1 --brightness 1.0" to increase brightness. Values >1.0 are possible, however that seens to be overdone.

At this point you are nearly done. However:
- Sound settings default to headset, which does not work.
- Step 18. has to go to a conf file in order to be persistant.
- When you ask me, installing SSH is a must, when your graphic settings are not reliable.

Best regards
Frytz

« Last Edit: January 29, 2017, 01:32:02 am by derbaertigeFrytz »

Matan

Re: Linux Anyone?
« Reply #11 on: May 14, 2017, 01:52:19 pm »
In case someone missed:

Hans de Goede's kernel (http://hansdegoede.livejournal.com/17445.html) for the GPD Win adds support for some features, most notably battery monitoring and brightness control (the suggestion in step 19 only changes display gamma not the actual backlight intensity). It works for me on a Z8700 (original) device. I did not test on a Z8750 device.

If you do not wish to compile the kernel yourself, you can download the package from here:
http://my.svgalib.org/gpdwin/ (you only really need the image and headers packages, I believe).

You need to edit /etc/default/grub before installing the packages, changing
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"to
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash fbcon=rotate:1 dmi_product_name=GPD-WINI55"
And read Hans' blog post, there are other suggestions.

Re: Linux Anyone?
« Reply #12 on: May 17, 2017, 12:31:05 am »
One thing... you probably want to grab either a $2 USB - Ethernet adapter off ebay (get one that says it supports everything... its an old but cheap and very compatible chip).

Or if you want to be sure it works out of the box grab and ASIX based adapter of amazon (Pluggable etc... ) they are more like $15.

It's helpful when reinstalling windows as well... my cheapo ASIX based adapter worked great.

Piece_Maker

Re: Linux Anyone?
« Reply #13 on: May 30, 2017, 02:17:06 am »
Hi all, 

I've successfully had Ubuntu Gnome installed on my GPD, however due to some hit-and-miss performance with some games I decided to nuke 'n pave it with Windows again. Needing my FOSS fix, I went with a dual-boot, however ever since I've set this dual boot up I've had some insanely  bad crashing under Linux. It seems to be triggered by Gnome's animations, either when I maximize a window, or select an indicator, or open the Activities screen. 

Probably out of the scope of this forum, but has anyone else hit this issue and possibly fixed it? 

As a small aside, my touchscreen has decided to randomly quit working sometimes (Both under Windows and Linux) and so I'm wondering if the two are related. I tried resetting the BIOS to default to make sure it's not something I've touched in there to no avail. 

EDIT: Crashing is fixed! There were a few kernel parameters I needed to add. Touch still isn't working though so I'll get to work on that, seems to be a hardware problem as it doesn't work under Windows either.
« Last Edit: May 30, 2017, 12:43:11 pm by Piece_Maker »

Matan

Re: Linux Anyone?
« Reply #14 on: June 05, 2017, 11:10:14 pm »
Regarding bluetooth, I needed to run hciattach manually:
Code: [Select]
hciattach /dev/ttyS4 bcm43xxhciattach complains about missing firmware, but bluetooth works. At least for connecting a mouse, as I did not try anything else. Firmware might be found here https://github.com/winterheart/broadcom-bt-firmware/tree/master/brcm or it may be extracted from the windows driver.