Author Topic: GPD Win 2 Dolphin Woes  (Read 1904 times)

sunbear (OP)

  • *
  • Posts: 13
GPD Win 2 Dolphin Woes
« on: August 16, 2018, 09:21:23 am »
Hi all

Recently purchased the GPD Win 2, and it's great. Runs the PC games I want to fine, and emulators apart from.....Dolphin. I am using the current 5 version (also tried using older versions but get the same results). Basically, the frame rate is terrible. I have followed the Phawx video on how to set up the BIOS/UXT, power management options in windows for GPU and CPU are set to performance.

I am still only getting a stuttery frame rate of between 20-25fps on Mario Sunshine. Rogue Squadron runs a little better at between 25-30fps but with sound issues.

I would have thought that even an out of the box GPD Win 2 would be capable of better frame rates?

Dolphin settings are all on the settings recommended on this forum.

Any ideas? It's driving me crazy that I can run Mad Max beautifully without any issues but the system is really struggling with Dolphin.

Thanks
Sunbear

SONY

  • ***
  • !
  • Posts: 1633
Re: GPD Win 2 Dolphin Woes
« Reply #1 on: August 16, 2018, 09:34:28 am »
Those frame rates for Dolphin on GPD Win 2 are normal.
Nintendo Switch w/ipega PG-9083

SONY PS3 Super Slim
SONY PS4 Slim
SONY PS4 Pro

ALLDOCUBE Mix Plus w/ ipega PG-9023

Apple iPad pro 2019 w/Gamevice (pending)

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #2 on: August 16, 2018, 09:49:48 am »
Those frame rates for Dolphin on GPD Win 2 are normal.
They are not. Super Mario sunshine IS fullspeed.

Make sure you have CPU and GPU un m?ximum performance Mode. Also, if You are using a recent dev builds, use dx11 , ubershaders asynchronous, compile at start up, and 1x res. Super Mario sunshine should play fullspeed that way and 99 percent of GC titles.
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #3 on: August 16, 2018, 10:14:24 am »
Thanks skelton

I have those setting within Dolphin as you described.

I have set maximum performance on GPU in the Intel Graphics Settings app, and processor power management in the "control panel", "power options" settings to minimum processor state 5%, maximum processor state 100% in both unplugged and plugged mode.

Am I missing something?

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #4 on: August 16, 2018, 10:27:54 am »
Make sure that when You tick in the battery icon the slider of CPU IS on m?ximum performance too.
Some devices (maybe a BIOS bug) need also to disable dptf and GPU low power Mode on BIOS.
« Last Edit: August 16, 2018, 10:30:15 am by skelton »
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #5 on: August 16, 2018, 10:31:33 am »
I'll try disabling DPFT and report back.

I can't see no slider for the battery though, so maybe I am looking in the wrong place?

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #6 on: August 16, 2018, 10:36:02 am »
sometimes doesn't appear first time you click, but should be there. Most probably seems you are running on balanced mode.
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #7 on: August 16, 2018, 10:39:01 am »
Disabling DPFT has no effect on frame rates for me.

Call me daft, but would you mind taking the time to point me in the direction of the power setting you are talking about please so I can double check it's the same as what I am doing?

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #8 on: August 16, 2018, 10:39:58 am »
It's just to click on the battery icon that is on windows bar.

https://docs.microsoft.com/en-us/windows-hardware/customize/desktop/customize-power-slider

Do you have created a custom power plan or the one that comes with the device? If it's the one that comes with windows that slider should appear.

Another thing you can try is changing GPU drivers, latest ones have some issues I think. I use those ones.
https://mega.nz/#!x1RkEABL!8RHgLH0KkaclR1IuvzKXwFGrODcWzJRStmGpZ80lY6I

« Last Edit: August 16, 2018, 10:44:19 am by skelton »
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #9 on: August 16, 2018, 10:44:58 am »
Grrrrr so it was on balanced mode. I have shoved the slider all the way to performance mode now but still have the same results in Dolphin.

Frustrating is a mild word I'd use right now!

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #10 on: August 16, 2018, 10:46:21 am »
I didnt think it was the power performance to be honest as it does the same thing when it's plugged in

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #11 on: August 16, 2018, 10:49:22 am »
There must be something that is making thermal throttle or your device is not ramping from 4.5W or something, because it's not normal.

Maybe you can try with an older build or using dolphin ishiruka 744 for example making a clean install (deleting dolphin emulator folder in my documents folder).

But there must be something different in your config because mario sunshine is not demanding at all, could be even played on win 1.

Try using GPU drivers I gave you and see if it improves. Did you disable gpu low power mode on bios too?

This guide is also helpful.
https://www.youtube.com/watch?v=mIHWuqjVcn4

But maybe there is something in dolphin that is ticked making it running it slow.
« Last Edit: August 16, 2018, 10:51:48 am by skelton »
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #12 on: August 16, 2018, 10:55:36 am »
Thanks Skelton

I am downloading those drivers now so will see how that goes. I disabled the GPU low power mode in the BIOS, yes.

Something somewhere must be wrong I think - I never see more than 4w in the XTU Package TDP info

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #13 on: August 16, 2018, 11:00:10 am »
Yeah, that's not normal. It should go to 7W easily. Maybe some option in XTU is screwed up or in bios? Difficult to know, but certainly something is going on with your device if it doesn't go higher than 4W
Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #14 on: August 16, 2018, 11:04:13 am »
Thought as much. I have tried uninstalling XTU to see if that helped, but it didnt. I have since reinstalled XTU but same results.

Any idea what to check in the BIOS?

All I have done thus far is follow the Phawx yuotube video.

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #15 on: August 16, 2018, 11:06:06 am »
Try to disable XTU on bios since on retails devices I have heard it can give some issues.

I didn't follow phawx guide, but maybe you can try this one that is quite useful too.

https://www.youtube.com/watch?v=mIHWuqjVcn4

Something seems to be limiting your cpu power but hard to know exactly what setting.

Retired

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #16 on: August 16, 2018, 11:15:50 am »
I'll take a look.

Thanks for all of your help!

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #17 on: August 16, 2018, 12:14:58 pm »
If it's any help to solve the riddle, performing a CPU stress test in XTU, the package TDP never goes over 7w

sunbear (OP)

  • *
  • Posts: 13
Re: GPD Win 2 Dolphin Woes
« Reply #18 on: August 16, 2018, 01:05:50 pm »
OK now so even more bizarre. Mario Sunshine now still running around 24/25fps. But Rogue Squadron anywhere between 35-60fps, which is absolutely playable ?!

skelton

  • *****
  • Posts: 6834
Re: GPD Win 2 Dolphin Woes
« Reply #19 on: August 16, 2018, 04:13:57 pm »
Mario sunshine if is the pal version should run at 25 fps, and 30 for ntsc. Rogue squadron is very demanding, one of the few GC titles that need a ultra PC.
Retired

 

Post a new topic