• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: GPD Win 1 Not Charging  (Read 3103 times)

bpopilek (OP)

  • Posts: 2
GPD Win 1 Not Charging
« on: October 22, 2019, 04:24:48 am »
So I recently picked up a GPD Win 1 from eBay to replace one that I had stolen. This one was sold as-is and stated that it would not power on. I first tried using a USB C cable with an iPad charger, this unit came with no accessories, but it wouldn't charge or turn on. I then tried the USB C charger for my Lenovo laptop, but the same results. Next, I removed the bottom shell and disconnected the battery. After I reconnected it, I was able to boot the unit into Windows and it seemed to work as it should. However, it still wouldn't charge, and because the battery was so low, it powered off after just a couple of minutes. It then wouldn't turn on again until I pulled and reinstalled the battery a second time. Unfortunately the battery is pretty much dead at this point and I cannot get it to charge at all.

What I am trying to determine at this point is could this potentially be any the following issues preventing me from charging and using it:
1. Bad USB C port?
2. Bad charging circuit?
3. Defective battery?
4. Incompatible charger?

Or are there any other suggestions? If any of the above, how do I remedy them? I know I can use alternate batteries, but what about chargers or replacement USB C ports? Thanks for any possible advice!
Tinkerer Extraordinaire!

bpopilek (OP)

  • Posts: 2
Re: GPD Win 1 Not Charging
« Reply #1 on: October 25, 2019, 10:18:25 pm »
This message shows that there have been 80 views since I initially posted it, but no replies received from anyone yet. Does anyone have any ideas or possible suggestions that I can try? At this point, without being able to charge it, it's not useful for much more than a paperweight. I'd love to fix this vs. just throwing it into the trash and counting my losses. Thanks!
Tinkerer Extraordinaire!

xdplus fanatic-oopsy

  • * AKA Dreamesper
  • Posts: 1338
Re: GPD Win 1 Not Charging
« Reply #2 on: October 26, 2019, 01:10:29 am »
you have two options:

A)  Send it in to GPD for repair(s)
B)  Contact 'psyops' from reddit; he performs GPD repairs for a small fee



  • Posts: 326
Re: GPD Win 1 Not Charging
« Reply #3 on: November 07, 2019, 08:48:36 am »
Not easy to find Win1 battery replacement, because it's already stop produced couple years.