Author Topic: Issue with upgrading G5A firmware / Solved with Linux  (Read 1680 times)

holmes (OP)

  • Posts: 20
Issue with upgrading G5A firmware / Solved with Linux
« on: February 28, 2014, 03:42:06 pm »
I have been unsuccessful in installing the Rockchip driver on my Windows 8.1 HP Latop. After many attempts (manual or automatic install, use of WinXP with VirtualBox), I tried with Linux. I first tried with RkFlashKit but my device was partially bricked (no more starting). I tried again and realized (feedback from RkFlashKit) there may be a problem with the NAND memory and have to format it. Then I found this:
http://wiki.radxa.com/Rock/flash_the_image
and use the following commands:
--> to format
sudo ./upgrade_tool lf       #(LF Lowlevel Format)
--> to upgrade:
sudo ./upgrade_tool uf  /path/to/update.img          #(UF Upgrade Flash)

To make it work, I had to maintain Power and vol+ buttons just before and a few seconds after typing the command. I had to format twice before getting a successful upgrading report.
Now my device works perfectly with the Legacy firmware...
« Last Edit: March 01, 2014, 11:27:06 am by holmes »

StevenP

  • Posts: 39
Re: Issue with upgrading G5A firmware / Solved with Linux
« Reply #1 on: February 28, 2014, 04:41:59 pm »
Thanks for posting this.
Handhelds: 3DS XL, GBA SP, PSP, GP2X Wiz, JXD 7100B, JXD100, Various other handhelds that include emulators and built-in games (their generic names escape me at this moment but some are actually cool.)
Tablets: Nook HD+, Entourage Edge
Consoles: XBOX 360, XBOX original, PS3, Wii, N64, 3DO, GameCube.

 

Post a new topic