Author Topic: Input configuration G5A help  (Read 2958 times)

victorsavu3 (OP)

  • Posts: 4
Input configuration G5A help
« on: March 16, 2014, 11:59:04 am »
I have some problems with RetroArch and Mupen64+ AE. I am using LegacyROM 1.1 for GPD-G5A Kitkat.

In Mupen64+ AE:
Everything is mapped properly except for the Z button. I have also tried using the tincore mapper to map L1 to the onscreen controls, but it also failed to register. The button works during mapping. Using the touchscreen also works.

In RetroArch:
I can not use any controls. How do I configure RetroArch to recognize the buttons properly? Using input debug I can see that the application registers the buttons, but they have no effect.

Does anybody have any hints?
« Last Edit: March 16, 2014, 12:10:26 pm by victorsavu3 »

skelton

  • Posts: 6894
Re: Input configuration G5A help
« Reply #1 on: March 16, 2014, 12:55:35 pm »
I don't understand your problem with Z button. You can assign Z to the button you like in the emu. Controls work fine, just map it as you like inside the emulator. No need for mapper or whatever. And no need to use onscreen controls. Just map inside the emu as you wish in emu options.

For retroarch, disable debug autodetection and map manually using player 1 custom binds option.
Retired

AncientGamer

  • Posts: 12
Re: Input configuration G5A help
« Reply #2 on: March 16, 2014, 02:58:28 pm »
I almost created a topic regarding the same problem with Retroarch yesterday.

For me, Retroarch has responded haphazardly to controls.  Sometimes they work, sometimes they're completely unresponsive. I've been using Retroarch for more than a year on various platforms so I'm pretty familiar with it and here are the things I've tried:

1. disabled auodetect for the controller
2. manually bound the keys (this always works fine)
3. cleared the data and cache from the app manager
4. uninstalled and reinstalled the app completely
5. disabled "use global settings" in the settings
6. tried changing the IME and then changing it back
7. rebooted the deivce
8. complete power down and reload
9. changed cores, tried loading a new game
10. deleting config file

Also worth noting is when the controls don't respond in-game, the on screen back button doesn't do anything either.  You can see the animation for it being pressed, but nothing happens.  Also when this is going on if you try to load a new game, it looks like it loads, but then you're thrown right back to the game that was already running and not responding.  This has happened regardless of core or game selected.

Something else worth mentioning is that on the OUYA, I have seen similar problems with Retroarch, where it stops recognizing button presses on the controller.  However, the problem happens MUCH more frequently on the G5A.  I also considered posting about it on Retroarch's forum but didn't since there are a few similar posts with no working solutions.

If anyone has run into this and been able to come up with a solution, I'd appreciate it.

skelton

  • Posts: 6894
Re: Input configuration G5A help
« Reply #3 on: March 16, 2014, 03:30:27 pm »
I have never suffered this kind of problem in Retroarch in any device. And not in g5a. So you must be doing something different. I don't know what exactly, but I have never suffered a problem with my devices using custom binds. And I have never suffered in g5a (retroarch is my main emulator, and never had an issue with it in g5a)
Retired

victorsavu3 (OP)

  • Posts: 4
Re: Input configuration G5A help
« Reply #4 on: March 17, 2014, 09:27:41 am »
For Mupen64+ AE:
  I didn't realize it has custom key bindings, it's now fixed. Thanks for the hint.

In Retroarch:
  How do I use "custom binds option"? I tried choosing Custom from the device list, but it does not appear. It's there for Player #2-8, but when I change to something else I can't change back to it. If I try to assign bindings it never registers any input. Once I managed to get the d-pad and one button to work (no idea how), the rest were still unresponsive.
  I will continue testing later today.

skelton

  • Posts: 6894
Re: Input configuration G5A help
« Reply #5 on: March 17, 2014, 04:04:08 pm »
It's in input options. make aure you have disabled autocongfiguration and touch screen overlays, and should be there. Player 1 custom binds is what you are looking for.
Retired

victorsavu3 (OP)

  • Posts: 4
Re: Input configuration G5A help
« Reply #6 on: March 17, 2014, 08:40:14 pm »
Finally found it :D. Thanks for all the help.