Author Topic: GPD XD Having issues with look control in GTA3, Dead Space and similar games  (Read 908 times)

ufo.mesh (OP)

  • *
  • Posts: 18
I've recently got GPD XD and maybe just don't know how to setup it correctly. I have latest Legacy ROM (but with old Mali drivers) installed. So, the problem is: after setting up mapping tool, setting up gamepad tool, switching to it's different modes, I still can't normally turn the camera around a character with my right stick. It turns for a small degree, turns back, shakes and so on. There's an icon for a right stick in mapper setup, I place it right in the center of the screen, where the main character is shown. I've tried changing it's size, placing it in different position, switching different modes... Nothing helps. I've also installed gamepad check app, it seems that it works fine, it even works normally in other games which don't use it for "mouse looking". So, what have I do with setup to comfortably play GTA and others that use rotation around the character camera? Thanks in advance!

Sent from my Nexus 5X using Tapatalk


eragon2890

  • ***
  • e
  • Posts: 1843
Dead space uses swiping for look which will Always be awkward/annoying i believe (i couldnt get it work good either) but for GTA the solution is simple: disable the mapper, you don't need it. It works natively with the gamepad. Same voor vice city and san andreas :)

I can also really recommend retro city rampage BTW, awesome game, was recently ported to android ;)

ufo.mesh (OP)

  • *
  • Posts: 18
Dead space uses swiping for look which will Always be awkward/annoying i believe (i couldnt get it work good either) but for GTA the solution is simple: disable the mapper, you don't need it. It works natively with the gamepad. Same voor vice city and san andreas :)

I can also really recommend retro city rampage BTW, awesome game, was recently ported to android ;)
Thanks for advice, eragon! Question is how do I disable the mapper? I thought it's always active, I mean the default one. I don't remember if there's an option to disable it.
Yeah, I've played Retro City Rampage on PC, it's really good, didn't know that it's available on Android. Now I'm playing Wayward Souls. It's a kinda rogue-like with cute pixel graphics. It has really good sensitive touch controls but hardware buttons and sticks give totally different experience. Would recommend this game, btw, if you like rogue-likes.

Sent from my Nexus 5X using Tapatalk


eragon2890

  • ***
  • e
  • Posts: 1843
you don't disable the mapper, you enable it.

it's Always off by default until you open it with the button, configure it for the application you are using, and click save.

then after that it's still only on/used for that application, if you switch to another it s off again.

so: for games/apps that suppoet controls, don't enable it. if you need to map, open it, configure/frag buttons fr that game, and click save. then every time after that you open that game/app it will work with those settings automatically.

skelton

  • *****
  • Posts: 6389
To disable the mapper just open it in the game you are using and press clean/close and it will be disabled.

I have never pkayed dead space on android, but if it requieres swipes, try with Tincore keymapper, it allow swipe options. It requieres root though and is more complex to use.
Retired

ufo.mesh (OP)

  • *
  • Posts: 18
Thank you for help, guys! It really worked! Not that way a bit that I supposed it would be, but... GTA3 switches to some sort of FPS mode when I move my right stick, Dead Space is hardly playable because of it's way to attack with different swipes on screen. You always have to switch your hand to screen to make a swipe and back to stick. It's a bit annoying of course. Maybe some mapper could deal with this, but I have plenty other games to play now and not in mood to experiment with tools.
I found very comfortable playing Wayward Souls, it a rogue-like game with cute graphics and I would recommend it. Btw, it has really good touch controls (I think the best I've ever seen) but of course plays much better with hardware buttons.
I also found that when the mapper software is active it's icon becomes magenta color. It's really handy.
Also I would greatly appreciate if someone pointed me the topic (or told me) about preferred emulators for most famous systems like nes, snes, gba(gb, gbc), smd, sms, mame, maybe atari, amiga and spectrum.
There are a lot of them, I've tried a couple but wasn't satisfied with them. The best would be something like an app from native firmware called 'something chicken' or like that.
Thanks in advance!

ufo.mesh (OP)

  • *
  • Posts: 18
What the trouble with Crescent Moon Games like EXILES (it's free for a short period) or Mines of Mars (free)? It appears that they find controller but games show no response to it. They show gamepad buttons icons on menu items, show messages about detected joystick but I can't use it. I've tried all modes but no luck. Mapper mode works but awkwardly. Any advice?

skelton

  • *****
  • Posts: 6389
Exiles has a bad controlller Support. Try with null joystick.modenin gamepad app and use the mapper.
Retired

 

Post a new topic