Author Topic: Solved - XD W/Cleanrom. TWRP doesn't detect Micro SD *cleanrom 2.0 question*  (Read 886 times)

unclecarl (OP)

  • *
  • Posts: 9
*update
Cleanrom 2.0. fixed it. So stoked.

OP:
Hello all,
I have already used flash tool to flash cleanrom 1.10 onto my device. So I am trying to use my brand new Micro SD (32gb) for backup purposes and to reflash roms without needing to use a pc (since I don't currently have ready access to a computer). Unfortunately, TWRP does not detect any storage other than the default internal (both when in recovery mode, through the TWRP app, and through twrp via root essentials). When going through the XD+'s settings menu and ES explorer; the card is detected and useable, but just not in TWRP. I have seen a few posts on this but none have resolved this for me so I will start with the steps I've taken to get those out of the way.

I have reformatted the SD card through the XD+'s settings, as alternately internal and external storage. This did not resolve.
I have attempted to use Aparted app to partition the card, unfortunately Aparted crashes immediately upon opening.
I have attempted to partition the card through TWRP in recovery mode, but since it does not detect the card, that is a pointless effort.
I have reformatted the SD card using windows 10 by right clicking the card and selecting format. I have tried to format it as FAT32 which did not resolve. I tried NTFS which did not resolve. I have tried exFat which did not resolve. I have gone into properties and renamed the card, did not resolve.

I had seen a post which mentions 'TWRP external SD Loading - Doesnt recognize SD Card' is a known issue.
https://www.reddit.com/r/gpdxd/comments/a4u4y5/using_stock_or_cleanrom_is_there_any_bugs_that/
I cannot help but wonder if this is common. If so, why does XDrescue and other starter guides not mention this, when using an SD is so key to flashing and recovery?

I'm at my wit's end and I am begging for help. I'm stuck with a 200$ paperweight because I couldn't backup NVram/NVdata so my wifi is shot, nor can I reflash to the rev that doesn't have the sound glitch because I can't actually use TWRP.  Has anyone found a consistent fix or workaround? Can anyone with Cleanrom 2.0 say whether this issue was addressed in the release? Any help would be massively appreciated.

*update* One moment the SD is accessible through the XD+ and randomly become corrupted without me even interacting with the interface or hardware whatsoever. Then after repairing and reformatting the card it will just randomly corrupt again. Has anyone else had this issue?
« Last Edit: January 20, 2019, 10:22:31 am by unclecarl »

skelton

  • *****
  • Posts: 6834
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #1 on: January 19, 2019, 09:54:39 pm »
Have you tried a different SD in case that one has issues?

Also, I would try to format to fat32. You can in windows 10 using guiformat.

http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm
Retired

unclecarl (OP)

  • *
  • Posts: 9
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #2 on: January 19, 2019, 10:09:14 pm »
Have you tried a different SD in case that one has issues?

Also, I would try to format to fat32. You can in windows 10 using guiformat.

http://www.ridgecrop.demon.co.uk/index.htm?guiformat.htm

Ty for the reply. I have used 2 different SD cards. An old 128gb and a new 32gb. I have a new 128 but I don't want to risk getting that corrupted too. Also, you might notice in the original post I already stated that I formatted it to fat32 on Windows 10.

unclecarl (OP)

  • *
  • Posts: 9
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #3 on: January 19, 2019, 10:12:20 pm »
Also, I can't use guiformat because currently the only computers that I have access to are public or work pcs. The 32gb card came packaged in fat32 between that and the multiple reformats I tried I don't see fat32 being the fix.

Then again... Is there any additional potency(for lack of a better term) that guiformat offers that windows does not? Like, does windows fail to actually format correctly?
« Last Edit: January 19, 2019, 10:36:26 pm by unclecarl »

foxsevent

  • *
  • Posts: 42
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #4 on: January 20, 2019, 01:12:51 am »
I have tested 4 different cards 32gb 64gb 128gb and 256gb, most of them Samsung cards and the 256 SanDisk, all work fine in TWRP.
To find them in TWRP you have to select to go up a level folder and then enter external_SD, that's gonna be it.

What I'm guessing your problem is simply either a cheap/fake sd card or just old and busted if it corrupts.

GPD XD+ has an option to format the SD card, but you have to be careful as it has an option to format the card as an internal storage which will allow apps to be installed onto the SD card, but this will make the card unusable on pc or other Android devices unless you format it again as a external storage.

One good way to test an sd card is to connect it to a pc via card reader, format it with the default windows setting, should be fat32 if not use guiformat to do so, and then use h2testw, this tool will fill the SD card with files then it will check them.

If the card is fake or busted this will show you any errors that there may be.
« Last Edit: January 20, 2019, 01:19:34 am by foxsevent »

unclecarl (OP)

  • *
  • Posts: 9
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #5 on: January 21, 2019, 08:11:09 pm »
I have tested 4 different cards 32gb 64gb 128gb and 256gb, most of them Samsung cards and the 256 SanDisk, all work fine in TWRP.
To find them in TWRP you have to select to go up a level folder and then enter external_SD, that's gonna be it.

What I'm guessing your problem is simply either a cheap/fake sd card or just old and busted if it corrupts.

GPD XD+ has an option to format the SD card, but you have to be careful as it has an option to format the card as an internal storage which will allow apps to be installed onto the SD card, but this will make the card unusable on pc or other Android devices unless you format it again as a external storage.

One good way to test an sd card is to connect it to a pc via card reader, format it with the default windows setting, should be fat32 if not use guiformat to do so, and then use h2testw, this tool will fill the SD card with files then it will check them.

If the card is fake or busted this will show you any errors that there may be.

I'm curious, had you read the original post? Every point you make here was already addressed. I'm lucky black saraph was on it because the only replies I'd still be getting is people telling me to do what I had already done, and ignoring the fact that this is a known issue with TWRP in cleanrom 1.10.xx. Sigh. At least it isn't a problem anymore.
« Last Edit: January 21, 2019, 09:12:38 pm by unclecarl »

foxsevent

  • *
  • Posts: 42
Re: XD+ W/Cleanrom. TWRP doesn't detect any Micro SD *cleanrom 2.0 question*
« Reply #6 on: January 21, 2019, 11:00:58 pm »
I have tested 4 different cards 32gb 64gb 128gb and 256gb, most of them Samsung cards and the 256 SanDisk, all work fine in TWRP.
To find them in TWRP you have to select to go up a level folder and then enter external_SD, that's gonna be it.

What I'm guessing your problem is simply either a cheap/fake sd card or just old and busted if it corrupts.

GPD XD+ has an option to format the SD card, but you have to be careful as it has an option to format the card as an internal storage which will allow apps to be installed onto the SD card, but this will make the card unusable on pc or other Android devices unless you format it again as a external storage.

One good way to test an sd card is to connect it to a pc via card reader, format it with the default windows setting, should be fat32 if not use guiformat to do so, and then use h2testw, this tool will fill the SD card with files then it will check them.

If the card is fake or busted this will show you any errors that there may be.

I'm curious, had you read the original post? Every point you make here was already addressed. I'm lucky black saraph was on it because the only replies I'd still be getting is people telling me to do what I had already done, and ignoring the fact that this is a known issue with TWRP in cleanrom 1.10.xx. Sigh. At least it isn't a problem anymore.

Addressed would mean that you tried what I and others suggested and replied with the results, which you did neighter of.
I just like many others I had no issues with TWRP so it could very easily be a user error or a defective card.
You did not provide us with type of the card you used other than size or a results of a test to see if it's corrupted/defective.
You said it yourself that the card you used got randomly corrupted.

I'm glad your issue was resolved, thou this could be a case of just a cheap/fake SD card that that older version of TWRP didn't recognize.
Thou I may have been mistaken, as going by the cleanrom change log, reading and backing up to SD cards was added to 2.0 version, which could mean that simply version 1.0.5 didn't have that option.

Anyhow have a nice day.
« Last Edit: January 21, 2019, 11:12:57 pm by foxsevent »

unclecarl (OP)

  • *
  • Posts: 9
I'm not trying antagonize, simply to clarify and give feedback on the applicability of the advice given. When I say addressed I mean every fix I attempted was outlined in the OP.

"I have reformatted the SD card through the XD+'s settings, as alternately internal and external storage. This did not resolve.
I have attempted to use Aparted app to partition the card, unfortunately Aparted crashes immediately upon opening.
I have attempted to partition the card through TWRP in recovery mode, but since it does not detect the card, that is a pointless effort.
I have reformatted the SD card using windows 10 by right clicking the card and selecting format. I have tried to format it as FAT32 which did not resolve. I tried NTFS which did not resolve. I have tried exFat which did not resolve. I have gone into properties and renamed the card, did not resolve."

I also explicitly stated that the SD I used was new and the sizes of the cards used. I didn't state the brand but it is a scandisk. The only solution offered that I hadn't already tried was guiformat, which I did respond to inquiring as to what make it different than formatting through windows. To which no answer was given.
« Last Edit: January 23, 2019, 06:06:58 pm by unclecarl »

foxsevent

  • *
  • Posts: 42
Don't worry no hard feelings here, just trying to help.
As I wrote it could very be that 1.0.5 doesn't support SD cards going by the change log of 2.0.0.

As for guiformat, I don't know exactly if there is a difference, all I know is that M$ is slowly dropping support for fat32, windows keeps only basic support for old devices USB pendrives and cards that are smaller than 64gb anything bigger can't be formated to fat32 in widows, it will default it to exfat.
Ergo why people recommend guiformat for fat32.
My main recommendation is to test if the cards itself isn't fake or defective, regardless if it was brand new.
I can get a brand new 400gb micro SD card for 20$, the a gander how real that is.

Anyhow no need to dwell on this topic, the issue was resolved and everyone's happy.

unclecarl (OP)

  • *
  • Posts: 9
TY. After reviewing all of the responses I've confirmed that the older SD card was in fact defective. So I can officially confirm that cleanrom 2 has no issues with SD cards.

Thrush1120

  • *
  • Posts: 35
I also installed the new cleanrom. While it has it's advantages it also has some disadvantages i discovered on my own.

Real Boxing does not open now. Strike Wing: Rator Rising Is a black screen with white lettering.

And LEGO? Star Wars: TCS, LEGO Star Wars: TFA, and LEGO Marvel Super Heroes all have visual problems.

I have tried dicking around with GLTOOLS but have had no success yet with finding the right settings to get those games to work.

And I also noticed and I do not remember if its part of the cleanrom or not but Webview is permanently disabled. :(

 

Post a new topic