Author Topic: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)  (Read 32713 times)

leosabii

  • Posts: 2
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #80 on: April 26, 2016, 05:25:27 pm »
Nice Job with the rom. I recently just got a Q9PSV yesterday and flashed your rom. The rom seems stable enough and everything works as it should.

I did receive the Error 18 from the play store when installing Mame4droid, however, changing the primary storage to my 64 gig microSD as the primary drive fixed the issue. I have no clue why it fixed it, but my suspicion is it might be the 3 gig partition.

To have 3 different storage systems is a bit annoying, but it's workable. A Data partition, a Nand partition, and finally an external microSD storage is a bit crazy especially in KitKat.

Anyways, the 3 gig vs 6 gig issue, I would choose 6 gig as it is more adaptable for the future. It seems like Android will still install certain files on the 3 gig data partition even when the externalSD is set as primary. The Nand can be cut down in size since users can insert a bigger microSD instead. I dumped all my roms and big games on the microSD. I'm still trying to figure out what I want to put on the Nand.

The gamepad app seem useful from the XD. It would be great to mirror the XD Legacy rom features as closely as possible.

It's nice to have a vanilla android rom without all the gpd extras.

Thanks!

skelton (OP)

  • Posts: 6894
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #81 on: April 26, 2016, 06:00:44 pm »
The mame4droid issue is probably related with devices that don't use unified storage, because it happens also in my phone.

A trick to install it or update it  is just unmounting the nand flash partition, installing the app and mounting the partition again from settings/storage.

I have the new rom finished, but only for q9 standard models (I couldn't even test it deeply because my q9 is broken  :-\ ) But I hope to get a q9psv second hand model soon, so I can make the rom for q9psv and test it properly. If someone with a q9 standard model want to try it as a beta tester let me know.
« Last Edit: April 26, 2016, 06:02:55 pm by skelton »
Retired

weej

  • Posts: 15
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #82 on: May 07, 2016, 11:51:17 am »
Hi,
I don't know if you're still up for it, but I'll be glad to be a beta tester for you. I recently soft-bricked my GPD Q9 (standard not PSV) and was going to try flashing with your LegacyROM when I noticed this post. Sorry for the late bump and I sincerely do hope you get healthy soon!

skelton (OP)

  • Posts: 6894
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #83 on: May 07, 2016, 11:56:15 am »
Try this on your q9 standard:

1,6 ghz version:

https://mega.nz/#!8hpBWICS!J1PnLSshsk128BVBnek2GgGg5vXIhb2qMlLn_8Mf2jM

or if you prefer 1,8 ghz (may be unstable, be careful)

https://mega.nz/#!s9BkDJKJ!WH7376d0j8pWSvC_3iismChr0E_CritCF1YGUwl_k7o

You have to update it via BatchTool (mandatory) with restore option. SuperSU will ask you to update binaries so just update them using normal option in superSU and should be fine.

The firmware should be ok (I am using it in q9psv), but let ne know if controls work as they should (analog directions), which is the only change in q9 standard. You can use ganmepad app included in the rom to change between joystick modes (ps3, xbox or NULL)

I will release the rom for both models probably tomorrow anyway, if I have some time yo upload it.
« Last Edit: May 07, 2016, 12:00:41 pm by skelton »
Retired

weej

  • Posts: 15
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #84 on: May 08, 2016, 05:26:19 pm »
Alright so here's my findings:

first off, the RKBatchTool included in the zip didn't work for me, however another tool (from the TWRP firmware thing for the Q9) called AndroidTool worked.

Second, I downloaded the 1.6Ghz version, i dont really care for overclocking just that i can run things stable.

Third, To test analogs I tried the 2 games I know of that fully use analogs on PS1 (I didn't have time to test out PSP). I used epsxe and the games were Ape Escape and Apocalypse. I thought it wasn't working at first but turns out that the gamepad was set to XBOX, the moment I switched it to PS3, it got detected and ran smoothly. Result is, all the analog controls worked, this includes pressure - so lightly pushing the analog stick made my character walk super slowly, pushing a little more made him walk normally, and fully pushing it made him run.

Fourth: i found out how much I hate the analog sticks. Thank Goodness not many PS1 fully relied on it. Using the Q9's analogs While laying in bed was punishment.

I also installed a handful of my necessary apps, Play store worked fine! Let me know if you need me to test anything else.


skelton (OP)

  • Posts: 6894
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #85 on: May 08, 2016, 06:25:33 pm »
Well, if analog directions are ok then everything is ok. It's strange that BatchTool included didn't work for you. It's the one I use for flashing. Ps3 mode is more compatible in emulators (like Retraorch), but apparently some android games work better in XBOX mode. NULL Joystick is just useful for game that have bad detection of controllers and doesn't allow touch mapping, like horizon chase or Exiles Zero.

And yeah, analogs of standard q9 are terrible. the one included in q9psv model are much better and seems a different device.

I will finish uploading the q9psv version tonight and will try to release it tomorrow.

Thanks for your testing.
« Last Edit: May 08, 2016, 06:40:27 pm by skelton »
Retired

weej

  • Posts: 15
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #86 on: May 09, 2016, 01:21:05 am »
You're Welcome! I also had a quick question: in settings i see a bluetooth option, does this mean that if i connect an external BT dongle via OTG it will work ?

skelton (OP)

  • Posts: 6894
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #87 on: May 09, 2016, 09:27:43 am »
Nope, it's a bogus option to improve google play compatobility.
Retired

skelton (OP)

  • Posts: 6894
Retired

Kenju

  • Posts: 25
Re: [ROM] LegacyROM 1.0 GPD Q9 (Also compatible with new Q9PSV batch)
« Reply #89 on: February 07, 2018, 12:29:48 pm »
hi Skelton, you said that before on your thread https://boards.dingoonity.org/gpd-android-devices/(rom)-legacyrom-1-0-gpd-q9/

 If something (an app or game) is not working, send me a logcat to see what's going on. All complaints just saying ?This app game doesn't work? without a logcat will be ignored. And of course apps should be legally obtained. If your get an game or app from unofficial sources and does not work, then buy it and try again.

I have A problem With this game: https://play.google.com/store/apps/details?id=com.netease.chiji&hl=fr it show logo netease then a short download few second then game crash.. so how can i fix that? what  i will give you to check my problem...

 

Post a new topic