Author Topic: (GPD XD Plus) Right thumb stick not being recognized and stuck in android games  (Read 1908 times)

jpino3786 (OP)

  • Posts: 149
Neon Shadow is a great FPS for Android that ran really great on the GPD XD. On the GPD XD Plus the controls are messed up and your gun spins out of control in a circle with the right thumb stick. I?ve tried switching the controller in the game pad built in app that comes with the GPD and that didn?t do anything. Any one else having this issue with this game? It?s free on the android store! Let me know. Also, it?s not just this game but also I am having the same problem with minecraft on my XD Plus. It?s like right joystick is stuck in the up and right position on Xbox mode. Then switching to PS3 mode the same thing. The dpad also gets stuck in the menus. The selection text keeps scrolling. Is this a well known issue with the Plus? Any help would be appreciated, Thanks!


  • Posts: 30
I have the same problem in minecraft. I think they fucked up the controller app or the kernel code that make it work. It's a shame, make me regret the gpd xd 1. Hope they fix it but they even don't say a word about that on their forum.


  • Posts: 6894
Have you tried on ps3 mode? In theory the gamepad modes and driver should be the same as in old XD. Unless they changed it something. I usualy put it on ps3 mode and all games worked fine on old XD at least the games I played.
If not, you can always root and use tincore to simulate another gamepad , like original ps3, or shield gamepad.


  • Posts: 30
The PS3 mode is what I use now on the XD+, but on the first XD I was in XBOX mode and never had to change it. I re-tested minecraft on both device yesterday evening and the behavior of the control is definetly not the same. Even on PS3 mode if I use de Dpad then the direction continue to register the input until I touch the joystick, but the game is playable.

Only a no go problem is with Dreamcast games that need L/R to be pushed (ex: in race game). I can't manage to have the button working. As soon as I change direction with the joystick, the input for L/R is not registered anymore and make the car decelerate.

[EDIT] Maybe I could use both touch and real key using the gamepad overlay. I'll try it.

I think we can live with this but it would be cool if they take a look on this :p
« Last Edit: April 26, 2018, 08:46:50 am by romain337 »


Post a new topic