Author Topic: Quake 2 GLES (UPDATE 2017-10-31)  (Read 2952 times)

Thenesis (OP)

Quake 2 GLES (UPDATE 2017-10-31)
« on: March 01, 2017, 10:48:57 pm »
I made a version of Quake 2 using GLES 1. It is based on Yamagi Quake 2 v5.34 with some substantial rewrites and simplifications.

You can find the files and the sources here:

Initially I made this port to test my software rasterizer on PC and some embedded platforms but finally I tried to make a clean release.

I put my efforts into making the sources as clean and portable as possible but I don't have the time to rework everything. So the graphic parts received most of my energy.

It works pretty well with all official mission packs and has a decent framerate. The low framerate at some places is mainly due to the GLES 1 implementation which spends a lot of time doing useless things according to apitrace. But there is also a lot of possible improvements on my side.

Multiplayer works well too and you can play GCW Zero vs Raspberry Pi vs PC if you want.

UPDATE 2017-10-31

Version 1.1 is available here:

Main changes:
- Faster
- No more known rendering bugs (excluding current GPU driver rendering bugs which cannot be avoided)
- More control and rendering options available through menus
- Default configuration should give decent controls for everyone out of the box
« Last Edit: October 31, 2017, 02:05:35 am by Thenesis »


  • **
  • Posts: 707
Re: Quake 2 GLES
« Reply #1 on: March 02, 2017, 09:50:26 am »
Tried it but wont run i have quake 2 already old one would that interrupt this one starting?.
GCW White Retail

Thenesis (OP)

Re: Quake 2 GLES
« Reply #2 on: March 02, 2017, 12:49:12 pm »
It should work independently of the other Quake 2.
Have you put the pak files in the right place ?


  • **
  • Posts: 707
Re: Quake 2 GLES
« Reply #3 on: March 03, 2017, 12:15:25 pm »
Yes same as the other quake 2 folder i can only see one quake folder for both quake 2 games.
GCW White Retail

Re: Quake 2 GLES
« Reply #4 on: April 06, 2017, 12:50:11 am »
I have also tried and it is not working.

Thenesis (OP)

Re: Quake 2 GLES
« Reply #5 on: April 07, 2017, 01:10:42 pm »
Have you put the files in the right directories ?

For original Quake 2:

Re: Quake 2 GLES
« Reply #6 on: April 10, 2017, 05:34:02 pm »
Yes I have

Thenesis (OP)

Re: Quake 2 GLES
« Reply #7 on: April 12, 2017, 12:27:43 am »
I reinstalled Quake 2 on my GCW Zero using the file on the github page and it works.

Do you have the right case and read access for all users for these files ?

If you could connect to your GCW Zero using putty and run the game using the following command:
opkrun ./Quake2-1.0-GCWZero.opk
It should display the reasons why it doesn't run.

Also here is my system infos:

Kernel version: 3.12.0-dingux+
Compiled on Wed Aug 20 17:08:39 CEST 2014

Root file system version: gbb847d4
Compiled on Wed Aug 20 18:52:01 CEST 2014


  • **
  • Posts: 759
    • Russian Android/Dingo/GCW/gaming gadgets blog
Re: Quake 2 GLES
« Reply #8 on: April 23, 2017, 10:15:54 pm »
(Long time away from forum and scene, finally I had some free time to put my hands back on Zero. Hello all who are still here!)

It works for me but controls are kinda crap, at least on default configuration. Movements on D-pad are unusably sluggish and only function if I hold B pressed all the time. Movement on stick is good but vertically inverted (down => run forward, up => go backward) which is unusual and not that ergonomic (even considering all the limitations of Zero's controls) and I still need to hold B button which isn't that nice and confortable. Moreso, first thing one needs to do after loading the game is toggle mouse input mode (holding power slider up and pressing B), which isn't that obvious unless you remember about that Zero control trick. If you won't, you can't even shoot! And speaking of default config, I didn't find the way how to jump, crouch and change weapon. How to press "Enter" in some menus is also unclear.

So, OK, I go back to the options / controls and turn off "free look" and "lookstrafe" (because it's pointless in current control scheme), and then proceed to control customization. I've ended up with something like this:

Now it's playable but still I has a problem with "vertically inverted" stick. If only I would have a switch in "stick options" to turn that inverting off... Oh, and game can't save my custom control scheme (free look switch won't stay off as well) so I have to set it all again after every launch. I guess I need to try to edit config file manually.

Beside of that, it works indeed and works remarkably well (some minor graphical glitches are justifiable). I've put data from my Steam Quake 2 collection and it even created separate CTF shortcut (but I cannot pass team menu because I cannot press "Enter", probably?)! Good work, Thenesis, I hope to see some things I've listed above sorted in the next version of the port.
« Last Edit: April 23, 2017, 10:20:12 pm by Drem »

Thenesis (OP)

Re: Quake 2 GLES
« Reply #9 on: April 29, 2017, 10:50:05 am »
Thank you for your reply.

I forgot to put a default config file in the OPK, I will do it as soon as I have more free time (I just moved in my new apartment and I'm stuck with a lot of DIY).

But controls should not be as painful as you said. And you should not need to enable the mouse emulation.

Here is how I configure the controls:

free look -> yes
lookspring -> no
lookstrafe -> yes
always run -> yes

attack -> R
next weapon -> RIGHT
walk forward -> Y
backpedal -> B
step left -> X
step right -> A
up / jump -> UP
toggle crouch -> DOWN
use item -> L
next item -> LEFT
help computer -> START

Also ensure that the joystick is enabled in "stick options", this should be the default.

To navigate in the menus:
- Use SELECT to enter the menus while in-game.
- Use SELECT or B to exit a menu.
- Use START or A to enter a menu.
- Use the pad to navigate (UP / DOWN) and modify (LEFT / RIGHT) the options

Also, I will add the Y stick inversion and maybe the possibility to use one or two keys as modifiers so that we could map controls to key combinations, otherwise there is not enough keys on the GCW to control everything. A virtual keyboard would be great but it's more work.

Thenesis (OP)

Re: Quake 2 GLES (UPDATE 2017-10-31)
« Reply #10 on: October 31, 2017, 02:18:36 am »

Senor Quack

  • *
  • Posts: 194
Re: Quake 2 GLES (UPDATE 2017-10-31)
« Reply #11 on: October 31, 2017, 11:18:14 pm »
Thanks for the new release, I got both this and the new Quake1 release (OPK versions) working well. I had to use the more detailed instructions you included in the built-in OPK manual, which I didn't see mentioned here or on the Github. In GMenu2X, highlight the game icon and press Select to bring up the context menu where you can view the game manual w/ install instructions Thenesis made.

Also, for Quake 2, I went to the Yamagi readme which told me why I didn't have pak1.pak and pak2.pak: I had to get those from the patch file, as the CD ISO I had only had pak0.pak. Even with just pak0.pak, the game seemed to run fine but I wanted to be sure. Thanks again!

I will try some expansion packs tomorrow.
« Last Edit: October 31, 2017, 11:21:11 pm by Senor Quack »

Thenesis (OP)

Re: Quake 2 GLES (UPDATE 2017-10-31)
« Reply #12 on: November 01, 2017, 12:11:10 am »
Thanks for trying the releases and giving me your review.

I'm sorry for the very terse informations and documentations, I'm was a little bit fed up with this release yesterday (I really need to automate the 5 platforms build generation). But this is also a point I'm not very good for...

For the pak files, I only knew that the demo version works with only pak0.pak.

If you have any suggestion, you're welcome.


Re: Quake 2 GLES (UPDATE 2017-10-31)
« Reply #13 on: November 01, 2017, 09:14:21 am »
Any screenshots or videos? :D

Thenesis (OP)

Re: Quake 2 GLES (UPDATE 2017-10-31)
« Reply #14 on: November 05, 2017, 03:39:58 am »
Any screenshots or videos? :D

I added some screenshots on the release page:
I also updated the release notes with more installation informations.
The opks have been updated too because the mission packs did not work (shame on me, I didn't tested them through the menus).


Post a new topic
Post a new topic