Author Topic: pcsx4all 2.4 UPDATE 2017-01-05  (Read 91787 times)

Jenova

  • Posts: 1321
Re: pcsx4all 2.3
« Reply #60 on: June 05, 2016, 12:50:31 am »
yup... crazy release!

Senor Quack

  • Posts: 223
Re: pcsx4all 2.3
« Reply #61 on: June 05, 2016, 03:02:28 am »
I'm trying to run Spyro using the scph1001.bin BIOS, but when the game tries to access a memory card, the screen freezes, any ideas what I might be doing wrong?
Something to note is that the sounds work fine during the intro cutscene, but there is no music

I assume you are referring to the first 'Spyro the Dragon' game. I've verified that both the US NTSC (SCUS94228) and European PAL (SCES_01438) versions work as long as you are indeed using a BIOS (will not work with HLE).  Perhaps your image is corrupted? I am able to save and load games in both just fine. Let us know if problems persist and also let us know more specifics and the contents of your Spyro rom folder.

If you are referring to one of the later Spyro games, the European versions are copy-protected and require a .sub or .sbi file be present alongside the .cue file and named the exact same as the cue file, minus the extension of course.  Or, you could just use a USA version that doesn't need them.
« Last Edit: June 05, 2016, 03:29:02 am by Senor Quack »

Qubits

  • Posts: 146
Re: pcsx4all 2.3
« Reply #62 on: June 05, 2016, 04:53:54 am »
BTW for thoses who want to (re)discover the giant catalogue of the psx games, i highly recommend this site, they've got screenshots so it's easier to browse the psx library : http://www.musee-des-jeux-video.com/fr/sys/31-playstation/2/all
Pity it's French though.

Sorry, its me that has set it in french, the site is originally in English : http://www.video-games-museum.com/en/sys/31-playstation/2/all

Strauberry

  • Posts: 9
Re: pcsx4all 2.3
« Reply #63 on: June 05, 2016, 05:19:42 am »
I'm trying to run Spyro using the scph1001.bin BIOS, but when the game tries to access a memory card, the screen freezes, any ideas what I might be doing wrong?
Something to note is that the sounds work fine during the intro cutscene, but there is no music

I assume you are referring to the first 'Spyro the Dragon' game. I've verified that both the US NTSC (SCUS94228) and European PAL (SCES_01438) versions work as long as you are indeed using a BIOS (will not work with HLE).  Perhaps your image is corrupted? I am able to save and load games in both just fine. Let us know if problems persist and also let us know more specifics and the contents of your Spyro rom folder.


Ah, my mistake for not clarifying. I'm trying to emulate the first Spyro game, and just to be sure, I tried installing the US NTSC rom. This time, the music did play at the title screen, but as for the game itself, safe for the music, it completely froze when trying to access the memory cards. As for my flash image, it's likely not corrupted as I have upgraded to the latest firmware, but I'm not sure how I would find out if it would be corrupted to begin with. I placed the rom in "/media/data/local/home"
"Might as well, y'know? Never know, y'know? Hey... You know me I'm Toby Sand"

Senor Quack

  • Posts: 223
Re: pcsx4all 2.3
« Reply #64 on: June 05, 2016, 06:24:13 am »
Ah, my mistake for not clarifying. I'm trying to emulate the first Spyro game, and just to be sure, I tried installing the US NTSC rom. This time, the music did play at the title screen, but as for the game itself, safe for the music, it completely froze when trying to access the memory cards. As for my flash image, it's likely not corrupted as I have upgraded to the latest firmware, but I'm not sure how I would find out if it would be corrupted to begin with. I placed the rom in "/media/data/local/home"

What I meant by 'corrupted image' was your CD image of Spyro might be corrupted or flawed. It's not unusual because CD images are so huge and uploading to the GCW's internal storage is pretty slow and can time-out very easily.  Are you sure you have free space on your device and haven't used it all up copying PS1 CD images to it?

First, if you don't have any saved games you care about, you can try renaming/deleting your memory card files in /media/data/local/home/.pcsx4all/memcards/ folder and fresh ones will be created when you next run the emulator. You will lose your saved games if they're deleted, of course. If that doesn't work, you can delete the fresh ones and rename the originals back to their original names.  Then, I'd try the following:

1.) Verify you have a working ROM named as /media/data/local/home/.pcsx4all/bios/scph1001.bin and have it chosen instead of HLE in the emu settings.
2.) Verify different games than Spyro work before fighting with just one game. You haven't told us if you've gotten any other games to work.
2.) Try copying the Spyro image from your computer to a microSD card and see if that works on your GCW. it will be in /media/sdcard/WHEREVER   If it works, that means the game CD image in your home directory got corrupted or wasn't fully copied over.
3.) If that doesn't work, try a different Spyro game image. You can use a PSP Eboot .pbp if you like, or a regular .bin/.cue image, preferrably NTSC US.
4.) Remove the file /media/data/local/home/.pcsx4all/pcsx4all.cfg to reset your settings to defaults. Change BIOS setting back to scph1001.bin afterwards , of course, as Spyro won't work with HLE emulated bios.
« Last Edit: June 05, 2016, 06:27:46 am by Senor Quack »

Qubits

  • Posts: 146
Re: pcsx4all 2.3
« Reply #65 on: June 05, 2016, 06:27:44 am »
Yes, first you have to download a bios (scph1001.bin) and put it in the bios folder of your gcw (it's in /home/.pcsx4all/bios). Then i suggest you download the iso from the paradise of emulation if you see what i mean... Spyro has already been tested and is working in scph1001.bin mode as shown here : https://docs.google.com/spreadsheets/d/1maVTuSUzvoJcEe823vYJIVRJLs8BEL6AYtFidM4c36g/edit#gid=0

Qubits

  • Posts: 146
Re: pcsx4all 2.3
« Reply #66 on: June 05, 2016, 06:37:47 am »
BTW i have a good news for Mega Man fans, the X6 version is working if you download the .pbp rom (it's a rom made for the psp consoles which is basically just a single file instead of a .cue + .bin files), so you can play Mega Man X6 with a .pbp but only in HLE mode in the settings. I have tried other games that didnt work in HLE & scph1001.bin mode and they've worked with a .pbp rom so if your game doesnt work with a normal iso (cue + bin), try a .pbp and it might actually work.

Qubits

  • Posts: 146
Re: pcsx4all 2.3
« Reply #67 on: June 05, 2016, 11:59:17 am »
There is a big problem with scph1001.bin mode : When you press a direction it happens a lot that it doesnt record the " key up " event so the character will still keep on going on the direction you've pressed, either Up, Down, Left or Right, this is more obvious on shootemups, you can try Cotton Original - Fantastic Night Dreams (Japan) in scph1001.bin mode for exemple and see for yourself, sometimes the witch will keep moving in a direction even if you have stopped to touch the dpad but this problem happens with all games played in scph1001.bin mode. It doesnt happen in HLE mode and all other emulators that i've tested are working perfectly and not doing this problem.

Strauberry

  • Posts: 9
Re: pcsx4all 2.3
« Reply #68 on: June 05, 2016, 04:52:50 pm »
Ah, my mistake for not clarifying. I'm trying to emulate the first Spyro game, and just to be sure, I tried installing the US NTSC rom. This time, the music did play at the title screen, but as for the game itself, safe for the music, it completely froze when trying to access the memory cards. As for my flash image, it's likely not corrupted as I have upgraded to the latest firmware, but I'm not sure how I would find out if it would be corrupted to begin with. I placed the rom in "/media/data/local/home"

What I meant by 'corrupted image' was your CD image of Spyro might be corrupted or flawed. It's not unusual because CD images are so huge and uploading to the GCW's internal storage is pretty slow and can time-out very easily.  Are you sure you have free space on your device and haven't used it all up copying PS1 CD images to it?


Ah, now I see what you mean. I tried deleting both memory files in the memcards folder, and I also deleted the config file, as well as placing the .bin and .cue files of the rom in my SD card, but still no luck. As for storage, I currently have 8.9GB left, so I don't think that it's contributing to this. I'm using FileZilla to transfer files, so it is possible that the connection could time out and the image is thus tampered with, so I'll try to look more into that. I have gotten Silent Hill 1 and Crash Bandicoot 1 working, and they only suffer slight issues in terms of sound. I also tried using the EBOOT.PBP file, but that did not work either. To further explain, when I say that it freezes when it tries to access the memory cards, it simply displays the memory card box, but blank with no text or images, and the game freezes along with it.

Also regarding the post below yours, I have put the "SCPH1001.BIN" file in my bios folder, if that's what you mean
"Might as well, y'know? Never know, y'know? Hey... You know me I'm Toby Sand"

care16la20

  • Posts: 178
Re: pcsx4all 2.3
« Reply #69 on: June 05, 2016, 05:18:57 pm »
There seems to be something weird with controls expecially with directionals..

Ex Need For Speed there is no input
Road Rash commands dont respond properly making sometimes difficult to make turns

lunar

  • Posts: 22
Re: pcsx4all 2.3
« Reply #70 on: June 05, 2016, 07:17:18 pm »
Ah, now I see what you mean. I tried deleting both memory files in the memcards folder, and I also deleted the config file, as well as placing the .bin and .cue files of the rom in my SD card, but still no luck. As for storage, I currently have 8.9GB left, so I don't think that it's contributing to this. I'm using FileZilla to transfer files, so it is possible that the connection could time out and the image is thus tampered with, so I'll try to look more into that. I have gotten Silent Hill 1 and Crash Bandicoot 1 working, and they only suffer slight issues in terms of sound. I also tried using the EBOOT.PBP file, but that did not work either. To further explain, when I say that it freezes when it tries to access the memory cards, it simply displays the memory card box, but blank with no text or images, and the game freezes along with it.

Also regarding the post below yours, I have put the "SCPH1001.BIN" file in my bios folder, if that's what you mean

I had the same issue - turns out I had the BIOS in the wrong folder, causing it to run under HLE. Same is happening with you, except because your BIOS name is all capitalized. Make it lowercase and it should run fine.

Strauberry

  • Posts: 9
Re: pcsx4all 2.3
« Reply #71 on: June 05, 2016, 07:44:02 pm »
(deleted, redundant form of the message below)
« Last Edit: June 05, 2016, 07:52:43 pm by Strauberry »
"Might as well, y'know? Never know, y'know? Hey... You know me I'm Toby Sand"

Strauberry

  • Posts: 9
Re: pcsx4all 2.3
« Reply #72 on: June 05, 2016, 07:44:59 pm »
Ah, now I see what you mean. I tried deleting both memory files in the memcards folder, and I also deleted the config file, as well as placing the .bin and .cue files of the rom in my SD card, but still no luck. As for storage, I currently have 8.9GB left, so I don't think that it's contributing to this. I'm using FileZilla to transfer files, so it is possible that the connection could time out and the image is thus tampered with, so I'll try to look more into that. I have gotten Silent Hill 1 and Crash Bandicoot 1 working, and they only suffer slight issues in terms of sound. I also tried using the EBOOT.PBP file, but that did not work either. To further explain, when I say that it freezes when it tries to access the memory cards, it simply displays the memory card box, but blank with no text or images, and the game freezes along with it.

Also regarding the post below yours, I have put the "SCPH1001.BIN" file in my bios folder, if that's what you mean

I had the same issue - turns out I had the BIOS in the wrong folder, causing it to run under HLE. Same is happening with you, except because your BIOS name is all capitalized. Make it lowercase and it should run fine.

Thank you all so, so much! In the end, this is what made it work for me!
In retrospect, renaming the bios file is one the first things I should have done.
« Last Edit: June 05, 2016, 08:01:38 pm by Strauberry »
"Might as well, y'know? Never know, y'know? Hey... You know me I'm Toby Sand"

dmitry_smagin (OP)

  • Posts: 423
Re: pcsx4all 2.3
« Reply #73 on: June 06, 2016, 07:06:56 am »
UPDATE 2016-06-05:

- Added multi-CD boot/swap for for PSP Eboot .pbp images (senquack)
- Reset to default values in Settings menu (zear)
- Emulator is no more picky about case-sensitivity for bios name (zear)
GCW-Zero prototype, Dingoo a320, Ritmix rzx-50, Dingoo a380, Xperia Play

Qubits

  • Posts: 146
Re: pcsx4all 2.3
« Reply #74 on: June 06, 2016, 07:13:04 am »
No fix about the dpad ? it's a major problem...

Spaceman

  • Posts: 31
Re: pcsx4all 2.3
« Reply #75 on: June 06, 2016, 09:45:42 am »
Can I just asked those having control issues are you using eboot.pbp or .ISO files?
As I'm using .ISO and cue sheet and not seeing these issues outside the usual god awful dpad.
Nothing is getting stuck.
Was going to transfer to eboot for space saving but got a feeling the GCW isn't strong enough to pull the data out of a heavily compressed eboot.
I did notice ISO is definately booting quicker but that could be placebo.

Senor Quack

  • Posts: 223
Re: pcsx4all 2.3
« Reply #76 on: June 06, 2016, 10:42:41 am »
Can I just asked those having control issues are you using eboot.pbp or .ISO files?
Was going to transfer to eboot for space saving but got a feeling the GCW isn't strong enough to pull the data out of a heavily compressed eboot.

The control issue has nothing to do with using .pbp or .cue/.bin.. You can use whichever format you like. I haven't done any benchmarks/timings but I can't really notice much difference between Eboot pbp vs. uncompressed .bin.  Eboots save space, often 30% or more and though they need on-the-fly decompression they also require less data to be read off SD, which is slow in itself, and also have smaller disk-cache footprint.
« Last Edit: June 06, 2016, 10:47:16 am by Senor Quack »

Spaceman

  • Posts: 31
Re: pcsx4all 2.3
« Reply #77 on: June 06, 2016, 11:25:37 am »
Strange as I'm definately seeing lower framerates in both doom and resident evil 2 using eboot.
Doom has a lower framerate and resident evil 2 takes a hair longer too render a scene.

bear

  • Posts: 13
Re: pcsx4all 2.3
« Reply #78 on: June 06, 2016, 02:38:54 pm »
suggestions for next updates

1.add cheatpops.db for cheat
2.change select to select botton(select+b now)
3.add more memcards and memcard manager
4.fix load state bug(ie parasite eve some graphic glitches)
« Last Edit: June 07, 2016, 03:09:45 pm by bear »

kaio

  • Posts: 216
    • All about GCW-Zero on Russian + Repo
Re: pcsx4all 2.3
« Reply #79 on: June 06, 2016, 02:46:52 pm »
2.add run bios (memcard file copy/delete)
Just load BIOS file like an iso/bin game file.
It works.
GCW-Zero | JXD S602

 

Post a new topic
Post a new topic