Author Topic: gngeo port (neogeo emulator)  (Read 58284 times)

segakiki

  • Posts: 88
Re: gngeo port (neogeo emulator)
« Reply #20 on: September 01, 2013, 01:56:30 pm »
Amazing release thank you for your hard work pepone!
Is it possible to implement the test switch and also can I use unibios with this release?
Most games I have tried so far run amazing!

yoshi41

  • Posts: 474
Re: gngeo port (neogeo emulator)
« Reply #21 on: September 01, 2013, 01:57:56 pm »
I'll edit the first post and add your link to it, if you don't mind of course :)

Sure. I'm glad if it helps.

For those who are not familiar with clrmamepro (it's not really intuitive  ;), but very useful), here's a little tutorial...

http://boards.dingoonity.org/dingux-releases/final-burn-alpha-for-opendingux-(pre-release)/msg59033/#msg59033
Emulator packs and fact sheets for Wiz, Caanoo, Dingoo and Pandora.

fosamax

  • Posts: 328
Re: gngeo port (neogeo emulator)
« Reply #22 on: September 01, 2013, 02:33:57 pm »
From browsing the readme on the source :

  cyclone is written in arm assembler (default on arm target)
    starscream is written in x86 assembler (default on x86 target if nasm is found)
    gen68k is written in portable C (default in every other case)
   
    drz80 is written in arm assembler (default on arm target)
    raze is written in x86 assembler (default on x86 target if nasm is found)
    mamez80 is written in portable C  (default in every other case)

so it must be gen68k and mamez80 for sound.

doglush

  • Posts: 102
Re: gngeo port (neogeo emulator)
« Reply #23 on: September 01, 2013, 09:45:38 pm »
Many thanks for this release Pepone. (Viewpoint is working... That's enough :) )
Great emulator with a beautifull frontend.

Their is no 68K or Z80 cpu emulation "asm coded" for MIPS Cpu ?

« Last Edit: September 01, 2013, 09:54:25 pm by doglush »

pcercuei

  • Posts: 1673
    • My devblog
Re: gngeo port (neogeo emulator)
« Reply #24 on: September 02, 2013, 12:52:40 am »
The great thing about having a MIPS CPU, is that it's much more compiler-friendly than ARM; so there is no need for "asm coded" cores to get a good performance.

neilgeox

  • Posts: 15
Re: gngeo port (neogeo emulator)
« Reply #25 on: September 03, 2013, 11:02:50 am »
Great Release! I tried Neo Turf Masters last night though, and it seemed to have a glitch where the aiming and power are off. When you tee off, the shot is way overpowered and it clears the course! is there a setting or is it the rom at fault. Has anyone else experienced this? Other than that, it works brilliantly.   

trisoret

  • Posts: 27
Re: gngeo port (neogeo emulator)
« Reply #26 on: September 04, 2013, 01:16:43 am »
This is a great emulator as far as I tried, will future releases include analogue stick support?

Atlantis_Risen

  • Posts: 535
Re: gngeo port (neogeo emulator)
« Reply #27 on: September 13, 2013, 02:34:25 am »
This is a fantastic emulator! 

I do still get that neo turfmasters bug where the ball goes crazy and flies off the screen with every hit. :( It does this whether I have raster effects on or off.

qbertaddict

  • * Former Staff
  • The Doctor
  • Posts: 1184
    • about.me
Re: gngeo port (neogeo emulator)
« Reply #28 on: September 17, 2013, 09:34:46 am »
This runs great. A few bugs here and there but hopefully they will be worked out.

Inertia

  • Posts: 157
Re: gngeo port (neogeo emulator)
« Reply #29 on: September 19, 2013, 07:12:48 pm »
My (Fba romset) View point's load, I get the neo geo logo, then when the samy logo must appear -> go back to dingux.
Somebody can tell me wich viewpoint romset I must use?
THX :)
Very great debut for this cool emulator :)

Scoobysnaxx

  • Posts: 128
Re: gngeo port (neogeo emulator)
« Reply #30 on: September 27, 2013, 03:25:18 am »
Finally got around to trying this. Everything i throw at it runs beautifully. Thank you for this wonderful port. I very much enjoy the front end too!  ;D

I too was getting errors about the romset being too old (even after having successfully running them a first time). Once I moved everything to the home directory the problem disappeared. Thank you for the suggestion GhostWarrior

goldenegg

  • Posts: 56
Re: gngeo port (neogeo emulator)
« Reply #31 on: September 27, 2013, 06:57:12 am »
I'm having trouble with this one.   Every time I try to load a game, the emulator crashes.   I'm using the same rom set that I use on the Pandora, which checks out fine with the DAT.  I'm running the emulator from an external card.

Any ideas?

pepone (OP)

  • Posts: 16
Re: gngeo port (neogeo emulator)
« Reply #32 on: September 27, 2013, 09:32:06 am »
Strange.
Can you enable output logging in gmenu, and copy/paste the output here?

Atlantis_Risen

  • Posts: 535
Re: gngeo port (neogeo emulator)
« Reply #33 on: September 27, 2013, 01:20:10 pm »
Finally got around to trying this. Everything i throw at it runs beautifully. Thank you for this wonderful port. I very much enjoy the front end too!  ;D

I too was getting errors about the romset being too old (even after having successfully running them a first time). Once I moved everything to the home directory the problem disappeared. Thank you for the suggestion GhostWarrior

Do you play Neo Turfmasters?  I get a weird bug where every hit is 1000 times too powerful and the ball flies into orbit with every shot.  Adjusting various settings, like raster effects, hasn't helped.  It's my favorite Neo Geo game too. :(

hi-ban

  • Posts: 886
Re: gngeo port (neogeo emulator)
« Reply #34 on: September 27, 2013, 02:35:28 pm »
Do you play Neo Turfmasters?  I get a weird bug where every hit is 1000 times too powerful and the ball flies into orbit with every shot.  Adjusting various settings, like raster effects, hasn't helped.  It's my favorite Neo Geo game too. :(

I also get this bug. It does not happen always, though.

pepone (OP)

  • Posts: 16
Re: gngeo port (neogeo emulator)
« Reply #35 on: September 27, 2013, 04:48:59 pm »
I've never heard of this bug, so congrats to find a new one :) Looks like a integer over/underflow or something like that. I'll look into It.

Atlantis_Risen

  • Posts: 535
Re: gngeo port (neogeo emulator)
« Reply #36 on: September 27, 2013, 06:07:09 pm »
I've never heard of this bug, so congrats to find a new one :) Looks like a integer over/underflow or something like that. I'll look into It.

Thanks! :)  I had the same bug using neodroid for android.

pepone (OP)

  • Posts: 16
Re: gngeo port (neogeo emulator)
« Reply #37 on: September 27, 2013, 07:38:13 pm »
it's a port of gngeo, so...
« Last Edit: September 27, 2013, 07:42:34 pm by pepone »

Atlantis_Risen

  • Posts: 535
Re: gngeo port (neogeo emulator)
« Reply #38 on: September 27, 2013, 08:14:01 pm »
I'm just saying it isn't a problem that's exclusive to gngeo.

goldenegg

  • Posts: 56
Re: gngeo port (neogeo emulator)
« Reply #39 on: September 28, 2013, 05:09:26 am »
Strange.
Can you enable output logging in gmenu, and copy/paste the output here?

Sure.  Where will the log be output?  Is it on the internet SD or with the app on the external?