Author Topic: All we need is Löve  (Read 18825 times)

pcercuei (OP)

  • Posts: 1634
    • My devblog
All we need is Löve
« on: May 06, 2014, 11:18:10 pm »
Hi guys,

For those who don't know it, L?ve is "an *awesome* framework you can use to make 2D games in Lua. It's free, open-source, and works on Windows, Mac OS X and Linux": https://love2d.org/

It now runs on the GCW Zero. To use it, just launch the .zip of your L?ve game (it has to be a .zip) with the OPK that can be dowloaded in the repo.

Find it on http://www.gcw-zero.com/downloads
« Last Edit: May 06, 2014, 11:19:58 pm by pcercuei »

Shin-NiL

  • Posts: 355
    • Shin-NiL's Personal Web Page (Brazilian Portuguese)
Re: All we need is Löve
« Reply #1 on: May 06, 2014, 11:41:36 pm »
Good news! Is it using SDL2?

andmatand

  • Posts: 11
Re: All we need is Löve
« Reply #2 on: May 06, 2014, 11:49:02 pm »
HOLY GOATS YESSS I HAVE BEEN WAITING FOR THIS

THANK YOU :D

Greetdeath

  • Posts: 26
Re: All we need is Löve
« Reply #3 on: May 07, 2014, 01:52:36 am »
Sweet, downloading now, so many games to try out.

vonzippenstein

  • Posts: 49
    • vonzippenstein.com
Re: All we need is Löve
« Reply #4 on: May 07, 2014, 03:46:10 am »
You've made me very happy. Thank you.

Nebuleon

  • Guest
Re: All we need is Löve
« Reply #5 on: May 07, 2014, 04:12:17 am »
What's the version of L?ve you ported, and what's the version of Lua which underlies it?

I ask, because I cannot get Mari0 to run. It instead presents two sky-blue screens:

Code: [Select]
This game was made for a different version of LÖV
It may not be compatible with the running v

Code: [Select]
Error

main.lua:13: attempt to call field 'enumerate'
(a nil value)

Traceback

main.lua:13: in function 'load'
[C]: in function 'xpcall'

The repository has no version information for it.

pcercuei (OP)

  • Posts: 1634
    • My devblog
Re: All we need is Löve
« Reply #6 on: May 07, 2014, 07:35:43 am »
It's the latest version, 0.9.1. Most games were made for older versions, I think, and it looks like that breaking the API isn't a problem for them.

Nebuleon

  • Guest
Re: All we need is Löve
« Reply #7 on: May 07, 2014, 07:55:55 am »
That's a real shame.

I assume that's why Mari0 bundles a L?ve in its installers, and why there's a version field in the list of games using L?ve on love2d.org. But it can't be possible that all of those games that don't say 0.9.1 exactly don't work... Is it? ???

vonzippenstein

  • Posts: 49
    • vonzippenstein.com
Re: All we need is Löve
« Reply #8 on: May 07, 2014, 07:48:16 pm »
Anyone got a love example of input working on the Zero? Can't seem to get anything to respond on device.

Shin-NiL

  • Posts: 355
    • Shin-NiL's Personal Web Page (Brazilian Portuguese)
Re: All we need is Löve
« Reply #9 on: May 07, 2014, 10:04:59 pm »
Anyone got a love example of input working on the Zero? Can't seem to get anything to respond on device.

It looks like a SDL2 issue, I'm getting similar behavior on compiled code: http://boards.dingoonity.org/gcw-development/sdl2-issues-on-2014-05-05-toolchain/

andmatand

  • Posts: 11
Re: All we need is Löve
« Reply #10 on: May 07, 2014, 10:53:32 pm »
it can't be possible that all of those games that don't say 0.9.1 exactly don't work... Is it? ???

Games made for version 0.9.0 will still work, since 0.9.1 was mostly a bugfix version and didn't break compatibility.

But yeah, since it's not at version 1.0 yet, there are still a lot of compatibility-breaking changes being made to the API with each version (of course I think the plan is that by version 1.0 the API will be stable).

The nice thing about L?VE games is that you have the Lua code though, so if you're that determined you can always modify it to bring it up to 0.9.1 :)

Shin-NiL

  • Posts: 355
    • Shin-NiL's Personal Web Page (Brazilian Portuguese)
Re: All we need is Löve
« Reply #11 on: May 08, 2014, 02:09:33 am »
Anyone got a love example of input working on the Zero? Can't seem to get anything to respond on device.

It looks like a SDL2 issue, I'm getting similar behavior on compiled code: http://boards.dingoonity.org/gcw-development/sdl2-issues-on-2014-05-05-toolchain/

Now I'm almost sure it's a SDL2 issue, even my simple old tutorial code doesn't respond any keyboard event.

If anyone want to try, heres the zip. You're supposed to move the white ball with dpad and exit with select.

vonzippenstein

  • Posts: 49
    • vonzippenstein.com
Re: All we need is Löve
« Reply #12 on: May 08, 2014, 04:06:19 am »
Thanks Shin-NiL. Thought I was doing something wrong with the new version.

slapstick

  • Posts: 27
Re: All we need is Löve
« Reply #13 on: May 08, 2014, 08:11:29 am »
Yeah, I'm having the same input issues. I made a little test game (.zip, 4.3 KB), though. When it's working, pressing A should spawn another brick, and hitting B will remove all bricks.

SiENcE

  • Posts: 653
    • Crank Gaming (Dingux Apps)
Re: All we need is Löve
« Reply #14 on: May 08, 2014, 08:33:38 am »
@pcercuei: Nice work! I would be great when you can share the ported sources or a patch back to L?VE community. Do you used the experimental iOS port from slime as base?

There is a Subforum for ports: http://love2d.org/forums/viewforum.php?f=12

Maybe some of my old nl?ve games are still working with l?ve 0.9.1? http://crankgaming.blogspot.de/2011/02/nlove-070-final-love2d-for-dingoo.html

Keep on good work!

cheers
« Last Edit: May 08, 2014, 08:35:36 am by SiENcE »

pcercuei (OP)

  • Posts: 1634
    • My devblog
Re: All we need is Löve
« Reply #15 on: May 08, 2014, 08:40:27 am »
@pcercuei: Nice work! I would be great when you can share the ported sources or a patch back to L?VE community. Do you used the experimental iOS port from slime as base?
There is no patch. I didn't change a single line of code. This is the latest GIT version from the gles-experiments branch.

For the input issues, this seems to be related to SDL2 indeed, and I think I know the issue. If I have time soon I'll release a new OPK with the fixed SDL2 libs included so that people can test L?ve before we release a bugfix release of the firmware.
« Last Edit: May 08, 2014, 08:42:51 am by pcercuei »

SiENcE

  • Posts: 653
    • Crank Gaming (Dingux Apps)
Re: All we need is Löve
« Reply #16 on: May 08, 2014, 12:38:22 pm »
@pcercuei: Sounds awesome. You could post it on the l?ve subforum :).

Skyline969

  • Posts: 279
Re: All we need is Löve
« Reply #17 on: May 09, 2014, 06:58:35 am »
Anyone have any chance of getting Journey to the Center of Hawkthorne working for the Zero (Love version available in the comments)?

Lazarus404

  • Posts: 23
Re: All we need is Löve
« Reply #18 on: May 09, 2014, 10:33:46 am »
Okay guys, don't say I never do anything for you!

About four years ago, I started writing a book for the peeps at Corona Labs.  However, not long after I started writing, I landed a new job and life became too busy to finish it.  It just so happens, though, that of the chapters I completed, two were on using Lua.  I've been told they're very good, so I'd like to share them both with you guys.

Let me know if they help.  The only reason I write books is to help people; in this case, getting people into games development.

Cheers,
Lee

slapstick

  • Posts: 27
Re: All we need is Löve
« Reply #19 on: May 14, 2014, 07:01:21 am »
Hey everyone! I made a game in L?VE for the GCW Zero!

It takes place shortly after you have crash landed your ship onto an asteroid. Your ship is heavily damaged, but if you collect enough fuel, you just might be able to power its auto-repair systems. Your objective is to collect 10 blue energy quadrangles as quickly as possible. Due to some uncontrollable circumstances, you have lost motor control throughout your entire body. Luckily, your suit has backup AI! Unfortunately, that AI is very stupid. Will you ever return to Earth!?



Remember to post your high scores!

Download Now! (.zip, 48.85 KB)
« Last Edit: May 14, 2014, 09:41:52 am by slapstick »

 

Post a new topic