Dingoonity.org

GCW Zero => Releases => Topic started by: alekmaul on June 15, 2013, 09:56:54 am

Title: A5200 V1.0
Post by: alekmaul on June 15, 2013, 09:56:54 am
Hello all,
Here is a new emulator for GCW-ZERO, it is A5200, an Atari 5200 emulator :)

Picture (from Windows SDL version, the source code is compatible) :
(http://www.portabledev.com/media/GCW0/a5200/a5200_gcw_v10_1.png) (http://www.portabledev.com/media/GCW0/a5200/a5200_gcw_v10_2.png) (http://www.portabledev.com/media/GCW0/a5200/a5200_gcw_v10_3.png)

You can download here :
- A5200 GCW0 v1.0 : A5200 opk executables (http://www.portabledev.com/modules/download_gallery/dlc.php?file=508&id=1371286420)

Source code will be available soon on  my github

Enjoy :) !
Title: Re: A5200 V1.0
Post by: Seph817 on June 29, 2013, 10:00:43 am
Hey, thanks for all the great releases! I, however, cannot get A5200 to run on the SE. The log viewer says it can't find the bios. I have the bios and it's named 5200.rom. I've tried it in several locations. Is this still the correct name and where does it go?

Also, it seems like these opks are not allowing any settings to be saved. If I extract the opk and just link to the dge, I can play them and the settings save. Has anyone else had this issue? Thanks for any help.
Title: Re: A5200 V1.0
Post by: alekmaul on June 29, 2013, 10:18:17 am
Well..., extract from readme file :
Quote
Put a5200.opk to "apps" folder of inner flash-memory of your handheld.
Put bios named 5200.rom to "/boot/local/home" directory
Put your .A52 & .BIN games where you want.

 8)
Title: Re: A5200 V1.0
Post by: Seph817 on June 29, 2013, 03:19:03 pm
Thanks! Mine didn't have a readme. I had put it in the home/.a5200 folder. Haven't had to put a bios in just the home folder yet. That fixed it!
Title: Re: A5200 V1.0
Post by: Jonosborne on June 29, 2013, 04:38:57 pm
Does the 2600 also require a bios? It just crashes when you select the rom folder. 7200 works without bios.
Title: Re: A5200 V1.0
Post by: robert2098 on June 29, 2013, 11:17:42 pm
Does the 2600 also require a bios? It just crashes when you select the rom folder. 7200 works without bios.

The Atari 2600 does not have a BIOS so it must be another problem.

Robert
Title: Re: A5200 V1.0
Post by: Gaku_Kano on June 30, 2013, 12:42:25 am
alekmaul, do you plan to release a Dingoo version of these great emulators?
Title: Re: A5200 V1.0
Post by: segakiki on August 12, 2013, 10:14:07 pm
Has anyone else got a issue with the dpad and analogue stick conflicting with this?
I've tried turning analogue controls off/on in the menu but the problem still exists, its really noticeable on asteroids the craft keeps spinning in circles!
It seems to have started after upgrading the GCW firmware.
Title: Re: A5200 V1.0
Post by: alekmaul on August 14, 2013, 12:28:35 pm
OK, will check this problem. The game is ok when you disable analog stick in menu ?
Title: Re: A5200 V1.0
Post by: segakiki on August 14, 2013, 01:02:59 pm
OK, will check this problem. The game is ok when you disable analog stick in menu ?
No it makes no difference.
This is not the only emulator that I have noticed with the same problem,
Dcastaway also does it and also in fba the analogue stick does not work at all.
It started happening after the 22/7/13 firmware update.
I have tested my analogue stick in the hwtest and also scummvm and there are no problems at all.
It seems to be only affecting apps that use both the dpad  and analogue stick.
Also it seems to only happen during startup of a game, if I rotate the analogue stick a couple of times during play it seems to go back to normal control, and if I touch the analogue stick again by accident it starts spinning out of control again. (If that makes any sense!)
Title: Re: A5200 V1.0
Post by: Orion4874 on August 20, 2013, 08:26:31 am
Is anyone having any issues getting this emu running? I can't even get to the main screen to be able to pick a rom, it just crashes back to gmenu when I run it. I've tried different bios files with the same results but I don't think I need the bios to get the emulator to start, correct?
Title: Re: A5200 V1.0
Post by: alekmaul on August 20, 2013, 11:38:44 am
Well, just read carefully this thread, i answered regarding the bios file ...
Title: Re: A5200 V1.0
Post by: Orion4874 on August 21, 2013, 05:45:11 am
Ah, I see what I did. I assumed when you said put the bios in the /home dir it really meant the .5200 folder like the other emus use. Sorry about that!
Title: Re: A5200 V1.0
Post by: Prophet on April 07, 2014, 11:02:00 pm
Sorry to raise a somewhat dead topic, but I just used this emu for the first time today.

Have it working, but want to ask if anyone else is having:

-- choppy framerates? Ex. Stargate & Moon Patrol are choppy, and sound is off.
-- sometimes controls go crazy. Happened to me in Stargate.

Not sure Alekmaul is still working on these nice emulators, but would love to see new versions someday.
Title: Re: A5200 V1.0
Post by: surfi80 on April 08, 2014, 06:57:25 am
great job sir alekmaul  ;)
Title: Re: A5200 V1.0
Post by: Jindofox on December 09, 2015, 03:34:23 pm
Does anyone have a fresh link to this file?
Title: Re: A5200 V1.0
Post by: Spaceman on June 03, 2016, 06:09:01 pm
It's great all these emulators and all, but what would be really great is an actual working link.
You know, so people can actually use them.
There are actually very little working links to any of these OPK's on here.
Title: Re: A5200 V1.0
Post by: Aeter on June 04, 2016, 04:25:29 am
It's great all these emulators and all, but what would be really great is an actual working link.
You know, so people can actually use them.
There are actually very little working links to any of these OPK's on here.
http://pdroms.de/gcw-zero/a5200-v1-0-a5200-emu-for-gcwz
Title: Re: A5200 V1.0
Post by: Spaceman on June 04, 2016, 07:35:52 pm
Blimey!
Top man for finding those. I managed to get the 7800 as well
Title: Re: A5200 V1.0
Post by: Aeter on June 05, 2016, 03:22:41 am
Blimey!
Top man for finding those. I managed to get the 7800 as well
Yeah I think all of Alekmaul's zero releases are on there.
Pity he's not actively involved in the community anymore.
Title: Re: A5200 V1.0
Post by: Drem on February 27, 2018, 01:22:16 am
.
Title: Re: A5200 V1.0
Post by: Jutleys on April 26, 2018, 06:05:28 pm
@op why is all stuff released by alekmaul have dead links?