Author Topic: I destroyed my GCW0 with software  (Read 2326 times)

gameblabla (OP)

  • Posts: 1421
I destroyed my GCW0 with software
« on: December 12, 2016, 05:24:34 am »
So i don't know how but the motherboard is DEAD.
I was working on Virtual Jaguar and i had realized some games were requesting odd/weirds resolutions.
Power Drive Rally was one such game and it was using a resolution 640x240, meaning i had to use IPU scaling for that.

So i ran the emulator with Power Drive Rally and then the screen becomes slowly white.
I don't know how that phenomenon is called, LCD bleeding i think ?
I had experienced this before with Oswan but here, i was able to reproduce it every time i ran the game.
The first two time, i was able to power it off and get it back to normal.
I added some sanity checks and i thought it would fix the problem but it didn't...

The third time, i tried to power off the unit and it stayed dead for good.
I couldn't power it on anymore.

At first, i thought i had just destroyed the screen but it seems like the motherboard also got damaged.
The LED did not turn on, there was nothing.
When i'm plugging it back to my computer, the LED becomes red for a time and then it turns off.

I have never experienced something like this.
It does seem to look like an issue with the IPU unit because when i encountered the same issue on Oswan,
i was trying to get it to work again.

So there it is, my GCW0 died.
And so are my contributions to this community.

Any ideas ?
« Last Edit: December 12, 2016, 05:29:12 am by gameblabla »


  • Posts: 1689
    • My devblog
Re: I destroyed my GCW0 with software
« Reply #1 on: December 12, 2016, 01:20:28 pm »
Charge it, then press Reset for 60 seconds.
Also, you might want to try the rescue CD; if it detects your Zero, then it's not dead.

gameblabla (OP)

  • Posts: 1421
Re: I destroyed my GCW0 with software
« Reply #2 on: December 13, 2016, 01:12:21 am »
Thanks pcercuei.
I may have spoken too soon.

I couldn't reach the Reset button from the outside so i had to disassemble it and press it.
Now it works just fine.


Post a new topic