Author Topic: GCW - black screen [no telnet, cant reflash]  (Read 1575 times)

Bertuga (OP)

  • *
  • Posts: 22
GCW - black screen [no telnet, cant reflash]
« on: April 03, 2017, 04:42:43 pm »
Hi guys!

My gcw zero stopped working. When I turn it on, i got just a black screen, not even the backlight is on. I tried acessing it through telnet, no success.

When i boot it with select pressed, the PC recognizes it. I tried reflashing it with the recovery CD, with 3 different microSD cards, but I always get this screen before the "flashing error" message: https://1drv.ms/i/s!Aq9cJHPu9qKahwDkftthtyGzyIQ0

I don't know what more I could do. This GCW is cursed for sure! I had to swap the LCD, cause it arrived with an blue line on it, then the battery died, after i swapped the battery, the internal clock never worked again.

If anyone has any idea of what could be, or any test i can run to help recover it, i'll gladly try it. I loved the gcw, but i just got unlucky, i guess.

pcercuei

  • ***
  • Posts: 1397
    • GitHub
Re: GCW - black screen [no telnet, cant reflash]
« Reply #1 on: April 03, 2017, 05:20:16 pm »
Try with different USB cables and/or from a different computer. I know it never worked with some USB cables for me, and some others here reported the same problem.

mth

  • *
  • Posts: 297
Re: GCW - black screen [no telnet, cant reflash]
« Reply #2 on: April 03, 2017, 05:31:02 pm »
To skip the flashing process, you can use the "assemble_images.sh" script from the imager tool git repo to combine the flash images into a single SD card image. Then you can write that onto a new SD card (raw sector write, not as a file) and put the card in the internal SD slot of the Zero.

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #3 on: April 03, 2017, 06:00:03 pm »
Try with different USB cables and/or from a different computer. I know it never worked with some USB cables for me, and some others here reported the same problem.

Oh, i forgot to say, i tried it, pc and notebook, two different cables.

To skip the flashing process, you can use the "assemble_images.sh" script from the imager tool git repo to combine the flash images into a single SD card image. Then you can write that onto a new SD card (raw sector write, not as a file) and put the card in the internal SD slot of the Zero.

Gonna try this.

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #4 on: April 04, 2017, 02:25:13 pm »
Didnt work. =/

Tried two microSDs, and after it didnt work, tried reflashing, same screen. And still no backlight after turning it on. Its not a screen brightness issue either.

Any ideas?

pcercuei

  • ***
  • Posts: 1397
    • GitHub
Re: GCW - black screen [no telnet, cant reflash]
« Reply #5 on: April 04, 2017, 02:39:07 pm »
How did you create the SD image? How did you write it to the SD card?

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #6 on: April 04, 2017, 10:27:15 pm »
How did you create the SD image? How did you write it to the SD card?

I used the sh script from the repository. I wrote on the sd in two ways: one time with an hex editor, and one time with win32diskimager.

The files (mbr, uiboot, system and data) were downloaded from the gcw site.

pcercuei

  • ***
  • Posts: 1397
    • GitHub
Re: GCW - black screen [no telnet, cant reflash]
« Reply #7 on: April 05, 2017, 12:58:54 pm »
So you used the sh script on Linux to create the image, then booted to Windows to write it? ...

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #8 on: April 05, 2017, 02:29:47 pm »
So you used the sh script on Linux to create the image, then booted to Windows to write it? ...

I dont have Linux on my PC and Notebook, I ran the script on my server, downloaded the sd_image.bin and wrote with windows.

mth

  • *
  • Posts: 297
Re: GCW - black screen [no telnet, cant reflash]
« Reply #9 on: April 06, 2017, 08:47:09 am »
Have you double checked that the boot loader image you're using matches the hardware revision? Using the v1.1 (prototype) firmware on v2.0 (mass production) hardware or vice versa will lock up the device very early in the boot sequence, because the SDRAM init is different. The hardware revision number is printed on the PCB.

When you say telnet is not working, does that mean you can connect but not login, the connection is refused, the IP address of the Zero is unreachable, or the network interface for ethernet-over-USB doesn't appear on your PC at all? Note that a freshly flashed file system will spend the first few minutes after boot resizing the file system and networking won't be available until the resize has finished, so please allow 5-10 minutes (depending on how large and fast the SD card is) after power on before testing.

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #10 on: April 08, 2017, 10:00:55 pm »
Yep, 2.0. I left it for a few minutes, nothing happened, black screen, no backlight.

About telnes: I got a connection timeout, the device doesnt even appear on the devices listing, unless I turn it on holding Select. The gcw doesnt turn off too, i have to remove the battery (i soldered some wires i used on arduino, so it is easy to remove the cables).

So, the gcw is detected in the usb flashing mode, but it is not when you power it on as a normal device.

mth

  • *
  • Posts: 297
Re: GCW - black screen [no telnet, cant reflash]
« Reply #11 on: April 09, 2017, 10:00:28 am »
My guess would be that there is a problem with the SDRAM. The flash script first looks for the right vendor and device IDs on the USB bus (probe), then sends a small program to initialize the SDRAM. If the flashing stops after the probe, then it's probably the SDRAM init that fails.

That could be caused by a revision mismatch, but you already ruled that out. It could be caused by a USB hub or cable problem in transferring the program, but then the SD card that was written on PC would have worked. So it might be the hardware that is broken, unfortunately.

Bertuga (OP)

  • *
  • Posts: 22
Re: GCW - black screen [no telnet, cant reflash]
« Reply #12 on: April 09, 2017, 02:10:31 pm »
=/

Well, to the trash it goes. I was so unlucky with this. I have an A320 that still works, and GCW had so many issues. I'd try to get another, if it wasnt so hard to get one in Brazil.

Thanks for all the help guys!

 

Post a new topic