Author Topic: Dead unit? Power circuit? No red LED when charging :(  (Read 741 times)

David Knight (OP)

  • Posts: 577
Dead unit? Power circuit? No red LED when charging :(
« on: February 16, 2015, 11:07:49 pm »
Well I think I may have properly broken my gcw0 :(

I think I ran into the IPU bug with strange resolutions whilst removing the left 8 pixel bar from the sega master system emulation in Genesis Plus GX.

With the USB charger plugged in to the computer the screen faded from black to mostly white then the unit went dead. The red light no longer comes on when plugged in.

I have tried pressing reset for 60 seconds.

As no red light when plugged in I'm thinking I've overloaded the power.

UPDATE
Suspected low battery charge problem. I'd plugged the unit in as it was almost out of power.
After the unit became unresponsive I unplugged it and left it for a few minutes, occasionally trying to turn on the unit. I pressed reset button for 60 seconds a few times, still nothing. I then left it for around 30 minutes unplugged. Then plugged it in after about 30mins and the red indicator came back on :).
« Last Edit: February 16, 2015, 11:51:38 pm by David Knight »