Author Topic: Bizarre lag / freezing issues related to storage?  (Read 918 times)

glimmer (OP)

  • Posts: 119
Bizarre lag / freezing issues related to storage?
« on: December 15, 2013, 10:06:00 pm »
As I spend time FTPing files to the Zero or moving them between storage devices over telnet, I keep running into problems where output from the Zero will simply stop.

Via FTP, xferring any file over a few megabytes may or may not cause the FTP session to "hang" indefinitely. Moving "large" ( > 10MB or so) files from one SD card to the other can cause the same problem. It's like the Zero is blocking on storage, but FTP or telnet sessions don't always recover. I've waited up to ten minutes for a given file of 20-30 MB to finish uploading to the Zero, at which point I finally give up, power down the Zero, and pop the SD card into a real computer.

Via telnet, I can usually cause an active session to start responding again via SIGINT (Ctrl+C), but not always. I've had to kill off and restart telnet sessions. I have no idea if it's linked, but dmesg is usually filled with errors like these:
Code: [Select]
[  110.704000] jz4760fb_interrupt_handler, InFiFo0 underrun
[  110.704000] jz4760fb_interrupt_handler, InFiFo1 underrun

pcercuei

  • Posts: 1676
    • My devblog
Re: Bizarre lag / freezing issues related to storage?
« Reply #1 on: December 15, 2013, 10:15:28 pm »
The SD driver is a piece of crap, it's as simple as that (note that the error is unrelated).

glimmer (OP)

  • Posts: 119
Re: Bizarre lag / freezing issues related to storage?
« Reply #2 on: December 16, 2013, 11:15:30 pm »
The SD driver is a piece of crap, it's as simple as that (note that the error is unrelated).
Forever, or can we hope for a fix? ;)

pcercuei

  • Posts: 1676
    • My devblog
Re: Bizarre lag / freezing issues related to storage?
« Reply #3 on: December 16, 2013, 11:36:31 pm »
Fixing the SD card driver is pretty high on the TODO list, so it will eventually happen.