Author Topic: Quake1-GLES  (Read 11427 times)

Optimus

  • Posts: 107
Re: Quake1-GLES
« Reply #20 on: June 16, 2014, 11:51:36 am »
To me it seems to slow down when looking far at more open scenes with lot's of geometry. Look close at a wall and it's smoother.

Could be many reasons.
- FPU when more visible geometry? Visibility calculations?
- Something to do with more texture fetching per frame? More open scene is more visible textures at the same time.
If Software Quake and Quake 2 are already smoother, then maybe it's not FPU. So, some bottleneck hit in the GPU, that you simple don't have on software rendering?

panshuai0

  • Posts: 83
    • My Hocoslamfy high score is 40. I Love My Gcw Zero
Re: Quake1-GLES
« Reply #21 on: June 16, 2014, 12:23:56 pm »
Strange, it doesn't work. Even when I tried with the version I just bought from steam.

I copy the pak files to the respective directories, for example pak0.pak and pak1.pak to home/.quake/id1
I move the cursor to the id1 and press select and it returns me back to launcher.
What am I doing wrong?
Hey! Friends! Ask you is how to solve this problem?
I told you the case, back to launcher....
I follow the instructions to do, the result is not working .... I'm frustrated, because I like Quake, I want to how to make him work. . .
My Hocoslamfy high score is 40. I Love My Gcw Zero

Malleus

  • Posts: 67
Re: Quake1-GLES
« Reply #22 on: June 16, 2014, 12:57:54 pm »
Hey! Friends! Ask you is how to solve this problem?
I told you the case, back to launcher....
I follow the instructions to do, the result is not working .... I'm frustrated, because I like Quake, I want to how to make him work. . .
rename the files to lower case and try again.
in windows you might need to rename them to something else first and then back as it doesnt treat upper and lowercase all that good.

rename PAK1.PAK -> pak1.pak and so on

in windows you might need to rename PAK1.PAK -> temp.tmp -> pak1.pak and so on

havent tried it myself but thats what I think he meant.
« Last Edit: July 04, 2014, 09:34:53 am by Malleus »

Pickle (OP)

  • Posts: 30
Re: Quake1-GLES
« Reply #23 on: June 16, 2014, 03:21:02 pm »
To me it seems to slow down when looking far at more open scenes with lot's of geometry. Look close at a wall and it's smoother.

Could be many reasons.
- FPU when more visible geometry? Visibility calculations?
- Something to do with more texture fetching per frame? More open scene is more visible textures at the same time.
If Software Quake and Quake 2 are already smoother, then maybe it's not FPU. So, some bottleneck hit in the GPU, that you simple don't have on software rendering?

There are probably gains to be made on the driver side. Work has gone into making it render correctly but I think nothing has been done to optimize.
Like i said before ive tried to add different things to make it faster. It has degenerate triangle fans. I convert triangle fans to strips and degenerate them with the other triangle strips. Then I can issue the draw command one time.
Textures are converted to 16 bit, which should save on memory.
States are tracked on the cpu side to minimize driver interactions.
One thing i did not added was VBO's, which i couldnt see a good way to manage without doing to much work. And for the most part i havnt seen add much gain in the long run with other projects.

Some other ideas to try. The shadows for the monsters can be turned off from the config file. It also might be worth turning off multitexture, which i think was -nomtex. Multitexture can be slower than 2 pass for some reason on some drivers. I believe i tested it on gcw and saw no change.

panshuai0

  • Posts: 83
    • My Hocoslamfy high score is 40. I Love My Gcw Zero
Re: Quake1-GLES
« Reply #24 on: June 17, 2014, 03:33:10 am »
Hey! Friends! Ask you is how to solve this problem?
I told you the case, back to launcher....
I follow the instructions to do, the result is not working .... I'm frustrated, because I like Quake, I want to how to make him work. . .
rename the files to lower case and try again.
in windows you might need to rename them to something else first and then back as it doesnt treat upper and lowercase all that good.

rename PAK1.PAK -> pak1.pak and so on

in windows you might need to rename PAK1.PAK -> temp.tmp -> pak1.pak and so on

havent tried it myself but thats what I think he meant.
[/quote] ;DHi, thank you very much! You explain in great detail, Quake has been successfully working in my gcw zero!
Quake I try to add cd background music, but the music does not work ...
No background music is not perfect ah!
Luckily I came out of the sight adjustment.
My Hocoslamfy high score is 40. I Love My Gcw Zero

vonzippenstein

  • Posts: 49
    • vonzippenstein.com
Re: Quake1-GLES
« Reply #25 on: July 04, 2014, 04:38:03 am »
I could not for the life of me get the game to launch through the OPK. It just refused to find the pak files. I tried uppercase, lowercase, and shuffled them all around. I tried everything I could think of but it was no use. As far as I could figure the launcher was looking in a directory I don't have. Instead I had to unpack the OPK and create a link to circumvent the launcher.

At the top of the launcher it says that it's checking the directory: "/user/local/home/.quake1/"
But the way my GCW-Zero is configured it made the directory in: "/media/data/local/home/.quake1"

Did anyone else have this problem? Is there something wrong with my default directory structure?

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #26 on: July 04, 2014, 06:41:02 am »
@ vonzippenstein: you need to put the Quake 1 pak files in the $home/.quake/id1 folder and not in the $home/.quake... I put pak0.pak and pak1.pak (all in lowercase) in the "id1" folder and the game runs correctly! ;)

PS: for the Quake missions paks you need to use the folders $home/.quake/armagon and $home/.quake/dissolution

vonzippenstein

  • Posts: 49
    • vonzippenstein.com
Re: Quake1-GLES
« Reply #27 on: July 04, 2014, 07:27:51 am »
Yeah I tried that. I went as far as putting uppercase and lowercase paks files in both the /.quake/ and /id1/ folders just in case. Still didn't work. I'm starting to think it's a bigger problem. The Quake 2 opk, which used to run fine, was encountering similar problems and unable to start. I unpacked the opk and made a link and now it works. Even loads my old saves. Maybe my unit just hates opks.

[edit] All this stuff aside. Thanks for some Quake on the Zero. It's one of my favorite games of all time.

[edit] Problem was common. I missed the Quake 2 thread that discusses my exact issue.
« Last Edit: July 04, 2014, 04:36:04 pm by vonzippenstein »

Homeplanet

  • Posts: 28
Re: Quake1-GLES
« Reply #28 on: July 21, 2014, 11:22:21 pm »
Would Hexen 2 work with this? it uses the same engine
ARGHGHEHGHGH - Chewbacca

Words to live by

Vato

  • Posts: 72
Re: Quake1-GLES
« Reply #29 on: July 28, 2014, 02:18:39 pm »

zear

  • * Moderator
  • Posts: 2381
Re: Quake1-GLES
« Reply #30 on: July 28, 2014, 10:11:13 pm »
Would Hexen 2 work with this? it uses the same engine
Hexen 2 doesn't use the same engine. It uses the same renderer. The rest of the game code is custom and it requires a separate game port. See above post.

Homeplanet

  • Posts: 28
Re: Quake1-GLES
« Reply #31 on: July 29, 2014, 02:12:38 pm »
Yep, my bad. Could somebody direct me to the opk for Hexen 2?
ARGHGHEHGHGH - Chewbacca

Words to live by

zear

  • * Moderator
  • Posts: 2381
Re: Quake1-GLES
« Reply #32 on: July 29, 2014, 07:06:38 pm »