Author Topic: Quake1-GLES  (Read 11530 times)

Pickle (OP)

  • Posts: 30
Quake1-GLES
« on: June 07, 2014, 09:51:49 pm »
Here is a peek at the quake 1 gles port ive worked over for some time. now running on the GCW:

http://pickle.gp2x.de/gcw/quake1gles.opk

There is a couple ways to start using it.
1. Run the opk and let it create the folders and paths (then quit the launcher with the start button)
1a. Create the path $home/.quake1/id1

2. Copy .pak's to the right folder under $home/quake1. For example original data would go under id1. I created folders for the expansion packs called armagon and dissolution. Use original full game data, shareware is likely not to work.

3. Run the opk, which will bring up the frontend. The directories at the current location will show in the list. They will show regardless if data is there or not. If you dont want to see some of them just delete the folders.

4. To run select the folder and then hit the select button. If all goes right then you should see the game launch. If not it kicks back to the frontend.


Frontend:
select: launch game
start : quit
« Last Edit: June 09, 2014, 02:18:22 pm by Pickle »

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #1 on: June 08, 2014, 12:43:45 am »
Thanks a lot for your work! :)

I made a quick test... the engine seems to work well... the texture filtering and shading are applied correctly... the fps isn't stable, sometimes the animations are a little "jerky" (maybe an extra code optimization could help in this way)


Pickle (OP)

  • Posts: 30
Re: Quake1-GLES
« Reply #2 on: June 08, 2014, 01:03:31 am »
thanks, ive put in a number of optimizations to get a little bit faster here and there and I dont know thats theres much else id can or be willing to do.
You could try turning off use_vsync in eglport.cfg.

NecroPheles

  • Posts: 8
Re: Quake1-GLES
« Reply #3 on: June 08, 2014, 01:14:08 am »
Hey, thanks a lot for porting that one  ;D well done ;)

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #4 on: June 08, 2014, 07:17:49 am »
thanks, ive put in a number of optimizations to get a little bit faster here and there and I dont know thats theres much else id can or be willing to do.
You could try turning off use_vsync in eglport.cfg.

As you suggested, I turned off the vsync (use_vsync=0), but the frame rate remains the same (a "strange" thing is that the v-sync seems operative anyway).

PS: to make a test I tried to reduce the game screen area (using in-game config settings) and I verified that the animations had the same slowdowns in the same points (I'm not a big expert, but, in theory, if the slowdowns are caused from the GPU overloaded, decrease the active screen area should improve the fps)

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #5 on: June 08, 2014, 07:56:37 am »
You can use this png as icon... obviously, if you like it! :)
« Last Edit: June 08, 2014, 06:19:49 pm by Gab1975 »

deBeauharnais

  • Posts: 30
Re: Quake1-GLES
« Reply #6 on: June 09, 2014, 12:21:37 am »
Thanks for the port!

I tried it, everything seems to work. I however have some remarks:
- I found quiet illogical the use of start and select in the menus. If I understood well, pressing start is used to enter the selected option, and select is used to come back. Except to open the menu at first, where you need to press select, and not start. I would suggest that you use start to open the menu while in-game, and then the usual a/b to enter/come back the options. That's what used in chocolate doom, quake II, etc., and it's more instinctive. Oh, and "start" again to automatically discard changes, close the menu and go back to the game.
- The game slows down when rotating the camera around (left/right), but that's not very important.
- Maybe a frontend on the first menu, or at least a quake inspired background.

Thanks again, will test more soon

Korben_Dallas

  • Posts: 4
Re: Quake1-GLES
« Reply #7 on: June 09, 2014, 10:24:13 am »
Can't see the .opk. Where is it?

Thanks in advance!

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #8 on: June 09, 2014, 10:26:28 am »
here... ;)

Korben_Dallas

  • Posts: 4
Re: Quake1-GLES
« Reply #9 on: June 09, 2014, 10:30:33 am »

Nebuleon

  • Guest
Re: Quake1-GLES
« Reply #10 on: June 09, 2014, 11:00:46 am »
For some reason, Pickle never https* his links, so they're not automatically linked.

Pickle should learn to http his links.

For the record, the link was in the 2nd line of the 1st post.

_________
* 'to http' /h'tep/, transitive verb. To place http:// in front of a Web address, in order for it to be recognised as such by automatic linking algorithms.

Pickle (OP)

  • Posts: 30
Re: Quake1-GLES
« Reply #11 on: June 09, 2014, 02:19:13 pm »
sorry overlooked that, added it now

Scoobysnaxx

  • Posts: 128
Re: Quake1-GLES
« Reply #12 on: June 10, 2014, 03:23:10 am »
Thank you Pickle! Can't wait to test this one out.

Optimus

  • Posts: 107
Re: Quake1-GLES
« Reply #13 on: June 10, 2014, 08:35:20 am »
Strange, it doesn't work. Even when I tried with the version I just bought from steam.

I copy the pak files to the respective directories, for example pak0.pak and pak1.pak to home/.quake/id1
I move the cursor to the id1 and press select and it returns me back to launcher.
What am I doing wrong?

Optimus

  • Posts: 107
Re: Quake1-GLES
« Reply #14 on: June 10, 2014, 08:49:08 am »
Ok, I found it. Linux is case sensitive. They were all capital from dos.

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #15 on: June 13, 2014, 09:10:06 am »
You could try turning off use_vsync in eglport.cfg.

I don't know if it's possible (in this specific case)... can you add the triple buffer support to improve the frame rate?
« Last Edit: June 13, 2014, 09:14:56 am by Gab1975 »

endercraft4

  • Posts: 35
Re: Quake1-GLES
« Reply #16 on: June 13, 2014, 10:37:20 pm »
Thanks for porting this!
I love that I am able to play quake on the go.
Sadly it's fps drops when near a few enemies.
Anyway, its awesome, an I love playing my mod I'm working on with the zero.
 :)

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #17 on: June 14, 2014, 05:39:28 am »
Sadly it's fps drops when near a few enemies.

If you make a test, you can see that the fps slowdown is about the same also when the active screen size is reduced... so, I don't know if it's directly related to the 3D scene rendering! It would be useful understand where is the "bottleneck"...

PS: in any case, enable the triple buffer should improve the fps in the "critic situations" (with the v-sync on).
« Last Edit: June 14, 2014, 05:41:02 am by Gab1975 »

zear

  • * Moderator
  • Posts: 2381
Re: Quake1-GLES
« Reply #18 on: June 14, 2014, 11:43:52 am »
JohnnyOnFlame's Quakeforge port (unreleased) which uses a software renderer scores 60fps at any situation. Thus, until I get a counterevidence, I'm going to claim all the framedrop in GLQuake comes from the 3D rendering.

As for the triple-buffer, I don't think that works in GPU accelerated software. IIRC this is only a feature supported in SDL (for now).

Gab1975

  • Posts: 1165
Re: Quake1-GLES
« Reply #19 on: June 14, 2014, 02:09:09 pm »
JohnnyOnFlame's Quakeforge port (unreleased) which uses a software renderer scores 60fps at any situation. Thus, until I get a counterevidence, I'm going to claim all the framedrop in GLQuake comes from the 3D rendering.

It's a bit "strange"... Quake was one of the first PC games which used the 3D OpenGL hardware acceleration... the Vivante GC860 isn't a power prodigy, but it's clearly more advanced than the first "old" 3Dfx Voodoo (this graphic card was able to run perfectly Quake in the VGA resolution)...

 

Post a new topic