Author Topic: Port request: mxkp (RPGMaker XP player)  (Read 1890 times)

glimmer (OP)

  • *
  • Posts: 119
Port request: mxkp (RPGMaker XP player)
« on: January 08, 2014, 06:37:36 pm »
https://github.com/Ancurio/mkxp

This looks considerably more complete than EasyRPG. It could use a few PC-side tools for music conversion--I don't see any provided--but it's already been used for at least one commercial game.

Juan

  • *
  • Posts: 123
Re: Port request: mxkp (RPGMaker XP player)
« Reply #1 on: January 09, 2014, 08:44:53 pm »
I played thru To The Moon on x86_64, no hiccups.

GuyInDogSuit

  • *
  • Posts: 65
Re: Port request: mxkp (RPGMaker XP player)
« Reply #2 on: January 11, 2014, 06:52:43 am »
Being able to play the Aveyond games on my GCW Zero would rock!
"We are all searching for others whose demons play well with ours."

zear

  • * Moderator
  • Posts: 2379
Re: Port request: mxkp (RPGMaker XP player)
« Reply #3 on: January 11, 2014, 12:08:37 pm »
Due to the library dependencies (OpenGL, SDL2), the port is currently impossible.

pcercuei

  • ***
  • Posts: 1428
    • My devblog
Re: Port request: mxkp (RPGMaker XP player)
« Reply #4 on: January 11, 2014, 12:50:24 pm »
SDL2 could be ported (it's on the TODO list). The problem is more that they list OpenGL 2.0 as a requirement, while we only have OpenGL ES 1.1 or 2.0. OpenGL ES 2.0 is based roughly on OpenGL 2.0, so unless they use the fixed-function rendering pipeline, it should be rather easy to adapt. You'd better ask them about GL ES 2.0 then.

 

Post a new topic
Post a new topic