Author Topic: WiFi doesn't work with symbols.  (Read 1170 times)

glimmer (OP)

  • Posts: 119
WiFi doesn't work with symbols.
« on: October 26, 2014, 07:05:15 pm »
It looks like you're using either shell calls or something else that needs special-character escaping in the new Connect utility. However it works, it doesn't with properly random WPA2 keys with special characters.

I finally got it working with my local network by finding the Connect settings under /media/data/local/home/.local/share/gcwconnect/networks , editing the file, and replacing the double quotes around the WPA2 key with single quotes.

Of course, anyone with single quotes in their WPA2 key is going to be out of luck.
« Last Edit: October 27, 2014, 03:50:40 pm by glimmer »

glimmer (OP)

  • Posts: 119
Re: WiFi doesn't work with symbols.
« Reply #1 on: December 31, 2014, 06:11:46 pm »
It looks like you're using either shell calls or something else that needs special-character escaping in the new Connect utility. However it works, it doesn't with properly random WPA2 keys with special characters.

I finally got it working with my local network by finding the Connect settings under /media/data/local/home/.local/share/gcwconnect/networks , editing the file, and replacing the double quotes around the WPA2 key with single quotes.

Of course, anyone with single quotes in their WPA2 key is going to be out of luck.
Any plans to fix this issue?

pcercuei

  • Posts: 1667
    • My devblog
Re: WiFi doesn't work with symbols.
« Reply #2 on: January 01, 2015, 10:19:17 am »
Please make a proper bug report at http://github.com/gcwnow/buildroot
Otherwise it's impossible for us to track down all those small issues; I already forgot that this bug existed.