Author Topic: Uae4All status  (Read 21052 times)

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #20 on: May 04, 2014, 08:36:33 pm »
I didn't, but I've done now with no result  :'(

I don't know if this is your case, but some of the latest executables (which you tried) may cause trouble for the system stability...did you try to delete them (with the related config-dir in the $home folder)?

In the worst case, you'll have to reflash your console... with the Pcercuei Rescue Disc the operation should be simple!
(Obviously, you could try to reflash only the system partition, so that  your data aren't trashed)

PS: a provisional solution could be downgrade the firmware with the 2013-10-04 release...
« Last Edit: May 04, 2014, 09:48:14 pm by Gab1975 »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #21 on: May 04, 2014, 09:53:26 pm »
I didn't, but I've done now with no result  :'(

I don't know if this is your case, but some of the latest executables (which you tried) may cause trouble for the system stability...did you try to delete them (with the related config-dir in the $home folder)?

In the worst case, you'll have to reflash your console... with the Pcercuei Rescue Disc the operation should be simple!
(Obviously, you could try to reflash only the system partition, so that  your data aren't trashed)

PS: a provisional solution could be downgrade the firmware with the 2013-10-04 release...

I've not upgrade since last stable firmware. I'll try deleting executables and config files, but I don't see the relation.

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #22 on: May 05, 2014, 08:04:41 am »
I've not upgrade since last stable firmware. I'll try deleting executables and config files, but I don't see the relation.

Now, you can try with the new fixed firmware! :)

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #23 on: May 05, 2014, 08:37:24 am »
I've not upgrade since last stable firmware. I'll try deleting executables and config files, but I don't see the relation.

Now, you can try with the new fixed firmware! :)

I've tried. Same issue with fixed firmware  ???

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #24 on: May 05, 2014, 09:41:01 am »
I've tried. Same issue with fixed firmware  ???

I hope with the help of Mth and other expert guys you will solve soon your issue!

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #25 on: May 05, 2014, 12:14:23 pm »
Yesterday my GCW0 begun to go crazy:


I'll wait for the next firmware release before continue testing. Latest compilation tests were unstable and I'm afraid they are corrumption related

oh, that's bad to hear  :-\

...hope you'll get your gcw0 fixed soon!

edit: good to see that your gcw0 is alive again ;)
« Last Edit: May 05, 2014, 04:18:45 pm by sm0ky »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #26 on: May 05, 2014, 05:29:01 pm »
It works now after a reflash. I've installed last firmware also.

I finally got something new:





Sound looks nice. Screen flicks continously:
https://www.youtube.com/watch?v=1rOLPvMRyAw
« Last Edit: May 05, 2014, 06:40:49 pm by ker »

hi-ban

  • **
  • Posts: 864
Re: Uae4All status
« Reply #27 on: May 05, 2014, 05:58:20 pm »
If the screen flickers, it may be because of the double-buffering.
There is a way to fix that. Nebuleon, d_smagin or johhnyonflame will be able to explain that more accurately.

hi-ban

  • **
  • Posts: 864
Re: Uae4All status
« Reply #28 on: May 05, 2014, 05:58:46 pm »
sorry double post

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #29 on: May 05, 2014, 06:02:29 pm »
If the screen flickers, it may be because of the double-buffering.
There is a way to fix that. Nebuleon, d_smagin or johhnyonflame will be able to explain that more accurately.

My mistake. I delete some Dingoo references and add GCW0 ones but I add a GCW0 (o not zero) option at compilation :P

Now it looks a lot better:
https://www.youtube.com/watch?v=4_IsW2aq3k8
« Last Edit: May 05, 2014, 06:41:08 pm by ker »

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #30 on: May 05, 2014, 06:49:20 pm »
that looks sweet, man!  ;D
can't wait to get my hands on a first version to do some testing
« Last Edit: May 05, 2014, 06:50:53 pm by sm0ky »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #31 on: May 05, 2014, 07:01:45 pm »
that looks sweet, man!  ;D
can't wait to get my hands on a first version to do some testing

I've tried to compile with new toolchain and triple buffer but screen flicks again.

howie_k

  • *
  • Posts: 154
Re: Uae4All status
« Reply #32 on: May 05, 2014, 07:08:55 pm »
Happy to test also!

This will be a great result to have a working Amiga emulator without slow sound!

I can hear Chris Huelsbeck's classic Turrican 3 main theme tune already... :)

I can then start dreaming of an A1200/CD32 compatible emulator (AGA graphics)....

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #33 on: May 05, 2014, 07:28:40 pm »
one step after another  ;)

personally i would be absolutely satisfied with a full speed amiga 500.

great to see your progress, ker!

sparkymark79

  • *
  • Posts: 56
Re: Uae4All status
« Reply #34 on: May 05, 2014, 08:57:32 pm »
Thanks man :)

BAFelton

  • *
  • Posts: 276
    • Open Consoles
Re: Uae4All status
« Reply #35 on: May 05, 2014, 09:35:48 pm »
It rocks !

SuperMarcoVer

  • *
  • Posts: 121
Re: Uae4All status
« Reply #36 on: May 05, 2014, 11:07:40 pm »
Looking good!! Can't wait to test it!

DrChaos

  • *
  • Posts: 47
Re: Uae4All status
« Reply #37 on: May 06, 2014, 08:46:17 am »
This may be a dump question, but is this a port of the Pandora Version? I stried the pandora Uae4All2-SDL port for Android, and that was really good...

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #38 on: May 06, 2014, 08:53:49 am »
This may be a dump question, but is this a port of the Pandora Version? I stried the pandora Uae4All2-SDL port for Android, and that was really good...

As far as I know, this is a WIP port from the Dingoo version...

DrChaos

  • *
  • Posts: 47
Re: Uae4All status
« Reply #39 on: May 06, 2014, 09:20:36 am »
Ok, than I add another dumb question from a non-developer: Would the Pandora version not be a good starting point or is this impossible because of the MIPS processor? The Pandora version also supports AGA and, even more attractive for me, whdload flawlessly...
« Last Edit: May 06, 2014, 09:24:53 am by DrChaos »

 

Post a new topic
Post a new topic