Author Topic: Uae4All status  (Read 21042 times)

ker (OP)

  • **
  • Posts: 603
Uae4All status
« on: May 01, 2014, 03:33:13 pm »
I wondered if someone is working on Uae4All port...

I managed to compile it but cannot play any rom. Menu shows, TOS loads, I can select a game and launch it but emulator remains in this screen:


I can use shoulder buttons to show virtual keyboard, but that's all.

This is a dump of debug console (debugging sound, memory and disk):
Code: [Select]
sound.c : setup_sound
 sound.c : ! setup_sound
sound.c : uae4all_init_sound
 sound.c : ! uae4all_init_sound
sound.c : pause_music
 sound.c : ! pause_music
sound.c : close_sound
memory_init!
memory_reset!
map_banks : chipmem_bank
Map
!Map!
map_banks : custom_bank
Map
!Map!
map_banks : cia_bank
Map
!Map!
map_banks : clock_bank
Map
!Map!
map_banks : dummy_bank
Map
!Map!
map_banks : rtarea_bank
Map
!Map!
map_banks : kickmem_bank
Map
!Map!
disc.c : DISK_init
disc.c : drive_settype_id
disc.c : DRIVE_INSERT 0 - ./df0.adf
disc.c : DISK_validate_filename ./df0.adf, 1
disc.c : disk_eject
disc.c : drive_eject
disc.c : drive_empty
disc.c : drive_settype_id
disc.c : drive_settype_id
disc.c : DRIVE_INSERT 1 - ./df1.adf
disc.c : DISK_validate_filename ./df1.adf, 1
disc.c : disk_eject
disc.c : drive_eject
disc.c : drive_empty
disc.c : drive_settype_id
disc.c : disk_empty
disc.c : drive_empty
memory_reset!
map_banks : chipmem_bank
Map
!Map!
map_banks : custom_bank
Map
!Map!
map_banks : cia_bank
Map
!Map!
map_banks : clock_bank
Map
!Map!
map_banks : dummy_bank
Map
!Map!
map_banks : rtarea_bank
Map
!Map!
map_banks : kickmem_bank
Map
!Map!
disc.c : DSKLEN
disc.c : DISK_reset
map_banks : kickmem_bank en CIA_reset
Map
!Map!
disc.c : DISK_update
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : DISK_update
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
....................................... a lot of this, over and over .......................................
disc.c : DISK_check_change
disc.c : disk_insert
disc.c : drive_empty
disc.c : DRIVE_INSERT 0 - Rick Dangerous.adf
disc.c : DISK_validate_filename Rick Dangerous.adf, 1
disc.c : drive_settype_id
disc.c : drive_fill_bigbuf
disc.c : drive_fill_bigbuf --- DISCO AMIGADOS ---
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : read_floppy_data track 0 len 512
disc.c : mfmcode
disc.c : DISK_update
disc.c : dodmafetch
disc.c : DISK_update
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : DISK_update
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
disc.c : dodmafetch
....................................... To infinity and beyond! .......................................
« Last Edit: May 01, 2014, 03:35:36 pm by ker »

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #1 on: May 02, 2014, 08:09:08 am »
woohooo  ;D ;D ;D great to see someone working on it! seriously - this is great news for me as a working amiga emu is one of my main reasons for my purchase of a gcw0.

the only working version i am aware of is the one for dingoo a320 - this one can start disks but is rather dodgy as it isn't meant to run on a gcw0.
did you ensure that the kick.rom you are using ia okay?
« Last Edit: May 02, 2014, 08:11:19 am by sm0ky »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #2 on: May 02, 2014, 08:47:47 am »
woohooo  ;D ;D ;D great to see someone working on it! seriously - this is great news for me as a working amiga emu is one of my main reasons for my purchase of a gcw0.

the only working version i am aware of is the one for dingoo a320 - this one can start disks but is rather dodgy as it isn't meant to run on a gcw0.
did you ensure that the kick.rom you are using ia okay?

I'm not working seriously on it. I don't have any skills at all to do it. Just trying to stimulate real developers  :P

BAFelton

  • *
  • Posts: 276
    • Open Consoles
Re: Uae4All status
« Reply #3 on: May 02, 2014, 09:23:24 am »
Maybe your bios isn't good.

A black screen appears in this case.

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #4 on: May 02, 2014, 09:57:34 am »
Maybe your bios isn't good.

A black screen appears in this case.

I'm pretty sure this bios is good. It also shows a black screen with this red and green boxes when I select Reset option in menu. Emulator does'nt die at this screen. Pressing select+start it returns to main menu

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #5 on: May 02, 2014, 10:14:43 am »
With BIOS I suppose you mean the kickstart... to make sure, it's enough to try it with a PC Amiga emulator, like WinUAE ! :)

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #6 on: May 02, 2014, 10:42:46 am »
perhaps you could fire up and take a look at the log-file from the a320-version and compare it with your log-file?

btw: I am pretty sure you can get it runnin' - just like a real developer  ;)

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #7 on: May 02, 2014, 11:22:34 am »
perhaps you could fire up and take a look at the log-file from the a320-version and compare it with your log-file?

btw: I am pretty sure you can get it runnin' - just like a real developer  ;)

A320 version is working? I'll take a look, but it needs a recompilation to enable debug

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #8 on: May 02, 2014, 02:58:03 pm »
if possible you could try booting the emulator with no disk inserted at all. you should see this screen if everything works out as expected:



this would confirm the kickstart image (kick.rom) to be working just fine!

greetings

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #9 on: May 02, 2014, 03:16:29 pm »
if possible you could try booting the emulator with no disk inserted at all. you should see this screen if everything works out as expected:



this would confirm the kickstart image (kick.rom) to be working just fine!

greetings

If I select RUN without any ADF selected I got a black screen as shown in first post.

Note: I've tried Dingux emulator and if I select RUN without any ADF selected I also got a BSOD (Black Screen Of Death ;-)
« Last Edit: May 02, 2014, 03:23:34 pm by ker »

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #10 on: May 02, 2014, 03:34:35 pm »
I just tried it myself - and got the screen from my last post  ;)

try looking for a v1.3 kickstart image. it could be possible that you have a proper  kick.rom but it isn't supported by the emulator.

version 1.3 renamed to kick.rom should do the trick  :)

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #11 on: May 02, 2014, 03:36:12 pm »
I just tried it myself - and got the screen from my last post  ;)

try looking for a v1.3 kickstart image. it could be possible that you have a proper  kick.rom but it isn't supported by the emulator.

version 1.3 renamed to kick.rom should do the trick  :)

Can you write a link to the Dingux emulator you are trying? Perhaps mine isn't the good one =(

Edit: I've tried kick.rom with UAE4All Linux version and it works as expected
« Last Edit: May 02, 2014, 03:42:08 pm by ker »

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #12 on: May 02, 2014, 03:58:40 pm »
sure...I am at work right now but i will send you a link later on.

sm0ky

  • *
  • Posts: 34
Re: Uae4All status
« Reply #13 on: May 02, 2014, 06:07:57 pm »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #14 on: May 03, 2014, 03:15:46 pm »
here you go:

http://dl.openhandhelds.org/cgi-bin/dingoo.cgi?0,0,0,0,72,536

kick.rom works with this dge. I've tried to find this release source code but all i've found are links to Megaupload  :'(

pcercuei

  • ***
  • Posts: 1432
    • My devblog
Re: Uae4All status
« Reply #15 on: May 03, 2014, 03:21:16 pm »

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #16 on: May 03, 2014, 03:34:52 pm »
http://chui.dcemu.co.uk/uae4all.html

Yes, I've already download this sources but they are not the sources of the binary posted by sm0ky.

I'm now trying to remove all Dingoo stuff (volume, brightness and clock... I've not seen anything else) and trying to recompile. It's now starting to compile famec.cpp so I'll go to walk for a couple of hours  :P

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #17 on: May 04, 2014, 07:05:17 pm »
Yesterday my GCW0 begun to go crazy:


I'll wait for the next firmware release before continue testing. Latest compilation tests were unstable and I'm afraid they are corrumption related

Gab1975

  • ***
  • Posts: 1165
Re: Uae4All status
« Reply #18 on: May 04, 2014, 07:26:45 pm »
I'll wait for the next firmware release before continue testing. Latest compilation tests were unstable and I'm afraid they are corrumption related

Did you try to hold the reset button for 45/50 seconds (with the console turned off) and verify if the "strange glitches" persist?

ker (OP)

  • **
  • Posts: 603
Re: Uae4All status
« Reply #19 on: May 04, 2014, 07:58:51 pm »
I'll wait for the next firmware release before continue testing. Latest compilation tests were unstable and I'm afraid they are corrumption related

Did you try to hold the reset button for 45/50 seconds (with the console turned off) and verify if the "strange glitches" persist?

I didn't, but I've done now with no result  :'(

 

Post a new topic