Author Topic: Please help me get started  (Read 1493 times)

SnakiestD (OP)

  • Posts: 7
Please help me get started
« on: September 28, 2014, 08:46:06 am »
SOLVED: I installed the 32bit toolchain on 64bit linux.

Hey so I would like to make a game for the gcw-zero. I don't have much experience with making games, and absolutely none with C++. I have decided to use Code::Blocks. The first thing I did was install the latest toolchain. That worked fine. Then I installed Code:Blocks and that seemed fine as well, but I running into some problems. I changed the compiler and debugger settings following this: http://wiki.surkow.com/Tutorials:CodeBlocks I think that worked fine. Then I selected "new project" and then "console". Am I suppose to select console? After that I left it as the default "Hello World" app. I changed no code. I then compiled, built, and ran the app. It ran but I get the error:

***/path/to/workspace/appname/bin/Debug/appname: Syntax error: word unexpected (expecting ")")***

It does not say "Hello World"

Please help. I just want to create a text-based adventure.
« Last Edit: October 03, 2014, 07:01:01 am by SnakiestD »

zear

  • * Moderator
  • Posts: 2381
Re: Please help me get started
« Reply #1 on: September 28, 2014, 09:02:42 am »
If I rememer correctly this error on runtime means you're trying to run an executable compiled for a different architecture (ie. trying to run x86 binary on MIPS). You most likely didn't compile with the GCW Zero toolchain, but your host PC's one.

Or are you trying to run GCW Zero compiled software on your PC?

SnakiestD (OP)

  • Posts: 7
Re: Please help me get started
« Reply #2 on: October 03, 2014, 07:00:17 am »
I was on a 64 bit linux system. Oops. Thanks. Anyone know a good way to get around this?

 

Post a new topic