Author Topic: 2 new emulators  (Read 12600 times)

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #20 on: April 27, 2014, 03:39:23 pm »
I used the 1.62 and it turned into a STE
thanks for getting the logs

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #21 on: April 28, 2014, 08:50:19 pm »
I created a bash script to launch with logging and tracing

Code: [Select]
#!/bin/sh

./hatari -D -t tos162uk.rom --log-file log.txt --log-level debug --trace all --trace-file trace.txt

doesnt output much really

trace.txt

Code: [Select]
acia init tx_clock=501327 rx_clock=501327
ikbd init


log.txt

Code: [Select]
Hatari v1.7.0, compiled on:  Apr 25 2014, 13:28:00
Support for Hatari window reparenting not built in
1874 CPU functions
Building CPU function table (0 0 1).
Can not load TOS file:
''

its a start though.

Input is a real pain atm :)


slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #22 on: April 28, 2014, 09:04:16 pm »
What can I do to improve input?
Also try an absolute path for the rom
E.g. /home/tos162.UK.ron

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #23 on: April 28, 2014, 09:11:48 pm »

ATM I have to use power-up + B to enable mouse for  moving the cursor around but there is no means to select/click

to click I have to switch back to joystick mode again power-up + B and pess b to select.

if you press select or start by mistake you tend to get thrown from the emulator

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #24 on: April 29, 2014, 07:18:44 am »

using the absolute path doesn't help

Code: [Select]
Hatari v1.7.0, compiled on:  Apr 25 2014, 13:28:00
Support for Hatari window reparenting not built in
1874 CPU functions
Building CPU function table (0 0 1).
Can not load TOS file:
''

odd that its showing the '' after the TOS error

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #25 on: April 29, 2014, 07:26:02 am »
Here's another one where I went into the ROM option and selected browse

Code: [Select]
opendingux:/media/sdcard/apps # ./gohatari
fdc enable drive=0 on
fdc enable drive=1 on
Xcounout device 7 vector redirection enabled.
Exception debugging enabled (0x103).
fdc enable drive=0 on
fdc enable drive=1 on
WARNING: invalid desktop size 320x240, defaulting to 832x576!
Configured max Hatari resolution = 832x576.
Building CPU table for configuration: 68000
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred
Segmentation fault

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #26 on: April 29, 2014, 04:24:31 pm »
Thanks for that,  looks like I'll have to hack the video code to accept the gcwzero resolution

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #27 on: April 29, 2014, 06:17:46 pm »
actually its easier than that
just launch hatari like this

./hatari --max-width 320 --max-height 240

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #28 on: April 29, 2014, 06:19:43 pm »
I'll try that later but I did set my config up for the GCW res and it still complained and reverted back

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #29 on: April 29, 2014, 06:37:32 pm »
ok if that doesnt work Ill just alter the code to force it to 320x240
« Last Edit: April 29, 2014, 06:40:51 pm by slenkar »

ker

  • **
  • Posts: 601
Re: 2 new emulators
« Reply #30 on: April 29, 2014, 07:55:21 pm »
ok if that doesnt work Ill just alter the code to force it to 320x240

It doesn't work for me. Unable to load TOS file when launched and segmentation fault when I try to browse to select TOS file (sames results as @l00k)

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #31 on: April 29, 2014, 08:20:29 pm »
Thanks for testing,
 Thats weird because looking at the source code I was convinced that would work.
It wont be too difficult to alter fortunately.

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #32 on: April 30, 2014, 05:06:53 pm »
https://www.mediafire.com/?y3xa55apr9ypj54

You might be able to use the mouse by itself now, if not just switch between mouse and keyboard

also resolution is hard coded

source:
https://www.mediafire.com/?nrfgossxg22319t
« Last Edit: April 30, 2014, 05:11:38 pm by slenkar »

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #33 on: April 30, 2014, 05:09:45 pm »
Thanks I'll try it after work

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #34 on: April 30, 2014, 08:28:32 pm »
Hi slenkar. Good progress I've seen the little green desktop. I'm not able to click on anything now.

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #35 on: April 30, 2014, 08:35:05 pm »
The screen seems perfect btw

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #36 on: April 30, 2014, 11:50:37 pm »
Cool!

Were you able to use the mouse in the menus?

If so I can just apply the same fix to the mouse code for the st

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #37 on: April 30, 2014, 11:55:14 pm »
No mouse movement by default but I could select mouse using powerup+b then I could move the mouse but I couldn't click/select even when I toggle mouse mode again

slenkar (OP)

  • *
  • Posts: 45
Re: 2 new emulators
« Reply #38 on: May 01, 2014, 12:13:06 am »
I mean the emulator menus where you select your TOS rom
The mouse still doesn't work there?

l00k

  • *
  • Posts: 52
Re: 2 new emulators
« Reply #39 on: May 01, 2014, 06:59:56 am »
I can move the mouse in the menu but can't click on anything