Author Topic: Exult v1.4_svn6317 for Dingux (beta2)  (Read 6395 times)

SiENcE (OP)

  • **
  • Posts: 653
    • Crank Gaming (Dingux Apps)
Exult v1.4_svn6317 for Dingux (beta2)
« on: September 05, 2010, 07:06:09 pm »

This is my first official release of the Exult Engine to run

* Ultima 7 - Black Gate and
* Ultima 7 - Serpent Isle

on your Dingoo using Dingux.

Please report Bugs or Suggestions!

You will also need to install Keymouse!

Download:
http://crankgaming.blogspot.com/2010/09/exult-v14svn6317-for-dingux-beta2.html

cheers
^SiENcE
« Last Edit: September 05, 2010, 08:09:20 pm by SiENcE »

gri_ef

  • Posts: 4
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #1 on: September 05, 2010, 07:21:56 pm »
Cool:)

eule

  • * Former Staff
  • Posts: 889
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #2 on: September 05, 2010, 08:04:10 pm »
Cool indeed!  ;D
One thing i noticed so far, the readme speaks of GemRB sometimes...
I?ll test it tonight and report my findings, impressions and suggestions tomorrow. Never played an Ultima, let?s see if it?s truely that awesome.  :D

SiENcE (OP)

  • **
  • Posts: 653
    • Crank Gaming (Dingux Apps)
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #3 on: September 05, 2010, 08:32:05 pm »
One thing i noticed so far, the readme speaks of GemRB sometimes...

Ah copy/paste ;-). Fixed now. Redownload.

orakio_rob

  • *
  • Posts: 34
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #4 on: September 06, 2010, 03:33:20 pm »
The first time I try to run it some messages are quickly displayed on the console and then I'm back at gmenu. When I try to run it again the game actually works, but it only show on the left half of the screen, the right half stays black. Aside from that, the game runs at normal speed, incluing music. Any ideas?

eule

  • * Former Staff
  • Posts: 889
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #5 on: September 06, 2010, 03:38:14 pm »
The "first time" thing is a bug of the mouse driver i think, SiENcE?  ;D
The other issue (half screen) is probably due to you using an old rootfs, try elta?s.  ;)
Didn?t find time to actually test this thoroughly, but i will today!

SiENcE (OP)

  • **
  • Posts: 653
    • Crank Gaming (Dingux Apps)
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #6 on: September 06, 2010, 04:07:40 pm »
The first time I try to run it some messages are quickly displayed on the console and then I'm back at gmenu. When I try to run it again the game actually works, but it only show on the left half of the screen, the right half stays black. Aside from that, the game runs at normal speed, incluing music. Any ideas?

The "first time" thing is a bug of the mouse driver i think, SiENcE?  ;D
1.
It's because the kernel video driver does not deinitialize correct. It has todo with the don't leave option. But this option is needed. This is already fixed in OpenDingux kernel (release soon).

To fix this, just start it again :).

2.
Half of the screen!? Picture please.

Install Elta rootfs 2009-12-08 http://boards.dingoonity.org/dingux-development/a-couple-of-rootfs-upgrades/ 

Didn?t find time to actually test this thoroughly, but i will today!

Good :-).
« Last Edit: September 06, 2010, 04:09:59 pm by SiENcE »

orakio_rob

  • *
  • Posts: 34
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #7 on: September 06, 2010, 04:33:05 pm »
I've just noticed that my SD card was filled up :)

Freeing up some space and installing Elta's rootfs as you both suggested solved it, thanks! Now I'll test it.

orakio_rob

  • *
  • Posts: 34
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #8 on: September 06, 2010, 05:51:55 pm »
The game runs pretty fine, this is great!

The only problem I seem to have now is that whenever I hold R to move the mouse pointer, my character also moves. I can't move the pointer without moving the characters along with it.

I've tried reinstalling keymouse, but still no good.

SiENcE (OP)

  • **
  • Posts: 653
    • Crank Gaming (Dingux Apps)
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #9 on: September 06, 2010, 07:55:36 pm »
Yeah thats indead a problem.

The keymouse driver can't block the d-pad. So an app using the d-pad also receives keypresses.

But in Exult press Right+A and than move the cursor using d-pad. This works for now. I will add a blocker in Exult in the final release.

Thanks this reporting this issue.

More :) ?

gri_ef

  • Posts: 4
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #10 on: September 17, 2010, 01:00:36 pm »
Sometimes game shutdown after using left and right mouse button successively.

yzzwx2

  • *
  • Posts: 57
Re: Exult v1.4_svn6317 for Dingux (beta2)
« Reply #11 on: November 03, 2010, 04:21:44 pm »
who can tell me where is gamedata?