Author Topic: [RELEASE] fceu320 v0.3 beta  (Read 31982 times)

Siloucos

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #20 on: April 05, 2010, 03:57:43 am »
i can delete .fceux  folder

i can't load  game
 
my dingoo Freeze

Help me

Fullscreen option no work fine to me  :'(

with fullscreen have several crash and back to gmenu2x  :'(

i fix the problem with delete config file in Home folder.

 :'(



The same here, with exception of these problems the rest is pretty awesome!

goldenegg

  • Posts: 56
Re: [RELEASE] fceu320 v0.3 beta
« Reply #21 on: April 14, 2010, 06:53:55 am »
I can't use this release at all, as it doesn't limit game speed properly.   Clocked at 400Mhz, SMB3 runs at over 70fps, even with the FPS limiter enabled.  I can underclock to try getting it to a regular speed, but them other sections of the game would run too slow.

Any chance for an update with a working FPS limiter?

jevilon

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #22 on: April 14, 2010, 07:38:18 am »
Yor're using a PAL version of the ROM and your emulator is configured in NTSC?
Try to change the emu configuration to PAL (sound problems) or use a NTSC ROM

goldenegg

  • Posts: 56
Re: [RELEASE] fceu320 v0.3 beta
« Reply #23 on: April 14, 2010, 08:49:24 am »
Yor're using a PAL version of the ROM and your emulator is configured in NTSC?
Try to change the emu configuration to PAL (sound problems) or use a NTSC ROM

Were you responding to my post?

The issue I have has nothing to do with NTSC/PAL.  It's a problem with this beta release, which the developer even mentioned in release notes.  Game speed is not currently being throttled properly, allowing them to run way too fast, depending on clock speed.

jevilon

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #24 on: April 15, 2010, 07:55:28 am »
Ok, but only for curiosity, try with the same rom but in NTSC.
For exemple I play Super Mario Bros 3 (E) and the emulator is too fast but, i play Super Mario Bros 3 (U) and the game run at the correctly speed

goldenegg

  • Posts: 56
Re: [RELEASE] fceu320 v0.3 beta
« Reply #25 on: April 15, 2010, 12:11:37 pm »
Ok, but only for curiosity, try with the same rom but in NTSC.
For exemple I play Super Mario Bros 3 (E) and the emulator is too fast but, i play Super Mario Bros 3 (U) and the game run at the correctly speed

Wether you play in PAL or NTSC mode, the emulator doesn't properly limit speed of the game.  What you're refering to is the standard speed up/slow down that occurs when you play NTSC/PAL video back at the wrong speed.  It's a completely different issue.  No mater what your NTSC/PAL settings are, you should never have a result of being faster than 60fps.

jevilon

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #26 on: April 16, 2010, 04:05:56 pm »
I play NTSC games with NTSC option in the menu...
I don't know, but if you play a PAL rom with the NTSC emulation... the frame rate can be upper than 60 fps... I suppose...

Sorry my english

nine10

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #27 on: April 18, 2010, 12:53:12 am »
Final Fantasy VII works !!!

 :D

goldenegg

  • Posts: 56
Re: [RELEASE] fceu320 v0.3 beta
« Reply #28 on: June 22, 2010, 04:20:17 am »
Any update on this emu?  I'd love to get a version with a proper speed limiter.

EugenyN

  • Posts: 23
Re: [RELEASE] fceu320 v0.3 beta
« Reply #29 on: September 25, 2010, 11:09:11 pm »
Somebody has solved a problem with a sound and game speed ?

ValdikSS

  • Posts: 57
Re: [RELEASE] fceu320 v0.3 beta
« Reply #30 on: November 05, 2010, 06:27:28 pm »
Hey! Somebody! Reupload the sources please! I know you have it!
I ported fceux again but now i saw the sources of this port.
I want to merge latest SVN and make normal "auto" frameskip.

UPDATE: I've found a source code.
http://files.emuwiki.com/fceu320_src.tar.gz
« Last Edit: November 05, 2010, 06:33:10 pm by ValdikSS »

guiljb10

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #31 on: June 05, 2011, 04:42:06 pm »
I'm having problems with the FullScreen option enabled in this fceu320 0.3.
Just to mention, I haven't played the older versions.
With the FullScreen option enabled, the screen is cropped a bit on the left side and there are black bars on the top and on the botton of the screen.
This can be easily be verified when playing Castlevania III and the word Player (where it shows the health) e cropped.
How do I adjust this?

kir_13

  • Guest
Re: [RELEASE] fceu320 v0.3 beta
« Reply #32 on: December 19, 2011, 11:41:23 am »
I want to use it on Ritmix RZX-50? but it show cracked screen and freeze...
Can anybody help with that?

dingooforever

  • Posts: 63
Re: [RELEASE] fceu320 v0.3 beta
« Reply #33 on: December 19, 2011, 02:34:46 pm »
You should contact EXL, he is a coder and he owns a Ritmix RZX-50.

DiegoSLTS

  • Posts: 365
Re: [RELEASE] fceu320 v0.3 beta
« Reply #34 on: December 19, 2011, 04:49:51 pm »
Hi, I've made a new version of FCEU320 that works in OpenDingux. It's based on version 0.3 from ValdikSS, the main changes are:

- Input uses /dev/event0 insted of /dev/mem.
- Audio uses libao instead of OSS. Samplerate is 16000, you can't change that, I'll try to fix that option later but with 16000 is playable and it doesn't sound that bad.
- Some options were removed: general volume, brightness and overclocking. You can set overclocking on the link config in Gmenu2x and change brightness and volume with power+up/down/left/right.
- New controls on menus:
- - You can cycle through the menu, if you're at the top, press up to go to the bottom. If you're at the bottom, press down to return to the top.
- - PageUp/Down with L/R.

Download:
Binary
Source
« Last Edit: December 20, 2011, 04:37:56 am by DiegoSLTS »

Coccijoe

  • Posts: 366
    • Underground Portables
Re: [RELEASE] fceu320 v0.3 beta
« Reply #35 on: December 19, 2011, 10:02:02 pm »
Thanks very much diegoSLTS! This emulator lacked on OpenDingux
Can you make the sound higher? And you can activate hardware surface and doublebuffering to gain few fps (maybe it's already done?), another thing the menu is mapped on power buttons so when i try to change sound or brighness, emulator go to the menu.
« Last Edit: December 19, 2011, 10:12:18 pm by Coccijoe »

pcercuei

  • Posts: 1676
    • My devblog
Re: [RELEASE] fceu320 v0.3 beta
« Reply #36 on: December 19, 2011, 10:03:17 pm »
Nice, thanks!  ;D

DiegoSLTS

  • Posts: 365
Re: [RELEASE] fceu320 v0.3 beta
« Reply #37 on: December 20, 2011, 04:47:50 am »
Thanks very much diegoSLTS! This emulator lacked on OpenDingux
Can you make the sound higher? And you can activate hardware surface and doublebuffering to gain few fps (maybe it's already done?), another thing the menu is mapped on power buttons so when i try to change sound or brighness, emulator go to the menu.
I'm not sure about the first two, I'll take a look tomorrow. The code is a really big maze, I'm not even sure where some things happen :P.
About the last one, yes, I'll try that, shouldn't be a problem.

Coccijoe

  • Posts: 366
    • Underground Portables
Re: [RELEASE] fceu320 v0.3 beta
« Reply #38 on: December 23, 2011, 12:28:01 pm »
hi diego, i tried to compile fceu with 48000 on samplerate that work and sound is much better (still not perfect), emulator is not slower, I don't find how to make sound higher for the moment btw. Maybe you could change samplerate if you make an other release?

DiegoSLTS

  • Posts: 365
Re: [RELEASE] fceu320 v0.3 beta
« Reply #39 on: December 23, 2011, 04:00:40 pm »
I've already changed the things for the other post, but I'm testing if SDL improved something.

I changed the default volume to the maximum, re-enabled an option on audio settings to change it... there were two, I disabled both of them earlier but only "hardware" volume was useless.
Also changed the menu key to L, and disabled the hotkeys for save/load state that were assigned to L/R.
The video code wasn't using SDL, yesterday I managed to change some code to use it, with hardware surfaces and double buffering, but didn't see any improvements. In fact, I think 1 or 2 fps were lost :S, I want to check this before posting a new version.

I'll see about the samplerate, the best thing would be to re enable the option to change it, I'll try to fix it one more time. If I can't make it, I'll set the default samplerate higher, but when I was testing for the first release it wasn't smooth with the default dingoo clock (336 MHz).

 

Post a new topic