Author Topic: OpenDingux Developer Pre-Release 2 Application Compatibility  (Read 10671 times)

m4gic

  • Guest
OpenDingux Developer Pre-Release 2 Application Compatibility
« on: September 27, 2011, 09:45:28 pm »
Update Oct 25, 2011: It looks like I'm not going to have the time to keep up with this, unfortunately. However, I will begin inputting the current info into the WIKI sometime this coming weekend. I've been having problems with my SD corrupting repeatedly (beginning to think the SD card itself is at least partially at fault) and I can't keep reloading dingux to test apps. That said, if others continue to post to this thread, I'll come back from time to time and update the OP and try to keep the wiki up to date with the info contained here. At least for now, I won't have time to keep up with all the new releases posted, so if you DO post a program to be included with the list, please also post a link to the release thread where possible so I can make sure the newest version is included when I do updates. Thanks to everybody who's helped out.

OP Follows.

Okay, so I've updated my A320 to OD Dev PR2 (I haven't modified my dingoo in so long, I don't even remember what version rootfs I was on before  ???)

Anyway, I did a bit of looking around and it doesn't seem as if anyone has started a legacy apps compatibility list yet. (sorry if there has, my forum/wiki searching skills are renowned for their inadequacy). I'm painfully aware that my Linux skills are lacking so many problems may be my own fault, bear with me. Please contribute to the list, share tips on getting things working, and for those of you whose skills surpass my own, point developers towards the specific reason why any app isn't working - error messages, missing rootfs support, incompatible methods, etc etc.

Legend:
Not working
Partially working
Working
Runs Better on OD

So far, I've tested the following:
Applications:
  • Dingux Commander 2.1 with Chinese Character support Download - Not sure, I think this is my fault perhaps. GMenu itself bombs out and restarts when attempting to select the folder DC2.1 is contained in to add a link.  ???
  • Dingux Commander 2.1 Download - Works.
  • Dingux Write 1.1.0 Download - Works
  • SDLCalc Download - Works



Games:
  • Arkanoid Download Wiki - Runs fine
  • ASCIIPortal Download Wiki - seems fine
  • Biniax2 Download Wiki - Crashes
  • Block Dude Download Wiki - Crashes
  • Blockrage Download Wiki - Works
  • Bubble Dizzy Download - Works
  • CDogs Download - Runs fine, sound is fine. Game is slow on default clocks, playable at 408Mhz
  • CommanderGenius (clonekeenplus) Download - Works fine. Includes freeware episodes 1 and 4 (support for ep4 is experimental, doesn't work).  Full-version episodes can be bought here (post if you find a cheaper source for these)
  • CZDoom Download - Works fine. Additional IWads can be used via launching the game with the parameter "-iwad [WADNAME]" via a shell script.
  • Defendguin Download Wiki - Crashes after splash screen
  • Dodgin Diamonds 2 Download Wiki - Makes it to the main menu, crashes upon starting a level.
  • Eduke32 Download Wiki - Runs at fullspeed with sound, default clocks. Very busy screens, certain animations will slow it down. Duke it out in DC, Carribean Vacation, and Nuclear Winter expansion packs work fine. Shareware files available here. Atomic edition (full) can be purchased and data files can be extracted from the version here
  • GemdropX Download Wiki - Crashes after loading screen
  • Giana's Return Download - works.
  • Kobo Deluxe Download Wiki - Crashes
  • Meritous Download Wiki - Works
  • MrDrillux Download Wiki - Hangs
  • OpenJazz Download - Runs, no sound.
  • OpenJazz (Zear's Version) Download - Works fine. Some screen corruption noticed on intro with FULLCD datafiles (likely a problem with the port or data rather than OD). Otherwise runs perfectly. You'll need datafiles (commercial or shareware). The shareware files are available here. The full version files can be bought from Epic Classics, assuming they're still in business (?) page date is 2008. If anybody's ordered from them recently please let us know.
  • OpenLiero Download Wiki - Crashes, probably because it's staticly compiled?
  • OpenTyrian (ungood's version) Download - Crashes on start.  This version also had a reproducible late-game crash on legacy Dingux.
  • OpenTyrian (sweetlilmre's optimized build) Download  WIKI - Runs fine. Faster than ungood's build on legacy Dingux, the late-game crash is removed as well. You'll need the Tyrian2.1 data files (freeware) available here.
  • QuakeSDL Rikku2000's VersionDownload - Works
  • Rise Of The Triad Download WIKI - Runs fullspeed with sound, default clocks. Shareware data files here, full version can be purchased here.
  • Ro Bullet Reactor Download - Works
  • Slitherlink Download Release Thread - works
    • Spout Download - Works
    • So, Let's Roll a Smile - Works. Anybody have a working DL link? PACC2010 link is broken.
    • Ur-Quan MastersDownloadWIKI - Bombs out on selection from Gmenu.
    • XRick Download - Works

    Last edit: Added several games to the list
« Last Edit: October 26, 2011, 01:54:06 am by m4gic »


m4gic

  • Guest
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #2 on: September 28, 2011, 12:05:04 am »
i have no problem with quake, meritous, jazz rabbit, opentyrian (maybe different version?) and dingux commander but i use the 2.0 version

Interesting. I'll have to play around a bit and see what might be different from my old config to the new one. (still have my old SD card intact)

First thing I'll do is copy the old install directly into the new SD.  It's been so long since I originally did this, I may just be making a configuration problem  ;)

One question though, what version of quake are you using? Quakux or SDLQuake? I just got SDLQuake (and the rest of the downloads) off of the links on the Dingoonity WIKI page

EDIT - Indeed meritous works. Perhaps it wasn't working before because a crashed application left dingux in an odd state until the machine was restarted. OpenTyrian from my old SD card works... I noticed that I had backed up the original Tyrian.dge in the folder and replaced it with another. Perhaps the version linked in the wiki is just OLD?

Still can't get quake to work, likely a misconfiguration on my part. OpenJazz still has no audio, maybe the sound is just turned down somehow... Dingux Commander 2.1 from the BeyondDS blog works, the version linked to from the WIKI with Chinese character support doesn't. Probably a linux file permissions problem?

out of the remaining games from my old SD card, the ones which don't work are:
Code: [Select]
alice in crapland - dies upon entering level
biniax2 -> crashes
block dude -> bombs out
clonekeen2x -> crashes
Dodgin Diamonds 2 -> main menu, crashes when level starts
Defendguin -> splash screen
gemdropX -> dies after loading screen
kobo deluxe - Crashes
mrdrillux -> hangs
openliero ->crashes
Powermanga -> crashes
raw -> bombs out
rotategearux -> main menu. hangs on mission start
super transball 2 -> crashes
tcgs_car -> crashes ingame
quake -> bombs out
Tyrian -> new version works
waternet - crashes
« Last Edit: September 28, 2011, 01:34:10 am by m4gic »

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #3 on: September 28, 2011, 03:10:25 am »
I cant get hugo or midpath to work. After creating a link, when i try to launch the programs, they kick, me back to desktop with an exception error.  Anyone got any ideas? ???

qbertaddict

  • * Former Staff
  • The Doctor
  • Posts: 1184
    • about.me
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #4 on: September 28, 2011, 05:42:36 am »
OpenJazz works with sound. Make sure you are using the version by zear and for those of you having issues with opentyrian get the version by sweetlimre both are on openhandhelds.org


Coccijoe

  • Posts: 366
    • Underground Portables
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #5 on: September 28, 2011, 07:31:19 am »
for quake make sure you don't use the ingame overclocking,
 instead of clonekeen2x you can use commander genius. For power manga it exist 2 version, the one i use run on OD.

« Last Edit: September 28, 2011, 07:37:17 am by Coccijoe »

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #6 on: September 28, 2011, 06:22:24 pm »
I know dingux hugo has been updated for OD and midpath is said to be working. I would still like some feedback from those who have used it. Can anyone tell me why they might not function. The error message i get seems to be related to a sound driver. I cant fully make out what it says as the error messge dissappears very quick. I understand OD is new, but hugo is working for others is it not?  Please lend me a hand here, i would love to play some turbo!! Thanks.

Coccijoe

  • Posts: 366
    • Underground Portables
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #7 on: September 28, 2011, 06:45:52 pm »
Hugo is the OpenDingux version but you're right it don't work.
For midpath i use it so i confirm it work, make sure you put midpath folder in /local/ and not in /local/emulator or other folder. There is two executable, one of them is for launching midpath, are you sure you use the good one?

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #8 on: September 29, 2011, 01:36:38 am »
Not sure, i got the version from open handhelds. Is that the not the right version?  Ayla posted in another thread that hugo was not working and is now fixed. Thank you for the response. I appreciate all the help from everyone!!!

m4gic

  • Guest
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #9 on: September 29, 2011, 05:32:22 am »
This is great info guys! If you happen to have links to the newer versions (especially if they are updated specifically for OD) of problem programs, please list them here. As I get time, I plan to search them out, but if you happen to be sitting on the page, or know where the release thread is offhand, even posting who made the most up to date version will save a lot of searching. The end-game of this thread is to update the WIKI with known working and non-working programs, hopefully on a PER-Release basis (of OD). I'd like to say I'll have time to keep up to date on it, but I don't know... The more people post the easier it'll be for me to get the right info.

OpenHandhelds needs a better CMS to make this easier. One page for each program, with multiple versions on the same page, and sub-sections for different OSes. The nature of FOSS makes it difficult to find the newest version if there isn't a well organised central hub. We have a central hub in OH (at least for the binaries) but well-organised? I guess that depends on your point of view  ;)
« Last Edit: September 29, 2011, 05:37:22 am by m4gic »

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #10 on: September 29, 2011, 08:11:03 am »
Ok Hugo works great now. I can get midpath to start, but cant seem to get it to run, it gets stuck on a loading screen that never goes away. I will keep working at it. As far as hugo goes, i notice corruption in Air zonk, magical chase and neutopia. some games have this corruption, some dont. Can anyone else veryify these same problems. I dont believe it to be the emulator. it might have to do with my settings, or maybe the games are bad. All i need to know is if anyone else is having the same issue.  thanks.

Coccijoe

  • Posts: 366
    • Underground Portables
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #11 on: September 29, 2011, 08:14:16 am »
for midpath, i remember had this problem too, it was due to one of the game, just try without game to see if the emulator run.

m4gic

  • Guest
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #12 on: September 30, 2011, 12:47:15 am »
Updated OP, added more files.

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #13 on: September 30, 2011, 07:48:56 am »
coccijoe, i relocated midpath to the local directory as suggested, and i started it without any games. it does infact run now, i can bring up the menus. i tried installing tower defense, and peggle. midpath installs tower defense but not peggle. once tower defense is installed it does not come up in the midlet manager. when i try to start midpath after exiting, it says "loading" and never goes any further. I'm sure its a configuration issue, i'm slowly working the problem.  I noticed a crazy bug in hugo. It works good now, but i had this same problem before opendingux. Air zonk has horrible screen corruption only if zonk is exactly in the middle of the screen when playing. A similar effect happens in magical chase, but not nearly as bad. i noticed this in two versions of air zonk, and three versions of magical chase. Otherwise. other games that i had issues with now work fine.  I know i'm over doing this but i really really cant thank everyone enough for the help. In time it will only get even better :)

pcercuei

  • Posts: 1588
    • My devblog
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #14 on: September 30, 2011, 09:25:57 am »
The error message for Quake(SDL) you quote is totally unrelated. It appears each time you switch from a graphical app to a text console, and this occurs when an application fails to load. So the only information it provides is that the app failed to load...

m4gic

  • Guest
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #15 on: October 01, 2011, 02:33:06 am »
I did figure that out afterwards. I'm relatively convinced that it's probably a misconfiguration on my part. Thanks for the help though.

Coccijoe

  • Posts: 366
    • Underground Portables
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #16 on: October 01, 2011, 07:50:17 am »
http://boards.dingoonity.org/dingux-releases/quake%28sdl%29-1-02-r2-tec/
is it the version of quake you use?
have you tried without the ingame overclocking (let it at 336mhz), like i told you few message ago?

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #17 on: October 01, 2011, 01:29:01 pm »
Ok, i changed versions of openjazz to the one with sound and i cant get it working. I read the instructions carefully and put the full cd data files in the appropriate directory. Is this similar to midpath were it needs to be in a specific folder in order to function? I have put openjazz in root and in local with no luck. I have also tried the cd and non cd version of the game with no luck. I'm only trying to start one copy of jazz at a time, i do not have multiple copies loaded in different directories. 

m4gic

  • Guest
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #18 on: October 03, 2011, 03:47:47 am »
http://boards.dingoonity.org/dingux-releases/quake%28sdl%29-1-02-r2-tec/
is it the version of quake you use?
have you tried without the ingame overclocking (let it at 336mhz), like i told you few message ago?

Yeah, I don't know what the problem was. It wasn't even getting to the point of letting me chose the overclocking. I just deleted everything and started copying files from scratch and it didn't work, and I did it again, now it does. I'm pretty sure I had Rikku2000's 1.02 R2-Tec before but maybe it was a different version. Anywho, it's working, and the link to the working version is up in the OP.

Ok, i changed versions of openjazz to the one with sound and i cant get it working. I read the instructions carefully and put the full cd data files in the appropriate directory. Is this similar to midpath were it needs to be in a specific folder in order to function? I have put openjazz in root and in local with no luck. I have also tried the cd and non cd version of the game with no luck. I'm only trying to start one copy of jazz at a time, i do not have multiple copies loaded in different directories.
I don't believe it needs any special position in the file system. I just have mine in local/games/openjazz. I threw my fullcd data files into the relevant folder and it worked. Have you tried the shareware episode?
« Last Edit: October 03, 2011, 03:50:11 am by m4gic »

HercTNT

  • Posts: 662
Re: OpenDingux Developer Pre-Release 2 Application Compatibility
« Reply #19 on: October 03, 2011, 09:17:14 am »
No i have not and i guess i should. I will start small, and if i can get that going i will work up from there.  I honestly did not think of that. I just figured that the version of jazz i have worked with the other port that it would work with this one. Thanks for taking the time to answer.

 

Post a new topic
Post a new topic