Author Topic: intro and some  (Read 4600 times)

indrora

  • Guest
intro and some
« on: November 12, 2010, 08:23:52 am »
So, first post here.

I've had my dingoo all of 48 hours at this point -- got mine off DealExtreme and its the real deal (made by Shenzen Jingchirang electric technology ltd, so matches the official stuff).

I've gotten Dingux working on it without too much hassle... only little thing was getting /ftp/ under windows 7.... Until I started googling.

Turns out, WIndows 7 has *native* support for RNDIS devices... you have to find them though. I found it thanks to the diligent documentation over at OpenInkPot... Here's the steps to *natively* getting Dingux talking over the USB:

  • plug in the device and wait for windows to finish not find a device driver.
    • Go to Windows device manager, find RNDIS/Ethernet gadget device in "Other devices" folder, right-click it and select Properties.
    • Click "Update driver", "Browse my computer for driver software", "Let me pick from list of device drivers", double click "Network adapters", select "Microsoft Corporation" manufacturer and "Remote NDIS Compatible device" driver.
    • Click "Next" and let Windows install selected driver. If everything went well, "RNDIS/Ethernet gadget" device should now show up in "Network devices" folder working correctly.
  • FTP! Congratulations, the udhcpd server on the box will bring things up for you.
this works on 7 x64! the driver is signed by Microsoft, and is just the generic rNDIS driver!

mindw0rk

  • Posts: 4
Re: intro and some
« Reply #1 on: November 12, 2010, 05:39:19 pm »
Had a hard time trying this on Win 7 x86. With no avail of course.

Anyone else had problems?

campusten

  • Guest
Re: intro and some
« Reply #2 on: November 12, 2010, 06:00:42 pm »
Had a hard time trying this on Win 7 x86. With no avail of course.

Anyone else had problems?

I had a heck of a time flashing my dingoo with the dual boot for dingux with win7 64.  I eventually just had to use a macbook.

indrora

  • Guest
Re: intro and some
« Reply #3 on: November 12, 2010, 07:09:00 pm »

I had a heck of a time flashing my dingoo with the dual boot for dingux with win7 64.  I eventually just had to use a macbook.

As did I... I grabbed my linux box and flashed over that.

I've managed to isolate part of the problem... I'm running the local pack 0.35, and I'm not sure if that has anything to do with it. I also am going on a root hub, not a child hub.

I can't help debug past logging what I did

clach04

  • Posts: 256
Re: intro and some
« Reply #4 on: November 12, 2010, 11:00:14 pm »
So, first post here.

I've had my dingoo all of 48 hours at this point -- got mine off DealExtreme and its the real deal (made by Shenzen Jingchirang electric technology ltd, so matches the official stuff).

I've gotten Dingux working on it without too much hassle... only little thing was getting /ftp/ under windows 7.... Until I started googling.

Turns out, WIndows 7 has *native* support for RNDIS devices... you have to find them though. I found it thanks to the diligent documentation over at OpenInkPot... Here's the steps to *natively* getting Dingux talking over the USB:

  • plug in the device and wait for windows to finish not find a device driver.
    • Go to Windows device manager, find RNDIS/Ethernet gadget device in "Other devices" folder, right-click it and select Properties.
    • Click "Update driver", "Browse my computer for driver software", "Let me pick from list of device drivers", double click "Network adapters", select "Microsoft Corporation" manufacturer and "Remote NDIS Compatible device" driver.
    • Click "Next" and let Windows install selected driver. If everything went well, "RNDIS/Ethernet gadget" device should now show up in "Network devices" folder working correctly.
  • FTP! Congratulations, the udhcpd server on the box will bring things up for you.
this works on 7 x64! the driver is signed by Microsoft, and is just the generic rNDIS driver!

Awesome research! Could you add this to the wiki?

flaming_goat

  • Guest
Re: intro and some
« Reply #5 on: November 12, 2010, 11:51:52 pm »
Amazing ;D This works! I have 64bit and works great with Filezilla. just put in Host: 10.1.0.2 and leave the other field blank and it connects fine. Dont use active transfer and make sure u set transfer type to binary or it doesn't work.

indrora

  • Guest
Re: intro and some
« Reply #6 on: November 13, 2010, 05:27:06 am »
Righto... so I found part of the problem: USB Hubs and Windows don't play nice when you have rNDIS devices on the other end.

Apparently if you have a cheap hub (some mobos have one built in) you get this nasty "device failed to start" error because windows can't see it anymore! Oh noes! This becomes the bane of the hack!

You see, windows temporarily stashes "Device AF3D at hub 3D02 uses rndis.inf" until it gets unplugged... Which... Well it causes issues because it doesn't log that the device AF3D should always use that driver.

Sooooo I came up with a modified rndisnet.inf that might maybe possibly work

General disclaimer applies:
Quote from: common_sense
IF THIS JACKS UP YOUR SYSTEM ITS NOT MY FAULT, I TESTED IT AND IT WORKED FINE FOR ME.

Here's dingoo_a320_rndis.inf:
Code: [Select]
; dingoo_a320_rndis.inf:                     
; Remote NDIS for Dingoo A320 USB.
; Copyright (c) Microsoft Corporation
; Modified by Morgan ``Indrora'' Gangwere on Nov. 12 2010
;


[Version]
Signature           = "$Windows NT$"
Class               = Net
ClassGUID           = {4d36e972-e325-11ce-bfc1-08002be10318}
Provider            = %Microsoft%
DriverVer=06/21/2006,6.1.7600.16385
;CatalogFile        = device.cat

[Manufacturer]
%Dingoo%         = RndisDevices,NTx86,NTamd64,NTia64

; Decoration for x86 architecture
[RndisDevices.NTx86]
; Explicitly handle this one device.
%RndisDevice%    = RNDIS.NT.6.0, USB\VID_0525&PID_A4A2&REV_0223


; Decoration for x64 architecture
[RndisDevices.NTamd64]
; Explicitly handle this one device.
%RndisDevice%    = RNDIS.NT.6.0, USB\VID_0525&PID_A4A2&REV_0223

; Decoration for ia64 architecture
[RndisDevices.NTia64]
; Explicitly handle this one device.
%RndisDevice%    = RNDIS.NT.6.0, USB\VID_0525&PID_A4A2&REV_0223

;@@@ This is the common setting for setup
[ControlFlags]
ExcludeFromSelect=*

; DDInstall section
; References the in-build Netrndis.inf
[RNDIS.NT.6.0]
Characteristics = 0x84   ; NCF_PHYSICAL + NCF_HAS_UI
BusType         = 15
; NEVER REMOVE THE FOLLOWING REFERENCE FOR NETRNDIS.INF
include            = netrndis.inf
needs              = usbrndis6.ndi
*IfType            = 6    ; IF_TYPE_ETHERNET_CSMACD.
*MediaType         = 0   ; NdisMediumNative802_3
*PhysicalMediaType = 14   ; NdisPhysicalMedium802_3

; DDInstal.Services section
[RNDIS.NT.6.0.Services]
include     = netrndis.inf
needs       = usbrndis6.ndi.Services

; No sys copyfiles - the sys files are already in-build
; (part of the operating system).

; Modify these strings for your device as needed.
[Strings]
Microsoft             = "Microsoft Corporation"
RndisDevice           = "A320 Dingux rNDIS"
Dingoo                = "Dingoo Digital CN"


Changes to the original rNDIS driver list:
  • Removed the "Vista Option" items. Not needed.
  • Dingoo should come up in the "manufacturer" listing. I don't know if it will all that well.
  • Exact USB specifier used -- This will always match the Dingoo (theoretically, if it doesn't share a USB Vendor/Device ID!)
    (the above makes Windows always load it and play nice)

if it tells you that this isn't the right driver for your device then your device has a different USB ID. Right click the device in the device manager look under properties->2nd tab for "USB\VID_NNN&PID_NNN" -- Copy-paste that into all 3 places.

Also, cool part of this is that it *should* work on WinXP and above without hassle

adrianomm

  • Guest
Re: intro and some
« Reply #7 on: December 31, 2010, 03:42:23 am »
That works, the first time. From the second on windows gives me a message "device could not be started".

If I install another driver and install your custom driver again, Dingux rndis start to work again. If I boot dingux or disconnect the device, the driver could not be started again and never works.

Does anybody have any idea on how to fix it?

 

Post a new topic
Post a new topic