Author Topic: ILI9338 dual boot problem  (Read 2828 times)

JackSparrow (OP)

  • Posts: 3
ILI9338 dual boot problem
« on: October 09, 2012, 01:14:36 pm »
Hi folks.  Just got my dingoo after a month of waiting on dx and I am having trouble flashing to dual boot.  Followed the Idiots' Guide, but the dingoo did nothing.  No confirmation screen, nawt.  Legacy still boots, but with graphics glitches- missing words, etc.  Attached is a jpg screencap of the cmd window I used/got.  Any ideas?  Help would be much appreciated. 
  Jack
My Invisible Friend Is Armed.

yoshi41

  • *
  • Posts: 467
Re: ILI9338 dual boot problem
« Reply #1 on: October 09, 2012, 05:00:38 pm »
I had problems with the original USB cable. Might be worth to try another one.

If you plan to install Dingux, make sure you have the latest files...

http://boards.dingoonity.org/dingux-help/dingux-installation-help-with-ili9338-on-win7-x64/msg41801/#msg41801
Emulator packs and fact sheets for Wiz, Caanoo, Dingoo and Pandora.

RetroChiGuy1212

  • *
  • Posts: 38
Re: ILI9338 dual boot problem
« Reply #2 on: October 10, 2012, 08:59:55 pm »
I went through the same issue back in July since my Dingoo was an ILI9338 from DX.

This link really helped me a lot:

https://www.youtube.com/watch?v=89gRknU9Djs

I couldn't get it to work with windows 7, but i have a laptop that's XP.  When I used my laptop, I didn't have any trouble.

I hope this helps a bit.

JackSparrow (OP)

  • Posts: 3
Re: ILI9338 dual boot problem
« Reply #3 on: October 11, 2012, 06:21:49 am »
Tried again using the latest gear, but no joy.  Everything else works-  I can read/write the device from my XP netbook, etc.  It's recognised by my device manager as a JZ4740 usb boot device (Rockbox usb tool).  Whatever that is.  MS-speak for Dingoo, I suspect.  Only issue is "sent data isn't the same as received data..." and, of course, the cmd window says now booting and the dingoo doesn't boot.  Or change in any way.  It does, however, get incrementially more annoying each time...  I assume the data cable is okay based on the fact that it works as a data storage device fine.  Any ideas?  Am I doing something stupid?  Does, for example, the usb card need to be in/out?  Should it have a zImage on it before I try all this?  Am I holding my tongue right?   Grr.  Still, I bought the thing to be challenged and entertained, and it's certainly doing that...
My Invisible Friend Is Armed.

yoshi41

  • *
  • Posts: 467
Re: ILI9338 dual boot problem
« Reply #4 on: October 11, 2012, 07:24:47 am »
The USB cable is really crap. Try another one.
Emulator packs and fact sheets for Wiz, Caanoo, Dingoo and Pandora.

JackSparrow (OP)

  • Posts: 3
Re: ILI9338 dual boot problem
« Reply #5 on: October 11, 2012, 11:07:20 am »
I got it!  Simple, really- just a bit random.  All other efforts aside, turned out I had to hold 'B' whilst plugging in the usb cable while already in usb mode.  Only got it by accident-  I unplugged and replugged the dingoo thinking I had another plug altogether.  So- seems resetting while holding 'B' while the device is being detected by windoze got around whatever the heck was the issue.  I've tested this several times now and the results are repeatable.  Failure when 'B' reset to usb mode unplugged, failure when 'B' reset plugged, success when holding 'B' in usb mode and plugging in.  Odd.  Thanks for the helpful suggestions, though-  I probably wouldn't have persevered without the comment about the cable being dodgy.  I was testing another device's cable when I unplugged the dingoo accidentally.  Maybe the original cable has a fault, maybe not- but this worked for me with the stock cable so I am happy.  Now- opendingux beckons...
My Invisible Friend Is Armed.

 

Post a new topic
Post a new topic