Author Topic: PC Engine / TG16 / Turbo Grafx emulator HuGo for Native - based on Dingux-Hu-Go  (Read 49692 times)

clach04 (OP)

  • *
  • Posts: 256
Dingux Hu-Go for Native.



Downloads from https://bitbucket.org/clach04/dingoo_hugo/downloads?highlight=19169

Basically a native version of http://boards.dingoonity.org/dingoonity-news/tailtale-v0-1-for-dingux/.

WARNING this will overclock by default to 400Mhz
WARNING this build will hang unless you have a rom called default.pce in the same directory as the .app, Hugo now includes a free PD rom, Chris Covell 's Screen Dimension Test http://pdroms.de/files/1079/, to avoid this problem

INSTALLATION

Unzip the zip file, into:

    A:\Game\3D Games\

this should mean a directory is created called:

    A:\Game\3D Games\DingooHuGo

Containing; hugo_dingoo.app

It should behave just like the Dingux version (with a minor change with the position of rom names in the menu). See the help file (which is viewable in the Emu). Use the START button in the ROM browser to bring up keyboard to enable jumping to ROMS beginning with a specific letter.

Finally, I can play Bomberman  8)

[edit1: hang problem with default.pce documented]
[edit2: new download same binary, includes a default.pce]
[edit3: new download same binary, includes a working default.pce]
« Last Edit: January 12, 2011, 02:10:54 am by clach04 »

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
Great, downloading now. Very excited to try this. The only other alternative for PC Engine on native is DOOEngine, and whilst good with some games it struggles with many others.

Thanks for this. :)

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
Not having much luck. Upon launching the .APP file I see a brief HuGo splash screen, screen turns black and Dingoo freezes. :'(

clach04 (OP)

  • *
  • Posts: 256
Not having much luck. Upon launching the .APP file I see a brief HuGo splash screen, screen turns black and Dingoo freezes. :'(

Make sure you extracted to the directory I specified in the post/help file. This _may_ be one cause.

Check in the directory where .app file is for a "debugout.txt" file, this is a (Unix style newline) text file that may contain some useful debug output.

Right now this file ALWAYS gets created/appended too for situations like these :-)

Can you confirm which type of Dingoo you have? It shouldn't make a difference but just in case it is worth recording that now.

Chris

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
Thanks for the reply.

Yes, installed to the path as specified:
Quote
A:\Game\3D Games\DingooHuGo

debugout.tx
Code: [Select]
stdout for hugo
--[ INITIALISATION ]--------------------------------

I have a Dingoo Digital A320 - ILI9331 LCD.

samir

  • *
  • Posts: 344
Not having much luck. Upon launching the .APP file I see a brief HuGo splash screen, screen turns black and Dingoo freezes. :'(

I have the same problem  :-[ My screen is a 9331, Black Dingoo.

clach04 (OP)

  • *
  • Posts: 256
That is worrisome, it indicates the emulation engine hasn't started yet (the PCE hasn't been reset yet).

How high can you clock your dingoo? It starts off at 400. I can probably do a build that starts at 330.

segakiki

  • *
  • Posts: 88
I have the same error my dingoo is a ILI9325 version, and can overclock to 410mhz

clach04 (OP)

  • *
  • Posts: 256
The good news is that I have a LCM_FAIR_ILI9331_3 so I think we can rule that out. I'm looking into this.

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
My Dingoo can go up to 420Mhz without any stability issues.

I did think that it might be the overclocking that's causing the freeze. Would it be much trouble to add an option for overclocking within the application, this way we could specify an overclocking rate.

For now, I suppose the best bet would be to release a 330 build and see if that works.

I deleted the other PCE.SIM (DOOEngine) file I had and made sure there were .PCE roms in the roms folder, still no luck. I even tried putting the 'DingooHuGo' folder in different directories, no joy.
« Last Edit: January 09, 2011, 11:45:04 pm by Frank_fjs »

clach04 (OP)

  • *
  • Posts: 256
More good news, I've reproduced the problem on my machine. What this space :)

clach04 (OP)

  • *
  • Posts: 256
Would it be much trouble to add an option for overclocking within the application, this way we could specify an overclocking rate.

That is what this and OhBoy does :)

samir

  • *
  • Posts: 344
The good news is that I have a LCM_FAIR_ILI9331_3 so I think we can rule that out. I'm looking into this.

That is exactly my Dingoo Screen, LCM_FAIR_ILI9331_3.

clach04 (OP)

  • *
  • Posts: 256
Ok, place a rom called default.pce in the same directory as the .app, problem solved (as a workaround...). This is one of those behaviors of the Dingux version I forgot about  ::)

Sorry about that!

I'll try and include a free PD game, can anyone recommend a good one (ideally small) that I can use?

This is also a good way to load your favorite/favourite game without messing with browsing.

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
Yep, that got it working! Thanks! Off to play now...  ;D

Frank_fjs

  • **
  • Posts: 705
    • My simple Dingoo web site
Just noticed there is a clock frequency setting in the settings menu... it appears to be working too.

samir

  • *
  • Posts: 344
Yes!! Problem fixed, i tested one of my favourite PCE games, New Adventure Isldan, and works perfect! Thanks man!

Harteex

  • * Administrator
  • Posts: 709
    • Harteex Productions
Nice work :)

Saving doesn't seem to work for me though. "Can't save file".

A few other smaller things:
* Would be nice to not overclock by default and leave this to the user imo
* When browsing menus, especially load rom, it's very sensitive. If you press A it might jump two directories at once.

clach04 (OP)

  • *
  • Posts: 256
Yes!! Problem fixed, i tested one of my favourite PCE games, New Adventure Isldan, and works perfect! Thanks man!

Great, thanks for the bug reports to both you and frank_fjs, hopefully we can avoid this problem for other people if I include a PD rom.

Any suggestions/recommendations?

samir

  • *
  • Posts: 344
I cant run a .iso file (Castlevania), but I can run this in the Dingux version, any suggestion, clach?