Author Topic: New OhBoy release for native  (Read 59837 times)

jakten

  • *
  • Posts: 5
Re: New OhBoy release for native
« Reply #150 on: December 28, 2014, 09:23:33 am »
When I select "apply & save" in the settings menus after changing the volume it freezes the dingoo, does anyone know how to fix this?

I was also wondering if there was a way to use "start and select together" to open the main menu?

Edit: Sorry I'm dumb, I figured it out.
« Last Edit: December 28, 2014, 10:27:55 am by jakten »

wy_scorpio

  • *
  • Posts: 368
Re: New OhBoy release for native
« Reply #151 on: April 18, 2015, 12:46:29 pm »
I was using backslashes for the hardcoded save dir path, which used to work with no problem. But for some reason, they do not work anymore. I corrected the issue and now savestates and SRAM saves are working properly:

https://app.box.com/s/uxt1sd2e361xy03y09hv

Oh, there are some changes in the menu structure, i added a new option and i felt the settings menu was too crowded, so now there are "Main" and "Video" settings, and the config is split into 2 different files. This means you may have to go into each "main" and "video" settings menu and save the settings once in each one for the files to be created.

Enjoy!
i cant open the link...if can release this emu to http://dl.openhandhelds.org/cgi-bin/dingoo.cgi thx :)

streeker

Re: New OhBoy release for native
« Reply #152 on: November 27, 2016, 06:52:46 pm »
Hi!
I have problems with the OhBoy, please help.
When loading Game and Watch Gallery 3.gbc rom it is colorless. But if i first load a GB rom (for example Super Mario Land), and after that i load the G&W gbc rom, it turns to colored.

My settings:
mono palette: super gameboy.pal
filter type: 75%
upscaler:Ayla fullscreen
frameskip: off

I've had the same/similar problems with GBC ROMs. For example, some color-only games being detected as "inserted into a B/W GameBoy" and therefore not working in the latest 'OhBoy' version. But today I've discorvered a workaround for this strange behavior. Thought, it would be worth sharing:

All you have to do is zip your GBC ROMs (each game goes into a seperate archive) an afterwards rename the .zip-files to ".gbc". The last step is optional. But, by doing so, the zipped ROMs will still be selectable directly from the native file system. :)

hi-ban

  • **
  • Posts: 825
Re: New OhBoy release for native
« Reply #153 on: December 13, 2016, 01:12:59 am »
Hi!
I have problems with the OhBoy, please help.
When loading Game and Watch Gallery 3.gbc rom it is colorless. But if i first load a GB rom (for example Super Mario Land), and after that i load the G&W gbc rom, it turns to colored.

My settings:
mono palette: super gameboy.pal
filter type: 75%
upscaler:Ayla fullscreen
frameskip: off

I've had the same/similar problems with GBC ROMs. For example, some color-only games being detected as "inserted into a B/W GameBoy" and therefore not working in the latest 'OhBoy' version. But today I've discorvered a workaround for this strange behavior. Thought, it would be worth sharing:

All you have to do is zip your GBC ROMs (each game goes into a seperate archive) an afterwards rename the .zip-files to ".gbc". The last step is optional. But, by doing so, the zipped ROMs will still be selectable directly from the native file system. :)

Check the options, you should have "Main Settings > System > Auto / Auto, GBA Enhanced*" (both "auto" options are valid)
The "Force DMG mode" option will make the emulator think it's a B/W gameboy, so you'll have problems with many GBC titles if this option is selected.
« Last Edit: December 13, 2016, 01:21:31 am by hi-ban »

streeker

Re: New OhBoy release for native
« Reply #154 on: December 13, 2016, 09:50:57 pm »
Sure, but that's not it. For instance, I try to load a game like "Alfred's Adventure" from the native file system. It's gonna give me the "this game is for GB Color only" message. So, if I check the settings from there... "System=Auto" is selected, but it doesn't work.

Sometimes it will work, if I then switch to another system option / and back and reload the ROM file afterwards - but not initially. Or, like I said, if I put the ROM inside a ZIP file and rename it to GBC as a workaround. Strange behavior, I know... (and I haven't experienced this in previous versions of OhBoy, by the way)  ???
« Last Edit: December 13, 2016, 11:46:39 pm by streeker »