Author Topic: New OhBoy release for native  (Read 67316 times)

hi-ban

  • **
  • Posts: 852
Re: New OhBoy release for native
« Reply #140 on: September 14, 2014, 03:10:07 am »
i managed to reproduce that behaviour once. But then, after changing settings and taking out the miniSD and putting it again in, it started working in color mode. I will have to take a look at the modes of the emulator, but maybe it gives priority to monochrome mode.

Did it happen with previous versions of Ohboy?
« Last Edit: September 14, 2014, 01:34:07 pm by hi-ban »

miroli

  • *
  • Posts: 107
Re: New OhBoy release for native
« Reply #141 on: September 14, 2014, 02:00:57 pm »
i managed to reproduce that behaviour once. But then, after changing settings and taking out the miniSD and putting it again in, it started working in color mode. I will have to take a look at the modes of the emulator, but maybe it gives priority to monochrome mode.

Did it happen with previous versions of Ohboy?

I don't know, i didn't try it yet.


RetroChiGuy1212

  • *
  • Posts: 43
Re: New OhBoy release for native
« Reply #142 on: September 17, 2014, 01:40:46 am »
The file was unzipped to the root directory.  I deleted the other GameBoy emulator.  I loaded up OhBoy and the SuperGameBoy function works great.  However, I cannot save via quick save or SRAM.  The files are all where they're supposed to be, but it just doesn't save.  Besides that, it looks great!

Any suggestions on how to get it to save?  Thanks!
« Last Edit: September 17, 2014, 04:46:06 pm by chiguy1212 »

chevette

  • *
  • Posts: 191
Re: New OhBoy release for native
« Reply #143 on: September 17, 2014, 10:45:33 pm »
Have the same problem......Save States are not working.

hi-ban

  • **
  • Posts: 852
Re: New OhBoy release for native
« Reply #144 on: September 19, 2014, 12:12:07 am »
I was using backslashes for the hardcoded save dir path, which used to work with no problem. But for some reason, they do not work anymore. I corrected the issue and now savestates and SRAM saves are working properly:

https://app.box.com/s/uxt1sd2e361xy03y09hv

Oh, there are some changes in the menu structure, i added a new option and i felt the settings menu was too crowded, so now there are "Main" and "Video" settings, and the config is split into 2 different files. This means you may have to go into each "main" and "video" settings menu and save the settings once in each one for the files to be created.

Enjoy!

RetroChiGuy1212

  • *
  • Posts: 43
Re: New OhBoy release for native
« Reply #145 on: September 19, 2014, 02:27:59 pm »
Wow, the emulator works great now!  Hi-ban, this is the best Game Boy emulator for the A320.  It looks great, it works great AND the SuperGameBoy function works!

Thank you so much for taking the time and effort to make and distribute this.  ;D

hi-ban

  • **
  • Posts: 852
Re: New OhBoy release for native
« Reply #146 on: September 19, 2014, 02:35:48 pm »
RetroChiGuy, there is no SuperGameBoy support in Ohboy. There are included palettes and borders which can emulate that, but there is no real SuperGameBoy functionality in Ohboy.

RetroChiGuy1212

  • *
  • Posts: 43
Re: New OhBoy release for native
« Reply #147 on: September 19, 2014, 02:50:55 pm »
My apologizes, I meant in terms of color emulations because of the palettes, not the emulation of the functionality.  Either way, it's still an awesome emulator.

chevette

  • *
  • Posts: 191
Re: New OhBoy release for native
« Reply #148 on: September 19, 2014, 11:19:27 pm »
Save States are now working!!!
Thanks so much hi-ban

wy_scorpio

  • *
  • Posts: 368
Re: New OhBoy release for native
« Reply #149 on: November 15, 2014, 08:01:52 am »
I was using backslashes for the hardcoded save dir path, which used to work with no problem. But for some reason, they do not work anymore. I corrected the issue and now savestates and SRAM saves are working properly:

https://app.box.com/s/uxt1sd2e361xy03y09hv

Oh, there are some changes in the menu structure, i added a new option and i felt the settings menu was too crowded, so now there are "Main" and "Video" settings, and the config is split into 2 different files. This means you may have to go into each "main" and "video" settings menu and save the settings once in each one for the files to be created.

Enjoy!

great!thx for new release 8)

by the way,if you can make one app for dingoo native?
the app have below function:
1.adjust Brightness
native brightness only adjust from 1 to 5,if can make Brightness lower and lower to pretect eyes and save power.
2.adjust color temperature
addjust color temperature: warm, normal,cool
set to warm will pretect eyes

thx,  ;)

jakten

  • *
  • Posts: 5
Re: New OhBoy release for native
« Reply #150 on: December 28, 2014, 09:23:33 am »
When I select "apply & save" in the settings menus after changing the volume it freezes the dingoo, does anyone know how to fix this?

I was also wondering if there was a way to use "start and select together" to open the main menu?

Edit: Sorry I'm dumb, I figured it out.
« Last Edit: December 28, 2014, 10:27:55 am by jakten »

wy_scorpio

  • *
  • Posts: 368
Re: New OhBoy release for native
« Reply #151 on: April 18, 2015, 12:46:29 pm »
I was using backslashes for the hardcoded save dir path, which used to work with no problem. But for some reason, they do not work anymore. I corrected the issue and now savestates and SRAM saves are working properly:

https://app.box.com/s/uxt1sd2e361xy03y09hv

Oh, there are some changes in the menu structure, i added a new option and i felt the settings menu was too crowded, so now there are "Main" and "Video" settings, and the config is split into 2 different files. This means you may have to go into each "main" and "video" settings menu and save the settings once in each one for the files to be created.

Enjoy!
i cant open the link...if can release this emu to http://dl.openhandhelds.org/cgi-bin/dingoo.cgi thx :)

streeker

  • *
  • Posts: 7
Re: New OhBoy release for native
« Reply #152 on: November 27, 2016, 06:52:46 pm »
Hi!
I have problems with the OhBoy, please help.
When loading Game and Watch Gallery 3.gbc rom it is colorless. But if i first load a GB rom (for example Super Mario Land), and after that i load the G&W gbc rom, it turns to colored.

My settings:
mono palette: super gameboy.pal
filter type: 75%
upscaler:Ayla fullscreen
frameskip: off

I've had the same/similar problems with GBC ROMs. For example, some color-only games being detected as "inserted into a B/W GameBoy" and therefore not working in the latest 'OhBoy' version. But today I've discorvered a workaround for this strange behavior. Thought, it would be worth sharing:

All you have to do is zip your GBC ROMs (each game goes into a seperate archive) an afterwards rename the .zip-files to ".gbc". The last step is optional. But, by doing so, the zipped ROMs will still be selectable directly from the native file system. :)

hi-ban

  • **
  • Posts: 852
Re: New OhBoy release for native
« Reply #153 on: December 13, 2016, 01:12:59 am »
Hi!
I have problems with the OhBoy, please help.
When loading Game and Watch Gallery 3.gbc rom it is colorless. But if i first load a GB rom (for example Super Mario Land), and after that i load the G&W gbc rom, it turns to colored.

My settings:
mono palette: super gameboy.pal
filter type: 75%
upscaler:Ayla fullscreen
frameskip: off

I've had the same/similar problems with GBC ROMs. For example, some color-only games being detected as "inserted into a B/W GameBoy" and therefore not working in the latest 'OhBoy' version. But today I've discorvered a workaround for this strange behavior. Thought, it would be worth sharing:

All you have to do is zip your GBC ROMs (each game goes into a seperate archive) an afterwards rename the .zip-files to ".gbc". The last step is optional. But, by doing so, the zipped ROMs will still be selectable directly from the native file system. :)

Check the options, you should have "Main Settings > System > Auto / Auto, GBA Enhanced*" (both "auto" options are valid)
The "Force DMG mode" option will make the emulator think it's a B/W gameboy, so you'll have problems with many GBC titles if this option is selected.
« Last Edit: December 13, 2016, 01:21:31 am by hi-ban »

streeker

  • *
  • Posts: 7
Re: New OhBoy release for native
« Reply #154 on: December 13, 2016, 09:50:57 pm »
Sure, but that's not it. For instance, I try to load a game like "Alfred's Adventure" from the native file system. It's gonna give me the "this game is for GB Color only" message. So, if I check the settings from there... "System=Auto" is selected, but it doesn't work.

Sometimes it will work, if I then switch to another system option / and back and reload the ROM file afterwards - but not initially. Or, like I said, if I put the ROM inside a ZIP file and rename it to GBC as a workaround. Strange behavior, I know... (and I haven't experienced this in previous versions of OhBoy, by the way)  ???
« Last Edit: December 13, 2016, 11:46:39 pm by streeker »

 

Post a new topic