Author Topic: Main menu hangs when I try to navigate - A320  (Read 6488 times)

mrduke (OP)

  • Posts: 2
Main menu hangs when I try to navigate - A320
« on: June 06, 2011, 12:16:09 pm »
Hello everybody.
My Dingoo A320 started freezing when I wanted to start it after loading the battery after I didn't use it for 2 weeks or so.
After some resets and un-/plugging it to the pc or recharger the situation changed to the following:
I start it, come to the main menu, everything looks okay, the cursor flashes
I can choose "3D" and navigate and run the programms there, though there are some graphical glitches (dotted line) like this in the menu:
Which also appers in the title screen later:
But a bigger problem is, that the Dingoo freezes when I want to move from 3D to "Interesting games" or to the music player. The animation of the cursor stops.
If I press really fast down, then A, I can reach "Interesting Games", but usually it hangs.

It has dual boot, and I also flashed it again one hour ago, without a result.

Does anybody know some advice?

Thanks & Ciao, mrduke
« Last Edit: June 06, 2011, 12:32:04 pm by mrduke »


  • Posts: 19
Re: Main menu hangs when I try to navigate - A320
« Reply #1 on: May 12, 2012, 12:02:35 am »
Same problem I'm encountering now.  This is clearly not an isolated problem.


  • Posts: 139
Re: Main menu hangs when I try to navigate - A320
« Reply #2 on: August 06, 2012, 01:19:14 am »
I have the same problem. I was using Open Dingux and rebootet into the normal firmware and now the Dingoo freezes when I want to select something. The only thing working is the system menue.

I have had opened the internal sd with the file browser under OD. Maybe the filesystem is now corrupted? How can I format my Dingoo? I would like to give this a try.

Edit: I have installed a new native firmware but this doesn't help. I puted the firmware into the root directory and holded the down button while booting. I guess sth is wrong with the internal storage. Everytime I try to access (read or write) internal storage, the system freezes. Do I have to use the unbricker  tool to wipe everything? I guess it is windows only, not for linux?

Edit2: I just formated the internal storage the hard way (gparted) And all seemed to work fine. I used an old backup and I could go into the games again. But the GAMES folder is corrupted and a lot of strange letters when I look into the directory. I can't acces the Dingoo now, because it always switches into the usb-mode when connecting to my machine. And then the filesystem is read only :(

Ok, I managed to connect my Dingoo under Windows and finally my Dingoo works now.

This is what I did: I erased everything from the internal storage. Then I copied a fresh SYSTEM folder, which I found here in the forums, onto the Dingoo. After that I disconnected the Dingoo and turned it on. I went to "Update Jukebox". The other folders are created then. Now I connected my Dingoo to my computer again and copied my games and .sim files.

I tested OD again and opend the internal storage with the file browser. But the native firmware stil works. It has nothing to do with it.
« Last Edit: August 06, 2012, 10:59:07 am by schanall »

mrduke (OP)

  • Posts: 2
Re: Main menu hangs when I try to navigate - A320
« Reply #3 on: March 13, 2013, 10:58:41 pm »
Thanks, your post motivated me to try to repair my dingoo again, he is lucky that I am so patient :)
Your hints finally didn't help me, though I found out that I made some mistakes. I found another "a320 recovery tool complete" archive, with a more detailed readme. this:
For example I didn't run the unbrick tool as admin...

Everything seemed fine, I installed the emulators and games again, unplugged it, the update progress bar appeared, though without animated bar. There were the graphical glitches in the menu again, but the menu didn't hang.
BUT, when I reset the dingoo it froze at boot screen. When I reset it with usb plugged in, and then unplugged it, I came to the main menu. This sucked. Same was with some other "Flash files" I found on the internet. 

I thought I could still use it with dingux and dualboot. My old mini-sd card seemed corrupt, so I bought a micro-mini-sd adapter. I installed dualboot and opendingux and everything. Seemed to work. But it also started to freeze, at first because of some emulators, which didn't work. Then it didn't start complete. I tried several new dingoo-flash, sd-card-format, copy-everything attempts, also with another card, but always with the same result
I powered it on with select pressed. I reached the opendingux boot screen. After some seconds the Dingoo restarted. When I pressed start to see the console putput the messages were like I have no sd-card inserted.

Funny thing is, I discovered that the boot-up to the default Dingoo system now works again (though it also freezes when I want to access the sd card in the dingoo file navigation).
Maybe it works now because of the dual boot loader. I don't know and I'm curious which strange behaviour the dingoo will show next :)

If I remove the SD card, the Dingoo freezes at the second paw boot screen... with card inserted, it boots :) :'( :o :P :-*
« Last Edit: March 13, 2013, 11:11:59 pm by mrduke »


Post a new topic