Author Topic: Direction button trouble Dingoo A320 with ILI9338 screen  (Read 3094 times)

RetroChiGuy1212 (OP)

  • *
  • Posts: 43
Direction button trouble Dingoo A320 with ILI9338 screen
« on: August 01, 2012, 07:26:12 pm »
Hello,

I just received my second a320 and this time it has an ILI9338 screen.  I know all about the contrast issue and I've used the fix for OpenDingux and it works perfectly, but I've run into a problem that I'm not finding much other information about. 

When using the Atari 800/5200 emulators for either the Native OS or for OpenDingux, I try to use the onscreen keyboard, but I can't reach the corner buttons. I can only highlight the top, bottom, left and right selections, but not the corners, so it makes it difficult to start some games.  I have a dingoo with the ILI9331 screen and it can reach those problems without an issue, but with the ILI9338 it doesn't work.  Is there something that I'm missing, or is this just how the ILI9338 dingoo is?

Thanks in advance for your help!!

RetroChiGuy1212 (OP)

  • *
  • Posts: 43
Re: Direction button trouble Dingoo A320 with ILI9338 screen
« Reply #1 on: August 03, 2012, 03:04:40 pm »
So......suddenly things are different.  At first, whenever I tried to use the onscreen keyboard for the Atari 800/5200 emulator on either Native OS or OpenDingux, the highlighted selection would be red and I couldn't reach the corner letters.

However, last night, while attempting to play an Amiga game, I was testing to see if I could make the mouse pointer travel diagonally.  At first, it wasn't working. I had to press left then down left then down left then down.  I was  a bit disappointed with this situation.  Then, I thought, let me press left and down at the same time like I tried before, but this time, let me put a little more force.    I tried this earlier with the Atari emulator but nothing changed, however, this time, the cursor traveled diagonally. WTF?!?!  It was midnight Central time USA.  Was this real or was I dreaming?  I didn't spin a top like Inception, but I knew I was awake.

So I went into the Atari 800/5200 emulator for both native and opendingux to test the onscreen keyboard.  This time, the highlighted selection wasn't red, it was black AND I was able to get to the corners.  I was still disappointed because in the Native OS, if playing Pitfall for Atari 5200, you have to select lower case "h" in order to start the game.  This works on my black ILI9331 a320.  However, on my white ILI9338, even though I can now select the letters housed in the corner of the onscreen keyboard, I still couldn't start the game. 

It's not sooooooo bad because I can play the Atari 800 version of the game and it pretty much looks the same.  My major concern was the inability to move diagonally.  I don't know what I did to fix it.  I did delete the cfg file for the Atari 800/5200 emulator when I first noticed the inability to reach the corner buttons, but it didn't seem to work.  Then, a day later everything worked. 

For anyone out there in the Dingoonity community that is still reading this, I think that the ILI9338 dingoo is just a moody device.  It's a bit disappointing that they aren't making an ILI9331 version anymore, but I guess with all the new droid devices coming out, the manufacturer isn't concerned with older products when they're looking to make money in the current market, which we can't really blame them for.  Either way, the Dingoonity community rocks!  I'm really happy I stumbled upon this little device on thinkgeek.com and had a girlfriend willing to buy it for me for my birthday.

 

Post a new topic