Dingoo Official Firmware => Help => Topic started by: slaanesh on May 21, 2020, 11:46:37 am

Title: Dingoo A320 on Windows 7
Post by: slaanesh on May 21, 2020, 11:46:37 am
I recently re-installed my computer(s) and now running Windows 7 from VMWare but I can't access my Dingoo A320 anymore for DEV... the only way I can get files to it is via mini-SD card which is so slow and painful.

I've tried the hold <B> button and boot into jz4740 USB Boot device mode but the drivers just won't... update? Windows keeps saying I've got the latest drivers. So I think my driver's I'm using are prehistoric or something :)

Where can I get latest Windows 7 Dingoo A320 drivers?

So I tested it on my old computer, and I'm sure I never installed any driver on it. Indeed it's just using system32\drivers\usbstor.sys and works fine.
When I plug it into my VMWare version Win7 box, it just tries to use the same driver but sits there for a minute and then eventually and silently fails. The Mass Storage entry for it in Device Manager turns into a little yellow exclamation mark icon.

I'm guessing it's something to do with VMWare perhaps... My old PC was USB2.0 only and this one is USB3.0. I can set USB under VMWare to be 1.0, 2.0 or 3.0 but doesn't seem to make any difference with the same result.

I used to love just plugging it in, copy my files across and done... So quick. I've got another work around, I can mount it on native Mac OS X but it never seems to eject correctly from there.

Any ideas?

Title: Re: Dingoo A320 on Windows 7
Post by: slaanesh on May 26, 2020, 02:30:30 am
So I've tried a second Dingoo A320, in case the first one was bad... which it isn't, but just in case.
Different cables... nothing really works. It's frustrating as it worked fine on my old Mac running bootcamp but on my new Mac with VMWare it just doesn't want to mount. :(

I also have a Gemei A330 which doesn't mount at all on anything! I can't remember if it used to now, perhaps I just used the SD card directly, anyway it seems like a similar issue.

So I tried something else.
I downloaded the dual boot dingux drivers in the hope of using these drivers... These actually seem to install however they are unsigned, so Windows 7 is refusing to use them. There are apparently ways around this... using unsigned drivers by pressing F8 and disable signed drivers from the boot menu. Whilst this did allow the jz4740 usb boot drivers to be used (if you hold 'B' button and connect the A320) it still doesn't work in normal "mass storage" mode when you plug in the USB cable normally.
Title: Re: Dingoo A320 on Windows 7
Post by: slaanesh on August 08, 2020, 03:38:42 am
Turns out there is an issue with VMWare 11.5.5, which is what I was using originally.

The VMWare 11.5.6 (https://docs.vmware.com/en/VMware-Fusion/11.5.0/rn/VMware-Fusion-1156-Release-Notes.html) update supposedly fixes issues with USB Mass Storage devices.
Title: Re: Dingoo A320 on Windows 7
Post by: slaanesh on August 09, 2020, 02:05:58 am
Though it's still not entirely fixed under Windows.

Why is it so hard to connect my A320 to a VMWare Windows host?