Author Topic: Beloved 1st Gen a320 died for no reason, please help  (Read 164 times)

samc36 (OP)

Beloved 1st Gen a320 died for no reason, please help
« on: August 17, 2017, 12:29:15 am »
I'm on my second original dingoo a320, the screen shattered years ago on the first one and I've had this one for a few years. I've had it in storage in a Gameboy style hard shell case for the past 4-5 months.

I took it out wanting to use it anyway and it had a little bit of charge in it. When I turned it on though, I saw that the screen had two vertical lines of stuck white pixels to the right hand side. I was distraught, but though maybe the stuck pixel gba room would fix it or something, so was trying to put that on when it flashed a low battery warning and shut off.

I thought nothing of it, but then it wouldn't charge, connect to my PC, or turn on. I've opened it up and can't see anything disconnected.

Can anyone help, or any ideas? Kinda stuck because I can't get parts or just order a replacement. Is my battery dead? How can I test this or fix it?

Should also mention, I had the over clocking app in native dingoo firmware, although not sure if I set it. Also had dingux dualboot installed.

Any help is greatly appreciated.

slaanesh

  • *
  • Posts: 437
    • Slaanesh Dev
Re: Beloved 1st Gen a320 died for no reason, please help
« Reply #1 on: September 08, 2017, 02:03:25 am »
Perhaps the battery is dead, that happens.

What you could do is try connect your A320 to a power-only USB cable (ie. plugged into a USB charger - like an iPhone or Android dedicated charger).

Then try turning it on and see what happens.

 

Post a new topic
Post a new topic