• HomeBoards
  • RulesRules
  • HelpHelp
  • WikiWiki
  • Donate

Author Topic: Dingoo A330 stuck on starting screen  (Read 4651 times)

Gorillafunk (OP)

  • Posts: 9
Dingoo A330 stuck on starting screen
« on: December 29, 2016, 10:27:45 am »
Hi there,

First of all, I just want to say this is a great website. I've got a lot of help in setting up my Dingoo just by looking at these forums.

Now to my current problem - I have a Dingoo A330 with the standard system setup. All I've done is download some ROMS and emulators that work on the native system (eg, Master System, PC Engine, Game Gear etc)

Last night I was charging my Dingoo and thought I would just knock another level or two off Kirby's Nightmare in Dreamland  :) Anyway, I played it for about 15 minutes while the charger was plugged into the power socket and then put it down for a few minutes. I didn't seem to have any issues at the time, but now I am having a few problems:
- The main problem is that when I turn on the Dingoo, it gets stuck at the very first screen (the 'Dingoo Technologies' logo). I don't get any further than that.
- Second issue is that none of my PCs seem to recognise the Dingoo when I connect it via USB. When I go into devices, I can see it there, but it doesn't show up as a drive and there's no way to access the folders. Initially it said the device had malfunctioned, but I don't even get that message anymore.
- The third issue is that while it is on (stuck on the opening screen), I can't turn it off using the usual power button on the side. I can only turn it off by using the reset button, which actually resets it and I end up with the same problem.

Prior to this I haven't really had any problems. I've had a few issues here and there with ejecting from USB ports etc but nothing too bad.

In terms of solutions, I've tried downloading the driver to my computer so that the Dingoo is recognised but haven't been able to achieve that so far, through a combination of me being wary of shifty download websites and me being unable to use the drivers once downloaded.

I've also tried the 'hold B then reset followed by insert USB cable' strategy which I've read about in a few places. This usually results in my PC making a chime sound but nothing actually happening. The Dingoo screen turns black and it basically looks like it has turned off.

Any help would be appreciated.

Gorillafunk (OP)

  • Posts: 9
Re: Dingoo A330 stuck on starting screen
« Reply #1 on: January 03, 2017, 02:50:22 am »
Just bumping the above post in case anyone can assist. I'm going on holidays later this month and was looking forward to taking my Dingoo with me, so it would be really good if I could get some help in the next week or so.

I'd love to be able to keep my save content so I don't have to start games again or redownload everything, but at this stage I'd be happy to just reset my Dingoo back to what it was when I got it (ie a factory reset). I've trawled the internet and can't find how to do this either, it can't be that hard can it? The Dingoo technology website, which is theoretically where all that should be isn't working.

In terms of being able to access the Dingoo via PC, I've googled the drivers and have tried to download, but haven't been able to get them. Most of the time, the website says they have that driver, so I click download. Instead of downloading the driver, it downloads a 'driver manager' which proceeds to search for missing drivers, but never seems to identify that I need one for my Dingoo. But, that said I never needed a new driver before so am uncertain as to if I need one now.

As I've had trouble turning my Dingoo off, the Dingoo Technology Screen logo is now a little bunt into the screen, but I can't see it unless the screen is off.


  • Posts: 48
Re: Dingoo A330 stuck on starting screen
« Reply #2 on: January 04, 2017, 01:02:47 pm »
Well, the A330 is really problematic for recovery. The black screen when you start up holding B is an indication that the device is waiting for a connection. On the A320 at this point you should use the unbricker tool - driver is included, but I'm not sure it works with newer versions of Windows, or 64-bit windows for that matter. Worst case scenario, you may have to install a compatible version of Windows in a VM to get it working. Once the flasher tool connects and start flashing the device, the screen should light up and show the flashing progress.

However, the biggest problem, and one that you may not be able to get around, is that there's no provided HXF file (which is the firmware image) for the A330 on the unbricker tool, there's one only for the A320. As far as I could tell, I don't think an HXF for the A330 was ever released or leaked...

So, at this point you might as well just try your luck with the A320 HXF file. The A330 is almost the same device as the A320, only with a slightly faster CPU and double the RAM. I'm a bit skeptical it'll work, but if it does you'll be left with a firmware that will not use the full hardware resources. One workaround to that is installing OpenDingux on it, that should make full use of the devices' resources.

Good luck!

EDIT: Ok, just found a link to an A330 HXF file on a youtube video, it links to dingoo.hk which I believe is down, but thanks to the gods of Web Archive, you can get it here: http://web.archive.org/web/20101119105622/http://www.dingoo.hk//bbs//UploadFile//2010-5//A330kongjian.zip

On further reading, however, it seems the A330 firmware is really just a slightly modified A320 that doesn't fully use the A330 hardware capabilities anyway. You might still have better chances with it as opposed to using a straight up A320 firmware, if only because the file was originally hosted by Dingoo Tech and has "A330" in the filename...  :P


I believe that, afterall, your biggest hurdle will actually getting the drivers and the unbrick tool working if you've got a newer version of windows. I'm pretty sure the unbricker driver will only work on no later version than Windows 7 32-bit.
« Last Edit: January 04, 2017, 01:38:59 pm by cronot »

Gorillafunk (OP)

  • Posts: 9
Re: Dingoo A330 stuck on starting screen
« Reply #3 on: January 06, 2017, 09:03:51 am »
Thanks so much! Appreciate all the help - I'm a bit more positive now that I can get this done!

I dug up an old laptop with windows 7 on it and am using that a the moment. Unfortunately, the language isn't in English so I had some educated guesses on what each windows button and field means with the help of Youtube and Google Translate. I've now downloaded the unbricker tool file and the HXF fie and also installed the ChinaChip drivers that came with the unbricker.

From what I can tell from the A320 process (which I assume is the same), I need to hold down B while resetting the Dingoo, then connect the USB. After that I run the unbricker tool exe file on the PC is that correct? How does the unbricker tool interact with the Dingoo? Noting it still doesn't show up as drive on my PC? Am I missing a step? Apologies for the total noob questions.

I'm also not quite sure how to use the HXF file. Is there a 'step by step' process anywhere?


  • Posts: 48
Re: Dingoo A330 stuck on starting screen
« Reply #4 on: January 06, 2017, 03:55:11 pm »
Ok, what follows is a summary on the process, it's been a long time since I did it, so a few details may be different, but it's pretty straightforward, you should have no problems adapting if you find any differences.

I'm assuming here you have some basic knowledge on how to install drivers on Windows, via the Device Manager and such. Please note the instructions below assume Windows with english language. Since you've said the laptop you've got has another language of Windows, you'll have to work it out where to find the elements from Windows I'm referring here. And remember, the driver for the unbricker will not work on Windows 64-bit, only on 32-bit:
  • Unpack the unbricker tool somewhere on your PC. Also unpack the zip with the HXF you'll flash;
  • Run the unbricker tool, which is the executable "hacked-TestVersion.exe". Click the "Install Driver" button, and let it run its course - you'll know when it's done when a dialog saying "Installed!" shows up;
  • Hold down B and reset the dingoo, then connect it to the PC. The Dingoo's screen will stay black / blank, that's normal;
  • The PC should initially detect the device as "JZ4740 USB Boot device", or something like that. It will not show as a removable drive at this point, since it is in recovery mode;
  • Windows will try to hook it up automatically using the drivers installed on step 2. If it can't, you'll have to try installing the drivers manually, so go into the Device Manager, find the broken device there, and try to install / update its driver pointing it to the folder "usb_drv" that's inside the folder where you've unpacked the unbricker tool on step 1;
  • With the driver properly installed, go back to the unbricker tool. On the line saying "Firmware file", click the "Select..." button and select the HXF file you will flash;
  • Click the "Burning System" button. If everything went correctly, the flashing should start and at this point the dingoo's screen should light up and show the flashing progress. Once it finishes, reset the dingoo (if doesn't on its own after flashing finishes) and hope for the best...

Gorillafunk (OP)

  • Posts: 9
Re: Dingoo A330 stuck on starting screen
« Reply #5 on: January 14, 2017, 05:05:04 am »
Thanks to all your help Cronot, I have managed to fix it. Your instructions were excellent and really helped. The only additional point was that I needed to add a file into the System DL field otherwise you get an error message. I tried the A320_PD27 file - it seemed to work on the PC but the Dingoo just had colourful lines. Next I tried using the CCPMP file and that worked. The Dingoo lit up with the Firmware Upgrading screen. This went on for much longer than I was expecting so I eventually unplugged the Dingoo. But on turning it back on I get the Paw Screen, followed by the Lizard then the usual Dingoo A330 menu.

Somewhere in the process it also asked a couple of times if I wanted to format the drive and I said yes (I think I said yes - the message was in Chinese)

Only issue is that all the files are gone, so assume I need to re-download them (which I expected of course). In plugging the Dingoo into our Windows 8 computer, it said there was an error at first. I chose to fix the error and now it can see the drive just fine. All the usual folders are there, just empty.

I can now take my Dingoo overseas and enjoy it, assuming I can get the games working!

Thanks again!


  • Posts: 48
Re: Dingoo A330 stuck on starting screen
« Reply #6 on: January 16, 2017, 03:34:18 pm »
Unfortunately the Dingoo has a bad tendency to frequently corrupt its internal drive that is exposed to Windows, so you can expect the dialog asking to "Fix it" to show up often. That's one of the reasons I don't like using the native OS on the Dingoo, and almost always use OpenDingux instead.

Also - I'm pretty sure that some of the files on the internal memory (the part of it that's exposed to Windows as a removable drive) actually contains the emulators that the device runs, so if you can't see any files when you access it from Windows, then it's possible you won't be able run any games since the system will not be able to run its emulators. I may be wrong about that of course, since it's been a long time I've last reflashed my Dingoo or messed with the files on the internal memory (again, since I mostly use OpenDingux anyway). Just in case I'm right though, download this file and unpack it inside your Dingoo from Windows Explorer. These files are the ones on my own Dingoo, and some of the emulators in there actually are not the ones that are bundled with the device, but are instead third-party ones developed by the community, but trust me, they are miles better than the ones bundled with the Dingoo.

Gorillafunk (OP)

  • Posts: 9
Re: Dingoo A330 stuck on starting screen
« Reply #7 on: January 18, 2017, 02:42:59 am »
Thanks - I do get that error a lot so that explains it. Also it never seems to eject properly from the PC.

But the main thing is that The Dingoo is working fine again now that I've got a few games on it! So very happy. I'll try to replace the emulators I have with those you use - that sounds good.

I'm having problems with some emulators since the refresh. GBA games crash on the loading screen and PC Engine and Master System games crash on the Dingoo menu. They did work previously although there was no save or pause feature for PC Engine and Master System.
« Last Edit: January 18, 2017, 02:47:39 am by Gorillafunk »


  • Posts: 48
Re: Dingoo A330 stuck on starting screen
« Reply #8 on: January 18, 2017, 10:09:01 am »
You can always try flashing other HXF files (e.g. from the A320). I'm actually a bit concerned about what you said of the flashing process getting stuck or something to that effect: did the flashing application on the PC seemed to hang as well with no indication of having finished or only the flashing progress on the dingoo display seemed stuck? If it was the latter, then I'd say that's ok, but if it was also the former, then as far as I remember, that shouldn't be normal (but again, bear in mind I haven't done that in a long time, so I may be wrong).

As for the emulators crashing, on the pack I've linked to there's an improved SMS emulator that may work better and it has save state and pause feature. Can't say about PCE, I don't play games from that one. In fact, you might want to just unpack everything on top of anything you have, because for those emulators that I didn't replace with third-party ones I've kept the original, built-in ones and they are also in the pack - including GBA, which is one of the few emulators that are built-in that actually work pretty well, and it is working here.

You can also always try alternate emulators linked from the wiki or from the openhandhelds archive.
« Last Edit: January 18, 2017, 11:42:24 am by cronot »


Post a new topic